Support

Home Forums MailChimp Integration MailChimp Integration no longer w/ EE 3 because Mailchimp shut down API 1.1 -1.3

MailChimp Integration no longer w/ EE 3 because Mailchimp shut down API 1.1 -1.3

Posted: April 9, 2019 at 5:27 pm


Vitaliti Wellness

April 9, 2019 at 5:27 pm

On my most recent events in Event Espresso version 3.1.37.14.P
WordPress version WP 4.8.9, I stopped seeing the option to add registrants info to a list in Mailchimp. When I went to the MailChimp Integration within Event Espresso, the API key was missing. I copied it from MailChimp and pasted it in and got the following message:

“An error occurred while attempting to connect to the MailChimp server. Error: Mailchimp API versions 1.1, 1.2, and 1.3 are no longer available. For more information see https://mailchi.mp/195471f5dad4/important-information-about-your-integration-219125

If you click on that link, MailChimp says: “On April 2, 2019, Mailchimp shut down API 1.1, 1.2, and 1.3, which caused integrations that connect to Mailchimp through these APIs to stop working as expected. Prior to this change, we emailed affected integrators and users to give them time to update or change their integrations.

However, if you’re now seeing that you are affected by this shutdown, here’s more information on the change and what you can do to resolve the interruption in the functions provided by your integration.

What changed
We no longer allow integrations to use Mailchimp API 1.1, 1.2, or 1.3. To provide some historical context, we stopped supporting these APIs at the start of 2017, and encouraged developers to update their integrations to Mailchimp API 3.0. While we let developers continue to use the older APIs for their integrations, we were no longer comfortable allowing their continued use. As these unsupported APIs aged, we knew there was an increased risk that the integrations could break at any time, which would result in an unexpected interruption in the functions the integration provides to an account.

For this reason, we decided to shut down Mailchimp API 1.1, 1.2, and 1.3, and now require that all integrations be on 2.0 or higher, and preferably 3.0.”

I am trying to update my MailChimp Integration since I have version 1.2. hoping that will fix the problem. (Not sure it will but anyway…)When I logged into my Event Espresso Account, there is an option to download MailChimp Integration version 1.3 but there is no zip file in the download.

When I try to upload the new plugin, it is rejecting all of the files. Also, in the instructions in the Event Espresso documentation for version 3, it says to download the Zip file. Where is the zip file?

Thank you! -Ti

Event Espresso version 3.1.37.14.P
WordPress version WP 4.8.9
Installed plugins
InfiniteWP – Client by Revmakx version 1.8.6,
Gravity Forms by rocketgenius version 2.4.8,
Advanced Database Cleaner by Younes JFR. version 2.0.0,
Cart66 Cloud by Reality66 version 2.2.2,
Check Email by Chris Taylor version 0.5.5,
Chimpy by RightPress version 2.1.3,
Clean and Simple Contact Form by Meghan Nicholas version 4.7.0,
Comment Control by Samir Shah version 0.4.1,
Compact Audio Player by Tips and Tricks HQ version 1.9.6,
Custom Facebook Feed Pro by Smash Balloon version 2.2,
Ditty News Ticker by Metaphor Creations version 2.2.1,
Download Media Library by marcelotorres version 0.2.1,
Duplicate Post by Enrico Battocchi version 3.2.2,
Event Espresso – Calendar by Event Espresso version 2.2.7.p,
Event Espresso – Custom Template Display by Event Espresso version 1.0,
Event Espresso – MailChimp Integration by version 1.2,
Event Espresso – Recurring Events by Event Espresso version 1.1.8.p,
Event Espresso by Event Espresso version 3.1.37.14.P,
EWWW Image Optimizer by Shane Bishop version 4.0.0,
Google Analytics Dashboard for WP (GADWP) by ExactMetrics version 5.3.7,
Google Drive Media Library by Felix Wei version 1.0,
Google Drive WP Media by Moch Amir version 2.4.4,
Hostgator WalkMe Plugin by Snappy version 1.0,
Insert Headers and Footers by WPBeginner version 1.4.3,
Collapse-O-Matic by twinpictures, baden03 version 1.7.10,
T(-) Countdown by twinpictures, baden03 version 2.3.20,
P3 (Plugin Performance Profiler) by GoDaddy.com version 1.5.3.9,
P5 : Plenty of Perishable Passwords for Protected Posts by Cyril Batillat version 1.4,
Page Links To by Mark Jaquith version 3.0.1,
Really Simple SSL by Rogier Lankhorst, Mark Wolters version 3.1.5,
Search by ID by Uffe Fey, WordPress consultant version 1.3,
Slideshow by StefanBoonstra version 2.3.1,
Social Media Feather by socialmediafeather version 1.8.4,
SSL Insecure Content Fixer by WebAware version 2.7.2,
TablePress by Tobias Bäthge version 1.8.1,
UpdraftPlus – Backup/Restore by UpdraftPlus.Com, DavidAnderson version 1.14.5,
Varnish HTTP Purge by Mika Epstein version 4.3.1,
WangGuard by WangGuard version 1.7.3,
WordPress Importer by wordpressdotorg version 0.6.3,
Yoast SEO by Team Yoast version 5.7.1,
WP Attachment Export by Peter Harlacher version 0.3.3,
WP Mail SMTP by WPForms version 1.2.5,
WP Super Cache by Automattic version 1.5.7.1
Settings
Home URL https://vitalitiwellness.com
Site URL https://vitalitiwellness.com
Registration Pages
Event Page #7605 – https://vitalitiwellness.com/events/


Vitaliti Wellness

April 9, 2019 at 5:40 pm

One more update…

I just tried zipping all the files that download under MailChimp Integration 1.3 which is available from my account page in Event Espresso and I get the following message: “Unpacking the package…

Installing the plugin…

Destination folder already exists. /home3/wac6ve0abzom/public_html/wp-content/plugins/espresso-mailchimp/

Plugin install failed.”


Tony

  • Support Staff

April 9, 2019 at 5:48 pm

Hi there,

I just tried zipping all the files that download under MailChimp Integration 1.3 which is available from my account page in Event Espresso

Are you on a PC or MAC? The file you are downloading from your account page will be a .zip file but it sounds like its automatically extracting on your machine.

You need to update to the latest version of the MailChimp add-on (currently v1.3.p), it already uses v3 of the MailChimp API.

Regarding this error:

Destination folder already exists.

WordPress throws that error when you try to install a plugin that is already installed. So de-activate and delete the current version of the MailChimp Add-on that you have on the site and then retry the install step above.


Vitaliti Wellness

April 16, 2019 at 6:06 pm

Hi – thank you. It worked to Deactivate and Delete the current version and then to upload version 1.3.

However, for my future events that are already created, I am not seeing the option to add registrants to MailChimp.

How do I add the option to “add registrants to Mailchimp” to events that were already created? Do I have to duplicate them?

Also, what about an event that is currently going on? They also do not have that option.

Thanks!


Tony

  • Support Staff

April 17, 2019 at 6:56 am

How do I add the option to “add registrants to Mailchimp” to events that were already created? Do I have to duplicate them?

No, you don’t need to duplicate the events.

If you edit the event you should see something like this – https://monosnap.com/file/ikGQdBLYD9bgIq3m5b0eWAGyzckjsb

Select the List you want to subscribe the users to and if you have any groups in that list you can also select those.

Then any registrations made on that event should be subscribed to that list.

Also, what about an event that is currently going on? They also do not have that option.

So none of your events currently have an option to add the registrants to MailChimp?

Do you see the above metabox on those events?

The support post ‘MailChimp Integration no longer w/ EE 3 because Mailchimp shut down API 1.1 -1.3’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Tony 6 months, 1 week ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!