Support

Home Forums Event Espresso Premium MailChimp Confirmation Emails Sending Before Registration is Complete

MailChimp Confirmation Emails Sending Before Registration is Complete

Posted: February 3, 2014 at 11:01 am


Kelsey Borlan

February 3, 2014 at 11:01 am

Hi there,

I am not sure if this is something that can be resolved somehow on the EE end, or if it would need to be on the MC end.

I just finished setting up my events and am testing the process. What is happening is that people are going to be sent their email list confirmation email before their registration is complete.

I don’t want them being added to the email list until their payment has been processed so that if they were to not complete their registration for some reason, they are not on my itinerary.

Any direction with this would be helpful!

Thanks in advance!


Tony

  • Support Staff

February 4, 2014 at 4:18 am

Hi Kelsey,

If you go to Event Espresso -> General Settings. Find email settings.

Is ‘Send registration confirmation emails before payment is received?’ currently set to Yes?


Kelsey Borlan

February 5, 2014 at 8:55 pm

Its actually set to “no”

Its not the event registration email that seems to be the issue (the one I see in EE in the general settings). Its the MailChimp email mailing list subscription confirmation (that requires them to click to confirm) that is sent as soon as they start their registration process started.

I looked on MC to see if I can turn this email off, but it seems to be a default/required step in the list sign up process.

Do you have any suggestions? Thank you very much!


Tony

  • Support Staff

February 6, 2014 at 7:19 am

Hi Kelsey,

After a little investigation it would appear your right, the subscribe call is made before the confirmation emails are sent.

Currently there is no way within Event Espresso to defer this, however you should be able to disabled the double opt-in.

Either via http://kb.mailchimp.com/article/can-i-shut-off-the-e-mail-that-asks-people-for-confirmation-that-they-want-/

Or if the above does not work you can also alter the plugin’s code to not use the double opt-in method when subscribing any attendees.


Kelsey Borlan

February 6, 2014 at 3:05 pm

Thanks Tony! Unfortunately that linked article above specifically says that there is no way to turn off or disable this email.

How would I go about altering the plugin’s code to not use the double opt-in method when subscribing any attendees?

As detailed of instructions as possible would be GREAT! I’m a total novice with this stuff. Thank you very much!


Tony

  • Support Staff

February 7, 2014 at 7:36 am

You can disable the double opt-in by editing the Mailchimp Add-on.

When editing the files please do NOT use office or similar, use notepad or Notepad++ (windows), Text Wrangler or Text Mate (mac)

So you’ll need to open the file \espresso-mailchimp\MCAPI.class.php

Go to line 1567, you should see:

function listSubscribe($id, $email_address, $merge_vars=NULL, $email_type='html', $double_optin=true, $update_existing=false, $replace_interests=true, $send_welcome=false)

You see the $double_optin=true. Change that to false. So that line becomes.

function listSubscribe($id, $email_address, $merge_vars=NULL, $email_type='html', $double_optin=false, $update_existing=false, $replace_interests=true, $send_welcome=false)

Then test a registration, you should NOT receive an email now. However, I’m unsure if Mailchimp treats these subscriptions differently than when using double opt-in.

Hope that helps.

The support post ‘MailChimp Confirmation Emails Sending Before Registration is Complete’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 5 years, 9 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.