Support

Home Forums Event Espresso Premium Mailchimp Addon – not showing the correct field for name

Mailchimp Addon – not showing the correct field for name

Posted: September 5, 2018 at 7:44 am


fishwinkmarketing

September 5, 2018 at 7:44 am

We are using the Mailchimp add-on to capture email addresses at event registration. In the “Mailchimp List” box on the edit event page in the backend, we have the “Email Address” list field matched up to the “Email Address” form field which is correct. But for the name, the “Name” list field we are trying to match with the “Name” form field, but only “First Name” and ” Last Name” field options show up.

How do we get the “Name” field to appear as an option in the form fields?

Thanks!


Tony

  • Support Staff

September 5, 2018 at 9:48 am

Hi there,

So you have a custom registration question assigned to a custom group or to the personal info group? (EE does not include a ‘Name’ field by default so I’m assuming it’s a custom reg question).

The questions assigned to the event should all be available within the dropdowns, but, you will need to save/publish the event with the question group your custom question first. The MailChimp add-on can only pull in the fields assigned to the event (by default that’s just First name, Last Name, Email) so if you are creating a new event then before its saved with the custom fields included the MailChimp add-on doesn’t know which additional fields to include.


fishwinkmarketing

September 5, 2018 at 12:30 pm

Hey there,

Ok I understand what you are saying. I figured out that I needed to create a first and last name field in MailChimp to correspond with the registration fields. Those are now linked up but now I see “No Groups found for this list” (see image below).

Screenshot

What else do I need to do to get this setup properly?

Thanks!


Tony

  • Support Staff

September 5, 2018 at 2:10 pm

That’s normal if you haven’t got any groups on your MailChimp list.

So do you have groups on your list?

https://mailchimp.com/help/getting-started-with-groups/

(Note you don’t need groups, they are a method you can use to separate your list so you may not need them at all)


fishwinkmarketing

September 5, 2018 at 2:32 pm

Ok gotcha. Nope we don’t have any groups. Just wanted to make sure I don’t need to create any groups in order for people to get added to the master list. The red font on the group message made me think a setting was wrong or something.

Thanks for your help!


Tony

  • Support Staff

September 6, 2018 at 3:45 am

You’re most welcome and thank you for the feedback, I’ll see if we can improve that section in a future update to prevent confusion for future users.


fishwinkmarketing

September 6, 2018 at 9:39 am

No problem 🙂

One last question for you on this. So I created First and Last name fields in mailchimp to match the registration form fields.

The fields appear mapped correctly (see image below) and upon registration, the correct opt-in email goes out.

I looked at our list in Mailchimp and it’s adding the new email address to the list but isn’t adding the first and last name.

Any ideas as to why the names aren’t transferring?

screenshot

Thanks!


Tony

  • Support Staff

September 6, 2018 at 1:42 pm

Do you by any chance have multiple ‘First name’ questions within EE?

(You can find a list of your registration questions under Event Espresso -> Registration Form -> Questions)

In your MailChimp account, click on your name in the top right, go to Profile, now on the tabs about your details go to ‘Extras -> API Keys’.

At the bottom of that page you’ll see some of your API calls, do you see any with red X’s, if so what is the Response for those? Heres an example of what you are looking for – http://take.ms/XotHV


fishwinkmarketing

September 6, 2018 at 2:06 pm

I checked and there is only one ‘First Name’ and ‘Last Name’ questions on the registration form.

I went to our MailChimp and did find that there were two red X’s in the recent API calls ==> https://snag.gy/lvZQzf.jpg

Is that what’s causing this?

Thanks!


Tony

  • Support Staff

September 6, 2018 at 2:17 pm

No, those are expected.

For example the Method list/interest-groupings will fail if you don’t have groups.

At the bottom of that table you have arrow buttons, meaning there are multiple pages. Do you see any entries with a method list/subscribe?


fishwinkmarketing

September 6, 2018 at 2:32 pm

Ok gotcha. I just tried going through the our registration again and checked my list in MailChimp and now for some reason, the names are coming through correctly now!

Not sure what changed but it appears to be working fine now.

Thanks again for all of your help with this, have an awesome evening!


Tony

  • Support Staff

September 7, 2018 at 2:14 am

No problem at all, I’m glad it’s working for you.

As its Friday, have a great weekend 🙂

The support post ‘Mailchimp Addon – not showing the correct field for name’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 months, 1 week ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[i]
[i]