Support

Home Forums Event Espresso Premium Lots of problems with Message formatting

Lots of problems with Message formatting

Posted: May 11, 2018 at 4:21 am


iwbnet

May 11, 2018 at 4:21 am

We seem to continue to have formatting issues with our message templates. We are running 4 separate events and use custom message templates for each but we are constantly having issues with the formatting of the messages, the View Invoice button not working, the formatting of the Invoice & Receipt are terrible, images don’t load. Is anyone able to assist with this? I find the Message Templates seem to cause the most issue.


Josh

  • Support Staff

May 11, 2018 at 5:48 am

Hi there,

Usually these issues are caused by your web host having allow_url_fopen disabled on the server. The PDFs are generated using DOMPDF which requires allow_url_fopen to be enabled to load in the images and styles.


iwbnet

May 11, 2018 at 5:35 pm

I checked this setting awhile ago and it’s already enabled.
Its not just the PDF’s, it’s also just the basic message templates that attendees receive when they register, or when they pay.
The ability to format these to look nice seems to be more difficult than it should be and because we have 4 events, we have 4 versions for each message template.
The View Invoice button works on some message templates and doesn’t on others.


iwbnet

May 11, 2018 at 5:37 pm

I have double checked this setting again and we are running PHP v7.0 and can see allow_url_fopen is set to On within the PHP Options.


Josh

  • Support Staff

May 11, 2018 at 7:31 pm

Can you post a link to an event where we can do a registration test to investigate further?


iwbnet

August 16, 2018 at 10:51 pm

I have previously posted about:

We had been using the logo in each of the HTML invoices for our events but when we then click Download PDF the PDF version the image link is broken. The logo appears in all web-based pages all except the downloadable PDF. The Image URL is correct and can be accessed.

I was advised to check if allow_url_fopen is enabled on the server. I have checked this through PHP and the allow_url_fopen is set to On. The server is using PHP v7.0.

This is still an issue and we are looking to set up our next event for 2019 and would like this rectified as it doesn’t look great when participants download the PDF.

Thank you.


iwbnet

August 16, 2018 at 11:18 pm

Can I please reopen this previous post which has now closed:
https://eventespresso.com/topic/lots-of-problems-with-message-formatting/
Can I PM the event link as it’s a new event and we haven’t advertised the URL as yet as want to sort out issues before people start registering?


Tony

  • Support Staff

August 17, 2018 at 3:08 am

Hi there,

I’ve re-opened this thread for you and merged your 2 most recent posts together as there is a bit of crossover anyway, just so you are aware, threads automatically close after 2 weeks of no activity.

You can send the link to support[at]eventespresso.com and we’ll take a look.

Or post the link here and we’ll remove it from the post shortly after.

The support post ‘Lots of problems with Message formatting’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!