Support

Home Forums Event Espresso Premium Looping at Captcha at registration

Looping at Captcha at registration

Posted: May 14, 2020 at 10:33 am


Woodturner

May 14, 2020 at 10:33 am

Hi,
Once I click on proceed to checkout, it takes me back to the previous page and this goes on forever in a loop. I have tried everything I could find on the Internet. Updated my plugings, WP and tried both V2 and V3 reCaptcha types.
Can you please help?


Tony

  • Support Staff

May 14, 2020 at 10:58 am

Hi there,

If you temporarily de-activate Contact Form 7 on the site and retry, does it work then?


Woodturner

May 14, 2020 at 11:36 am

It didn’t help. I de-activated Contact Form 7, Contact Form 7 – PayPal & Stripe Add-on and Contact Form CFDB7 one by one.
Note that when I set reCAPTCHA Appearance to Invisible, the registration works fine but there is no captcha.


Tony

  • Support Staff

May 15, 2020 at 4:02 am

When you set reCAPTCHA to Invisible it validates the response in the background, so as the name suggests it is invisible on the front end.

So when you say ‘there is no captcha’ do you just mean there’s no checkbox? If so that is expected.

I can’t reproduce this on my test sites so first lets confirm your set up.

EE4 uses reCpatcha V2 and you need a V2 key, NOT v3.

You can confirm which key you are using in the reCpatcha console:

https://www.google.com/recaptcha/intro/v3.html

Log in with the google account you used to generate the key and confirm it the key it v2 and if you wish to use ReCaptcha checkbox make sure that integration type is set on the key itself.


Woodturner

May 15, 2020 at 9:23 am

This reply has been marked as private.


Tony

  • Support Staff

May 15, 2020 at 3:16 pm

Hmm, ok. I can’t see anything wrong with the request itself so it could be another plugin or possibly your host blocking the request.

With reCaptcha when you click on the checkbox it sends a request to see if passed or fails and then stores that response on a hidden input within the page. When you click to submit it sends that hidden details with the request in a POST request and EE checks it with reCaptcha to confirm and then redirects to the next step, on your site the POST request is sending but the redirect to the next step isn’t happening.

First, check the server error logs and see if there are any errors shown from Event Espresso there. Your host will usually have a section for you to view errors from the site in your control panel.

The next step is to disable all plugins other than Event Espresso and retest a submission, if it works its a plugin conflict. Enable each plugin one by one and test between enabling them to find which one breaks the response again, then post that here.

If it doesn’t work with all plugins disables, switch to a default theme such as twentyseventeen and and retest, this time your testing with all other plugins disabled and a default theme. If it doesn’t work then, it could be something on your host like a mod_sec rule.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 week, 4 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!