Support

Home Forums Event Espresso Premium Link on invoice in Registration Pending Payment – Primary Registrant not working

Link on invoice in Registration Pending Payment – Primary Registrant not working

Posted: July 5, 2019 at 4:10 am


Palladio

July 5, 2019 at 4:10 am

Hi, If I register with invoice and click on the link in the mail message I get as primary registrant, I get an error message: Safari can’t open the page (…address) because Safari can’t find the server “https”. However if I click the link on the Thank you page, the invoice shows correctly.


Tony

  • Support Staff

July 5, 2019 at 4:19 am

Hi there,

We’ve seen it before where an addition URL schema was added to the beginning of the link in the email.

If you copy the full link from the email, does it have https://http:// or similar at the beginning?

Is there an event I can register onto to view this?


Palladio

July 5, 2019 at 4:24 am

Hi, correct! the link is http://https//www.palladio.net?ee=msg_url_trigger&snd_msgr=html&gen_msgr=html&message_type=invoice&context=purchaser&token=1-a01806807e3a86328c776b9c324f60df&GRP_ID=1&id=128

I’ve already tried taking away the http in the Link form, but it got back automatically after I closed the pop-up.

the event is on this page: https://www.palladio.net/events/play14-basel-august-23-25-2019/


Tony

  • Support Staff

July 5, 2019 at 4:29 am

I’ve already tried taking away the http in the Link form, but it got back automatically after I closed the pop-up.

My apologies, but I don’t understand what you are doing here?

Which form? Which pop-up?


Palladio

July 5, 2019 at 4:34 am

Sorry – In this form: Editing Email Registration Pending Payment Template (Primary Registrant Recipient) there is the malfunctioning link in question: “You can find your invoice by clicking this link”. If I edit the link, it says: http://[INVOICE_LINK] If I delete the http:// and click “apply”, then “safe” for the whole template, on opening the link edit pop-up again, the link has reverted back to http://[INVOICE_LINK]


Tony

  • Support Staff

July 5, 2019 at 4:43 am

Hmm, there should not be an ‘Apply’ button.

Can you add a screenshot of what you see please?

https://eventespresso.com/wiki/troubleshooting-checklist/#screenshots

If you are editing the template in Event Espresso -> Messages -> Default message templates -> Registration Pending Payment -> Edit Primary Registrant

Then your in the correct place, but that link is custom as the template doesn’t include a link to the invoice by default and in short it sounds like its been added to the template incorrectly, causing a broekn link, or something is filtering the content and adding links to the EE templates (which is shouldn’t be).


Palladio

July 5, 2019 at 4:53 am

https://www.palladio.net/wp-content/uploads/2019/07/Screenshot-2019-07-05-at-12.50.42.png

Hm – it could be I added that text earlier on, because usually here people get the invoice by mail (often as an attached pdf), and not by having to go back on the page and find a link lower on the thank you page. If you have an alternative to get the link or the pdf into the email, please let me know.


Tony

  • Support Staff

July 5, 2019 at 5:07 am

EE doesn’t support attaching the PDF itself to the email, but you can add the link directly to the email using the correct shortcode.

The [INVOICE_LINK] shortcode parses to an actual link so you can’t use that shortcode in the way you are currently, it’s the reason you’re getting the error on the email.

[INVOICE_LINK] parses to '<a href="{invoice_url}">Click here for Invoice</a>', meaning if you wrap it as a link it will break.

Switch Text mode on the editor and edit the text directly, then switch out the shortcode to use [INVOICE_URL] and remove the http:\\, like this:

https://monosnap.com/file/qRtH1ElraWcLItWPWVHHpp8kusKldE

That link should work for you then.


Palladio

July 5, 2019 at 7:13 am

Thanks, that solved it!


Tony

  • Support Staff

July 5, 2019 at 9:43 am

You’re most welcome.

The support post ‘Link on invoice in Registration Pending Payment – Primary Registrant not working’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 9 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!