Support

Home Forums Event Espresso Premium Latest Update KILLED authortize.net processing

Latest Update KILLED authortize.net processing

Posted: May 28, 2015 at 9:49 am


Andriy Kharkovyy

May 28, 2015 at 9:49 am

Hello, i did an update for EE that showed up today.. and now my authorize.net is dead. BOTH methods.
I have live event registrations going on. What is happening.


Lorenzo Orlando Caum

  • Support Staff

May 28, 2015 at 10:15 am

Hi, what version of Event Espresso are you using and what exactly isn’t working?

Are payments all being declined? Is the registration checkout page not loading, etc?

It would be helpful to provide some additional information on this issue.

Thanks


Lorenzo


Andriy Kharkovyy

May 28, 2015 at 10:48 am

When i use either one of the methods i get This transaction cannot be accepted. (code: 103) error and thats it.. It seems that the CC info doesn’t even get to Authorize.net


Andriy Kharkovyy

May 28, 2015 at 10:49 am

Basically with the one method you fill out all of the info on the site with cc info and press submit and it gives the error.
On the other method where it supposed to take you to Authorize.net gateway it never does just sits there saying that if in 10 seconds you are not transferred click here but nothing happens even when you click


Tony

  • Support Staff

May 28, 2015 at 11:01 am

Hi Andriy,

I’ve just ran a registration on one of your events, selected Auth.net SIM and was directed to Auth.net

On inputting ‘1’ in the card field auth.net doesn’t return me back to your site. When making a payment using SIM you are directed to auth.net’s server to do so, then you should be returned. Which is not happening.

How was Event Espresso updated?

Are you running any caching plugins?

Does you host run server side caching? (For example GoDaddy Managed WordPress packages cache all pages across your site on the server)


Andriy Kharkovyy

May 28, 2015 at 11:09 am

Hello,
– did auto update on EE that came up this morning in the WP admin update section, just like i typically do
– we host ourselves on own dedicated server there are no caching issues
– do not run any caching plugins
– yesterday ran about 50 paid registrations just fine and the only thing that happened today was update to EE

Not sure what you tested by i JUST did another one on our active event and same thing.. nothing is happening.. tried chrome firefox safari.. would the update do something with event configuration itself? Is there something i can “reset”?


Tony

  • Support Staff

May 28, 2015 at 11:23 am

Not without re-setting your EE data, but I do not think that’s necessary.

Do you know what is adding this file – http://take.ms/4BEkH

As you can see its currently returning error 500 which I suspect is breaking the ajax call.

If it is being adding via a plugin can you temporarily disable the plugin.

If that doesn’t make any difference can you enable WP_DEBUG on the site and see if any errors are being thrown please?


Andriy Kharkovyy

May 28, 2015 at 12:13 pm

Yeah it’s deprecated tracking.. i removed it.. didn’t help.. here’s the debug info:

Notice: Undefined offset: 1 in ……/wp-content/plugins/ldap-login-password-and-role-manager/ldap_login_password_and_role_manager.php on line 100 Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the “EventsSideBar” sidebar. Defaulting to “sidebar-8”. Manually set the id to “sidebar-8” to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in ……wp-includes/functions.php on line 3560 Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the “HarvestRunSidebar” sidebar. Defaulting to “sidebar-9”. Manually set the id to “sidebar-9” to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in ……../wp-includes/functions.php on line 3560


Andriy Kharkovyy

May 28, 2015 at 12:14 pm

I also did disable the LDAP login plugin and that didn’t do anything either. Still same thing hangs on the redirect.


Josh

  • Support Staff

May 28, 2015 at 1:28 pm

Hi Andriy,

I can help you get this sorted, it’s going to be a bit of trial and error at this point because we are not seeing any issues with Authnet checkout on Eventsmart (which also got yesterday’s update), and the changes in version .29 from .28 were very minimal. In turns out, nothing has changed in the authnet gateways since the last version.

First, here’s some general information on the Authnet error:
https://support.authorize.net/authkb/index?page=content&id=A852

and here’s a link to a authnet support thread that has a few ideas that may help:

http://community.developer.authorize.net/t5/Integration-and-Testing/Error-103-This-transaction-cannot-be-accepted/td-p/20427

If you want to rule out whether this was caused by the latest update, you can deactivate and delete the copy of Event Espresso that’s installed right now and replace it with the previous version. You can download a zip of the previous version here:

https://github.com/eventespresso/event-espresso-core/tree/4.6.28.p-sans-tests-tag


Andriy Kharkovyy

May 28, 2015 at 2:23 pm

I did upload the old version and it seems as though that didn’t do anything same issues with connecting to authorize.net I will reach out to them as well. I tried your beta with same result.


Josh

  • Support Staff

May 28, 2015 at 2:28 pm

Hi Andriy,

The beta should not be used on a live site, and will not have any additional fixes over Master, it may even be behind master.

Have you checked to see if anything in your Authnet account has been changed?


Andriy Kharkovyy

May 28, 2015 at 2:35 pm

Auth.net claims there was some sort of certificate change yesterday they claim that they have sent out blog to developers about it.
They said that something needs to be updated on the plugin end to work with it.. something changed from 1 to 2 i dont really know what they are talking about


Andriy Kharkovyy

May 28, 2015 at 2:36 pm

I’m the only one that uses this Auth account and nothing changed there.. apart from me generating new keys which i updated in EE in effort to resolve this.


Andriy Kharkovyy

May 28, 2015 at 2:37 pm

http://community.developer.authorize.net/t5/The-Authorize-Net-Developer-Blog/Production-Certificate-Upgrades-begin-May-27-2015/bc-p/50616


Josh

  • Support Staff

May 28, 2015 at 3:03 pm

Hi Andriy,

Can you contact your web hosting company and ask them if they can install the certificates specified in the document you linked to? Event Espresso does not install the root certificates on your server.

The support post ‘Latest Update KILLED authortize.net processing’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 4 years, 5 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.