Home Forums Event Espresso Premium Language customisations not applying?

Language customisations not applying?

Posted: June 30, 2013 at 6:51 am


June 30, 2013 at 6:51 am

I have followed the instructions at how to change wording with poedit in order to change text such as ‘Check/Money Order Payments’ to ‘Cheque Payments’. The file I generated is in the /uploads/espresso/languages folder, and the wp-config.php has been updated with define(‘WPLANG’, ‘en_GB’); (confusing that EE uses UK and WP GB!).

The language file is not being read as the text has not been changed. Any ideas why?


July 1, 2013 at 12:00 am


Yes it is confusing and also causes the files to not work. There is a ticket in place to fix this. Please rename the mo/po files so UK becomes GB and it should solve it for you. Sorry about that!


July 1, 2013 at 2:53 am

Hi Dean

I had already tried this in fact and have just tried again to make sure. Still not working when the file is /wp-content/uploads/espresso/languages/

It is the case I assume that this is where to change the text on the ‘event registration’ page under ‘please choose a payment option’?

Wish there was an easy way to get at all the different bits of text here. They are scattered all over with the ‘yellow box’ text hidden in .php files and the headings in yet another files. – Got those the way they need to be at least!


July 1, 2013 at 3:44 am


Regarding the mo/po files, have you downloaded them correctly from Github? It can be a little annoying, and isnt intuitive.

To download the PO file – left click the link on the main page and then right click the Raw button in the top right of the page that comes up and save as.

To download the MO file – left click the link on the main page, and then left click the View Raw text link in the middle of the page that comes up.

If you don’t do this you may end up with a MO and PO file that contains garbage data and the language wont work.

Regarding the changing of wording, yes using the language file sis the easiest way to do it, we have a guide here that can help

I agree and understand about the text being broken up into bits, we are looking to improve that for both general users and translators in 4.0 and beyond.


July 1, 2013 at 3:53 am

Hi Dean

I did download ‘raw’ from github but your page of instructions only mentioned the .po file as being required? Using poedit to change the relevant sections within the file generates a .mo file on a save and this is what I have copied to the server?


July 1, 2013 at 4:04 am

The po file is the only one required, but the mo file helps speed things up (

I find it is best to have both.


July 1, 2013 at 4:34 am

‘helps speed things up’? You mean you can edit the .mo file in poedit and not have to trawl through all the seemingly spurious entries?

Anyhow – no closer to getting the text changed as the .mo file is seemingly not being read. What might prevent this happening?


July 1, 2013 at 4:38 am


Poedit will help as you can do a search.

By speed things up, if you read the link to WordPress it mentioned that as the mo file is in machine code it can be faster.

Is it possible to get your login details in order to look into this?

If so, please send them via

NOTE: login details need to be Admin level.


July 1, 2013 at 6:44 am


I logged in and the UK English translation is working as the Payment Settings section for Check is now correctly spelled as Cheque. I did not change anything.

What exact text are your trying to change?


July 1, 2013 at 6:58 am

Once one has confirmed an event on the ‘please choose a payment option’ panel there are three choices, Paypal (ok) Purchase Order Paryments (ok) and Check / Money Order Payments (no OK as needs to read ‘Cheque payments’).

To get here register for a test1 (hidden) event which has the id ee=26 – e.g …/event-registration/?ee=26


July 1, 2013 at 7:05 am

Ahhh I see, my apologies for not asking sooner. The language files don’t translate that bit as it is in the Payment options. Go to Payment Settings, find Cheque and you will see there are numerous fields, with text in, you can edit that to the correct spelling or completely change it.


July 1, 2013 at 8:31 am

Ye gods – it was the ‘Title’ field! (blush). Clearly life was so difficult with all the other stuff that as I found the same text in the .po file I just assumed it was there!

Sorry to waste your time Dean!


July 2, 2013 at 1:16 am


It’s not time wasted if the problem got fixed! Anyway I should have picked up on that sooner. Glad it’s sorted!

The support post ‘Language customisations not applying?’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso