Support

Home Forums Event Espresso Premium Issues with Stripe Payments and Registration Approvals

Issues with Stripe Payments and Registration Approvals

Posted: August 6, 2018 at 10:29 pm


jeremyswanston

August 6, 2018 at 10:29 pm

Hello,
I am having some issues with Event Espresso using Stripe to accept payments for registrations. I tested Stripe prior to going live and all transactions were going through successfully. Now live, when a user goes to register for an event by selecting the “Pay Now” button and enters there CC info, they are taken back to the registration screen with a prompt asking them to wait until the transaction has been completed and to not refresh the page. There is a spinning cog for about a min, then an error prompt appears saying there was an issue with the payment. However, when I check the Stripe dashboard, the payment was successful. This is also true when I check the Transactions section on EE. Additionally, the Registrations section says the registrant’s status is incomplete and awaiting payment approval. We have been manually changing the registration status for our users to “Approved” as this is not occurring automatically.

I was reading through the forums and noticed that memory could be an issue, but I check the current configuration and it is at 128MB, which I believe is large enough for transactions.

Thank you for your assistance!


Tony

  • Support Staff

August 7, 2018 at 2:29 am

Hi there,

I was reading through the forums and noticed that memory could be an issue, but I check the current configuration and it is at 128MB, which I believe is large enough for transactions.

That depends on what your running on the site, it’s not uncommon to hit 128MB rather easily with page builders etc.

If you switch back to the test key and retest, does it work as expected?


jeremyswanston

August 7, 2018 at 9:34 pm

Hi Tony,

I requested that our hosting site increase our memory settings and they did, to 256M. I performed a pre/post test this evening, with the pre-test resulting in the reoccurring timeout (approved confirmation on Stripe). After the memory was increase, the transaction completed almost instantaneously! I am going to continue to test the registration for the next few days, but am hopeful this fixed the issue.

Thanks!


jeremyswanston

August 7, 2018 at 9:58 pm

Also, is there a way to delete the testing transactions? Previous forum posts indicate that there should be a trash icon, but I am unable to find it on the primary Transaction page (see link below).

https://pasteboard.co/HyakCIC.png


Tony

  • Support Staff

August 8, 2018 at 4:51 am

I requested that our hosting site increase our memory settings and they did, to 256M.

Great, I’m glad that fixed the problem.

Also, is there a way to delete the testing transactions?

You need to delete the payment within those transactions – http://take.ms/GtA2y

Then you can delete the registrations that transaction is linked to and it will remove the transaction for you.

The support post ‘Issues with Stripe Payments and Registration Approvals’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 4 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!