Support

Home Forums Event Espresso Premium Issues with [ESPRESSO_PAYMENTS], Worldpay and The Callback Page

Issues with [ESPRESSO_PAYMENTS], Worldpay and The Callback Page

Posted: July 25, 2012 at 3:05 am


Joshua O’Riordan

July 25, 2012 at 3:05 am

Firstly I’m having issues with the shortcode [ESPRESSO_PAYMENTS] within our call back page https://thesecuritytrainingschool.co.uk/Thank You. It does absolutly nothing accept display [ESPRESSO_PAYMENTS]. The page has been set to force https and configured to be excuded on the link menu. 

Secondly there is an issue with the worldpay gateway when returning to the callback page and worldpay keeps sending an email stating the following: – 

“Our systems have detected that your callback has failed. 

This callback failure means we were unable to pass information to your server about the following transaction” 

I see that this has been reported on the forums before but cant view the solutions. 

Currently using event espresso 3.1.20P 

  • This topic was modified 8 years, 9 months ago by  Garth.


Seth Shoultes

  • Support Staff

July 25, 2012 at 6:47 am

Hi Joshua,

Sorry for the trouble with your account. Garth or I will update your account ASAP. I am going this from my phone right now, so I can’t update your account easily.

Sounds like something is wrong with that shortcode or maybe the version of Event Espresso. Once we get your account updated, you should download and install the latest version of EE.


Joshua O’Riordan

July 26, 2012 at 3:27 am

Installed the latest edition 3.1.25.P and still the same issues. The shortcode [ESPRESSO_PAYMENTS] still not displaying result(s) and worldpay not redirecting to Thank You page.

Received the following from World Pay :-

Error reported: Callback to https://thesecuritytrainingschool.co.uk/Thank%20You/: NOT OK, recevied HTTP status: 404
Server Reference: mm2imscs4p:callbackFailureEmail-3355:MerchReq-889-83

Would appreciate any help with this.


Josh

  • Support Staff

July 26, 2012 at 5:20 am

Hi Josh,

When I visit the above linked thank you page, the [ESPRESSO_PAYMENTS] shortcode is displaying on the page. It should be blank if the shortcode is working. Please verify that the Auto Return URL setting is set to the Thank You page under Event Espresso>General Settings>Page Settings.


Joshua O’Riordan

July 26, 2012 at 5:55 am

I created a new page called Thanks which can be found via https://thesecuritytrainingschool.co.uk/Thanks.

The auto return url is now set to this new page in the Espresso>General Settings>Page Settings section.

Shortcode now seems to be working (doesnt show) but still receive an error from Worldpay saying that the server returned an error 404 to new page.


Josh

  • Support Staff

July 26, 2012 at 7:55 am

Did you change the payment response URL in the WorldPay settings?

Here is the applicable documentation from the WorldPay settings box:

Enabling Payment Response As a default the payment response feature is set to OFF by default, to enable this feature:

Log in to the Merchant Interface
Select Installations from the left hand navigation
Choose an installation and select the Integration Setup button for either the TEST or PRODUCTION environment
Check the Enable Payment Response checkbox
Enter the Payment Response URL of the server-side script that is hosted on your web server
Select the Save Changes button
Note:If your Payment Response URL starts with HTTPS:// you will need to make sure that your server supports either SSL 3.0 or TLS 1.0.

You might also try setting the payment response URL as a standard permalink, so instead of https://thesecuritytrainingschool.co.uk/Thanks/ it would be something like: https://thesecuritytrainingschool.co.uk/?page_id=xx Find the page ID in the WordPress page editor.

Finally, how is the return page set as https? If you are using a plugin, be sure that the Force SSL on the return page setting in the gateway options is not checked.


Joshua O’Riordan

July 26, 2012 at 10:20 am

I have changed the response URL to https://thesecuritytrainingschool.co.uk/?page_id=969 as above.

Only using the Event Espresso SSL Plugin. Have tried with and without the Force SSL check box checked.

Still the same error 404.


Josh

  • Support Staff

July 26, 2012 at 10:24 am

Try deactivating the Event Espresso SSL plugin and using the Force SSL check box.

Also, check in /wp-content/uploads/espresso/ for older templates and older gateway files from a previous version.


Joshua O’Riordan

July 26, 2012 at 10:33 am

Have disabled the Event Espresso SSL plugin and unticked the force SSL (which is no longer available in any case).

I have also checked the /wp-content/uploads/espresso/ folders and they contain nothing.

Still receiving an error message.


Josh

  • Support Staff

July 26, 2012 at 10:40 am

This is the Force SSL check box that needs to be checked when the SSL plugin is deactivated:
enter image description here


Joshua O’Riordan

July 26, 2012 at 3:11 pm

Have set as above but still nothing.


Josh

  • Support Staff

July 26, 2012 at 9:12 pm

Hey Josh,

Can you check to see if there are any plugins that may be blocking inbound access? There are WP plugins that can do this, many times these have a feature where you can whitelist an IP address.

Also, check the .htaccess file in the root WP directory to see if there are rules set up to block access as well.


Joshua O’Riordan

July 27, 2012 at 2:25 am

I have disabled all the plugins and no longer getting the error code. Receive an invoice through via email but not redirected back to the thanks page.


Chris Reynolds

  • Support Staff

July 27, 2012 at 4:16 pm

Receive an invoice through via email but not redirected back to the thanks page.

You mean after the transaction is complete you don’t get taken to the Thanks page?


Joshua O’Riordan

July 29, 2012 at 4:08 pm

Yes – thats is correct.


Josh

  • Support Staff

July 30, 2012 at 9:56 am

Hi Josh,

Did you check the .htaccess file for any redirect rules? Try updating the permalink settings in WordPress>Settings>Permalinks, and if there is a custom permalink set, verify that it is valid.


Joshua O’Riordan

August 1, 2012 at 7:55 am

I have checked the main .htacess and there is only a basic mod rewrite rule. Content is as follows :-

BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

END WordPress

The permalink settings are as follows:-

WordPress Address (URL) = http://thesecuritytrainingschool.co.uk
Site Address (URL) = http://thesecuritytrainingschool.co.uk


Josh

  • Support Staff

August 1, 2012 at 8:24 am

The permalink settings are on a different page in the admin, they should look something like this:
enter image description here

You might try testing between the default setting and postname setting. If you’re using the default setting, use http://thesecuritytrainingschool.co.uk/?page_id=969 as the response URL. If you’re using the postname permalink setting, try: http://thesecuritytrainingschool.co.uk/thanks/

One other thing to try: download the simplified transactions page template (more info here)and upload this to the active WordPress theme’s folder. Then set the thanks and transactions pages to use this template.


Joshua O’Riordan

August 1, 2012 at 9:51 am

Have tried as above but no luck.

Tested between the default and postname permalink settings and made relevant changes to the urls within world pay.

Uploaded the transaction page template as suggested and set both the thanks and transactions pages to use the template.


Josh

  • Support Staff

August 1, 2012 at 9:57 am

Can you describe what is happening, are there any error messages displayed?


Joshua O’Riordan

August 1, 2012 at 10:02 am

No error messages displayed.

After entering in credit card details it takes you to a page where it asks you either accept or decline test transaction. When I accept it worlpay takes me to a sucessful transaction page providing transaction number information.

All relevant emails are sent to both parties including worldpay invoice.


Josh

  • Support Staff

August 1, 2012 at 10:16 am

That sounds like it’s working to me. Which may indicate that the thanks page having the simplified page template is a step in the right direction. The next step would be to create a simplified page template from the current WordPress theme to be used for the thanks page only. This would include more than the very minimal one that is on there now, things like a site navigation bar and a simple header and footer could be included.

The idea is to reduce the page weight down to as little as possible. So removing images, widgets, and javascript files from this page template would be key.


Joshua O’Riordan

August 7, 2012 at 5:38 am

Sorry for the late reply. I ran a test outside worldpays sandbox mode.

The simplified template has made no difference to the functionality of checkout.

Still the same problem and does not redirect back to the website. Please see screenshot showing that the final transaction screen after transaction is complete.

The URL bar clearly shows that I am not redirected back to the website after transaction has completed.

worldpay

Please see settings within the world pay control panel. I have tried the return url with both http:// and https://

enter image description here


Josh

  • Support Staff

August 7, 2012 at 6:27 am

If you set the WorldPay mode outside of Sandbox mode, be sure to uncheck the ‘Turn on Debugging using the worldpay sandbox?’ option in Event Espresso>Payment Settings>WorldPay settings.

Also, make sure that your server supports either SSL 3.0 or TLS 1.0.


Joshua O’Riordan

August 7, 2012 at 6:43 am

Yes – that option is turned off and the server supports SSL 3.0.


Josh

  • Support Staff

August 7, 2012 at 12:55 pm

I’ll need to get a developer to look at this.

Please send WordPress admin level log in credentials and FTP credentials via the contact form on this page: https://eventespresso.com/contact/

Select the “I am sending login info as requested” department form. Please let us know when it would be a good time to put the gateway in test mode so we can look into this further.


Sidney Harrell

August 7, 2012 at 1:45 pm

Hey Joshua,
WorldPay’s post-payment response back to your site to let EE know that the transaction has taken place is what they call the “Payment Response”, which you have checked. To allow EE to send a page back to Worldpay for Worldpay to display to your customer as a receipt page, including links back to your site, is what Worldpay calls the “Shopper Response”. You will need to check that box in your account page on Worldpay’s site in order to allow EE to control what Worldpay displays as the receipt page. This is similar to some other integrators, such as authorize.net, where we send them the ThankYou page, so that it looks like the customer has been redirected back to the site, but the url in the customer’s browser will still be “https://worldpay.com/etc” until the customer clicks on another site link, such as a menu button.


Darren

September 25, 2012 at 6:11 am

I’m having the same problem as Joshua above.

I’ve attached 4 screenshots:

worldpay-1.jpg is the WorldPay settings

enter image description here

worldpay-2.jpg is the Payment Gateway settings in EE plugin

enter image description here

worldpay-3.jpg is the Thank You page with the shortcode

enter image description here

worldpay-4.jpg is the page live on my site

enter image description here

When I make a test transaction, I end up on a WorldPay confirmation page but with no redirect or link back to the website. I also get an error message email from WorldPay saying the intended page was not found: “Error reported: Callback to http://www.highedge.co.uk/v4/thank-you/: NOT OK, recevied HTTP status: 404″

Any thoughts?


Darren

September 27, 2012 at 3:56 am

I’ve resolved this issue now by upgrading to the latest (3.1.27P) version.

The support post ‘Issues with [ESPRESSO_PAYMENTS], Worldpay and The Callback Page’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!