Support

Home Forums Event Espresso Premium Irregular 404 errors

Irregular 404 errors

Posted: June 30, 2019 at 4:53 am


Joost

June 30, 2019 at 4:53 am

Since two months I get irregular 404 errors on event pages. They seem to randmomly appear and dissappear. Sometimes I get a 404 error on one device while at the same moment have no problem on another device. I can’t relate it to server load. Any ideas where to look or how to solve it?

Thanks in advance!

Joost


Tony

  • Support Staff

July 1, 2019 at 5:30 am

Hi Joost,

What changed 2 months ago when this started happing? Any changes on the server?

To get 404 on one device but then not on another is strange and would lead me to look into if the device was triggering some form of mod_sec rule or if you’re running a load balancer, something going on with that.

I’m guessing there’s not error’s shown in the sites error logs?


Joost

July 15, 2019 at 5:27 am

Hi Tony,

Of course we tried to figure out if we could retrace the error to server changes, but we could not find something. We don’t have a mod_sec rule nor load balancer. At some point we thought it was caused by some irregular high server traffic, but once that traffic was gone, the problem did not dissapear.

We now have changed the EE slug. Perhaps there are some conflicts. We’re now testing, but given the irregular nature of the problem that is quite tedious. I’m open for other suggestions.


Tony

  • Support Staff

July 18, 2019 at 5:12 am

I spent some time on this and really, I can’t think of any reason why WordPress (EE events are custom posts so WP handles the routing) would show 404 on some requests and not others.

WP handles pretty much all of the routing for the request and then we take over to inject the event content.

However, what I did find was similar reports of this:

https://stackoverflow.com/questions/22183876/wordpress-randomly-returning-404

To me this sounds plausible and I recommend contacting your host to confirm if this is happening, you may be hitting a memory/query limit or the server is under load and they just return a 404 for the request.

I very much doubt the 404 itself is coming from within EventEspresso itself as if that were the case I don’t think this would be ‘random’.

The support post ‘Irregular 404 errors’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 1 month, 1 week ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!