Support

Home Forums Event Espresso Premium iphone app "Sorry, can't log in 500-internal server error"

iphone app "Sorry, can't log in 500-internal server error"

Posted: July 24, 2014 at 9:39 am


Kahlua

July 24, 2014 at 9:39 am

used to work fine. now can’t log in using the app. API is set to public. HTTPS is set to registration page only and I do use WordPress HTTPS plugin. website: whataticket.com
please advise.
Thanks


Tony Warwick

  • Support Staff

July 24, 2014 at 1:15 pm

Hi Kahlua,

I looks like your server is under heavy load, it is consistently take over 20 seconds for the page to load for me.

Can you try enabling WP_Debug and then viewing this page:

http://whataticket.com/espresso-api/v1/events/public.pretty_json

to see if any errors are being thrown, I suspect a the site is reaching the memory limit.


Kahlua

July 25, 2014 at 6:09 am

Hi Tony, I got this:

Errors :

Warning: include(/home3/whatatic/public_html/wp-content/advanced-cache.php) [function.include]: failed to open stream: No such file or directory in /home3/whatatic/public_html/wp-settings.php on line 65

Warning: include() [function.include]: Failed opening ‘/home3/whatatic/public_html/wp-content/advanced-cache.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home3/whatatic/public_html/wp-settings.php on line 65

Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home3/whatatic/public_html/wp-settings.php:65) in /home3/whatatic/public_html/wp-content/plugins/coming-soon-maintenance-mode-ready/classes/req.php on line 9

Notice: A session had already been started – ignoring session_start() in /home3/whatatic/public_html/wp-content/plugins/espresso-multiple/espresso-multi-registration.php on line 77

Could this be the reason?

Thanks


Josh

  • Support Staff

July 25, 2014 at 1:09 pm

It could be the reason. Can you try deactivating the Coming soon maintenance mode plugin and also disable caching for the time being? Please be sure to not deactivate the caching plugin, (leave it active), but instead disable caching via the caching plugin’s settings.


Kahlua

August 6, 2014 at 1:07 pm

Hi

I have deactivated Coming soon maintenance mode plugin. And viewed http://whataticket.com/espresso-api/v1/events/public.pretty_json.
Right now there is no cache plugin activated on site. I have found “W3 Total Cache” in installed plugin list but its deactivated.
Can you Please let me know what I need to do. Please advise on remaining errors I got on debugging mode.


Tony Warwick

  • Support Staff

August 7, 2014 at 5:48 am

Can you re-enable WP_Debug so we can view the errors please?


Kahlua

August 8, 2014 at 2:01 pm

done. its re-enabled

thanks


joinfof

August 8, 2014 at 4:43 pm

I’m also having similar issues. I just created a new thread on the matter.


Lorenzo Orlando Caum

  • Support Staff

August 10, 2014 at 5:06 pm

Hi Kahlua,

I see that EE3 core is up to date. Are you addons for EE3 also up to date?

Do these errors continue to appear if only EE3 core is running?


Lorenzo


Kahlua

August 12, 2014 at 11:25 am

Hi
yeah everything is up to date, now I am getting “Cocoa error 3840” when I try to login through the app.

please advise
thanks


Tony Warwick

  • Support Staff

August 12, 2014 at 11:42 am

I would recommend trying a full troubleshoot on the site.

Start by making a full site backup, we have a guide posted here:

https://eventespresso.com/wiki/how-to-back-up-your-site/

Then de-activate all non EE plugins and switch to one of the default themes (twentyfourteen) for example. Then retry both the app and the http://whataticket.com/espresso-api/v1/events/public.pretty_json page.

Do they then load? If so activate the sites theme once again and retry. Then activate each plugin one by one testing to see what is causing the API and APP to fail.


Kahlua

August 18, 2014 at 10:15 am

After deactivating all plugins and activation default WordPress theme, I still have errors.
http://whataticket.com/espresso-api/v1/events/public.pretty_json
Also, still getting the cocoa error trying to login in the app.

Please advise.

Thank you


Lorenzo Orlando Caum

  • Support Staff

August 18, 2014 at 2:11 pm

Hi Kahlua,

I see that there is a maintenance mode plugin active. When you tested, was this plugin also off?

Could you share a temporary WP admin login through the form below:

http://eventespresso.com/send-login-details


Lorenzo


Kahlua

August 26, 2014 at 1:05 am

Hi

App was working perfectly until I installed WP HTTPS plugin to secure registration page and now when I try to login using the app I get “Sorry can’t log in server response is zero-length; no data”

Please advise.

Thanks


Josh

  • Support Staff

August 26, 2014 at 7:48 am

Hi there,

I checked and I found that you’re using an older version of the Event Espresso API plugin (2.0.2). There is a newer version (2.1.2) where we added some compatible fixes for a few plugins, one of them being the WP HTTPS plugin. Please update to the latest version of the Event Espresso API plugin.

If you’re not sure how to update, please see this guide:

http://eventespresso.com/wiki/updating-event-espresso/

The support post ‘iphone app "Sorry, can't log in 500-internal server error"’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4
  • 5Voices
  • 15Replies
  • 2Followers

Status: closed

Updated by  Josh 3 years, 3 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!