Support

Home Forums Event Espresso Premium Invoices created but not downloading

Invoices created but not downloading

Posted: January 22, 2018 at 9:03 am


Pymwymic Events

January 22, 2018 at 9:03 am

Hi EE,

We are running into an issue with invoices not downloading at all. The invoices html is created, but clicking on the download button does nothing except getting WordPress stuck in a loop. The only way to get out of the loop is by restarting the browser.

Using a default invoice template throws the same error and logging with WP_DEBUG doesn’t give any information. Troubles started when we tried uploading an invoice logo. No logo is selected at the moment.

Hope you can help, thanks.


Tony

  • Support Staff

January 22, 2018 at 10:34 am

Hi there,

WP_DEBUG may be too late to log the error, can you check the servers error logs and see if there are any errors there?

Also, check that allow_url_fopen is enabled on your server and are you running any security plugins on the site?


Pymwymic Events

January 31, 2018 at 10:08 am

Hi Tony,

It’s taking its time to get a response from the server people, but they have enabled allow_url_fopen and things haven’t changed. Still trying to get a response re: server errors. In the meantime, anything else we can try?


Josh

  • Support Staff

January 31, 2018 at 1:07 pm

Some web hosts make those server error logs available via the hosting control panel (oftentimes called C-Panel). If you can access the server error log that way, can you compare the errors logged at the time you tried to get a PDF invoice?


Pymwymic Events

February 3, 2018 at 6:10 am

Hi –

We’ve done some troubleshooting and think this is related to the SSL certificate on our website. The certificate was disabled for a moment and invoices downloaded correctly. Is there a way to bypass ssl when downloading the invoices?


Tony

  • Support Staff

February 5, 2018 at 3:40 am

Not really, the URL’s are built using WP core functions which will use SSL if available.

How are you enabled SSL on the site?


Pymwymic Events

February 13, 2018 at 2:18 am

We’re still looking for a bug somewhere, but the certificate is installed in the vhost of Apache2. It’s a Let’s Encrypt certificate.

Does that info help?


Tony

  • Support Staff

February 13, 2018 at 9:39 am

Are you using a plugin to set the site to load over HTTPS or relying on a redirect?

For example, you could try the Really Simple CSS which switches the site to use HTTPS and make sure any plugins use HTTPS rather than HTTP (to then be redirected by the host).

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Tony 4 days, 6 hours ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!