Support

Home Forums Translations Install Error: Parse error: syntax error, unexpected T_STRING in /home2/voxlumie

Install Error: Parse error: syntax error, unexpected T_STRING in /home2/voxlumie

Posted: September 9, 2013 at 5:45 pm


Kevin Hayes

September 9, 2013 at 5:45 pm

Hi all:

I’m trying to install Event Espresso and I’m getting a fatal install error. I’ve tried loading via wp and ftp – with and without all other plugins – and.. I get the same (bad) results.

Details are below – thanks in advance for your help!

Kevin

Website: http://www.voxlumiere.com
WP: 3.6
Theme: Big Format – http://themeforest.net/item/bigformat-responsive-fullscreen-wordpress-theme/2632480

Error Message:
Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected T_STRING in /home2/voxlumie/public_html/wp-admin/includes/upgrade.php on line 1747


Sidney Harrell

September 9, 2013 at 9:48 pm

I took a look at that function wp-admin/includes/upgrade.php on line 1747 and it has to do with updating a theme and should only be called when WordPress is updated from versions prior to version 1.5. Can you try switching to the default WordPress theme before trying to install EE?


Kevin Hayes

September 9, 2013 at 10:28 pm

Hey Sidney:

Thanks for the quick reply. Can you give me a different solution? I am uneasy about switching templates and potentially loosing the hundreds of hours spent tweaking our site.

Thanks again.

Best, Kevin


Sidney Harrell

September 9, 2013 at 10:48 pm

Sorry, I should have been more clear. I meant switch to the default WP theme as a test, then install EE, then switch back to your theme. Can you also take a look at wp-admin/options.php in your browser and scroll down to db_version and tell me what it is? The function where your error message indicated the problem is called by another function which is called by another function which gets called only when that db_version number is below 2541. I have a feeling that your theme is saving it’s own db version number in the same place that WP is saving it’s db version number.


Kevin Hayes

September 10, 2013 at 6:12 pm

Hi SIdney:

Thank you again for all the help.

So…

1) db_version is 24448
2) I also was successful in adding event espresso to a little “test” site I have. http://www.liquidranchrecords.com. I switch to the simplest wp theme, and it loaded right in.

Now… can you give me some help on how to get EE to work in my big ol’ fancy site? 🙂

Thank you…


Dean

September 11, 2013 at 5:12 am

Hi Kevin,

OK well the Database version looks ok and correct.

As such it seems it is some sort of theme conflict, especially with it working on a default theme.

Is it possible to get FTP access so we can download a copy of the theme to our test servers? Sometimes we can pinpoint the issues with these things, sometimes we simply can’t and have to refer you back to the theme developer.

If it is ok, please send them via https://eventespresso.com/send-login-details/

The support post ‘Install Error: Parse error: syntax error, unexpected T_STRING in /home2/voxlumie’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Dean 7 years, 6 months ago ago

Topic Tags

Tagged: , ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!