Support

Home Forums Event Espresso Premium Inserting an image into an event – Calender will not display

Inserting an image into an event – Calender will not display

Posted: November 17, 2012 at 7:31 am


Dave Wilkinson

November 17, 2012 at 7:31 am

Hi, When I insert an image into an event, the calendar will no longer display.
WP-Config debug = true does not show anything but using google chrome to display the developer tab I am able to identify the error where it is falling over.
Its the line after this entry.
//Load the events into json srrsy
Error being “Uncaught SyntaxError: Unexpected identifier” or window.script1353164304872=1;
events: [{“color”: etc etc etc
If I remove the image from the event the calendar will show.
I am using the normal WP insert image/media tool If I add a pdf into the event the calendar will show.
Nothing is captured in the error_log either I am using the latest version of EE and the Calender plugin. Also the Members plugin.

I have enabled image in calendar to “yes”

When the calendar is working i get ‘n’ displayed between lines on the “pop-out” when the mouse is over an event.

Update: – The calendar will not display if I have this standard html within the event either
HELLO *take out the underscores.
Error displayed within the console of the developers tools on Chrome.
window.script1353164505645=1;

if I use the standard or tags within the event the calendar will appear.


Josh

  • Support Staff

November 17, 2012 at 10:30 am

Hi there,

Do you have a plugin active that alters the_content?

Some plugins may conflict with these features, so I’d first suggest deactivating all other plugins besides Event Espresso and the calendar, and see if the calendar with images will work again. If they work, reactivate your other plugins one at at time to find the culprit. It may even be a theme function, so you could try temporarily switching to the default WordPress theme to rule that out.

Please let us know how it goes, and whether you find a plugin that is conflicting. Thanks very much.


Dave Wilkinson

November 19, 2012 at 1:22 am

Hi.
It is an issue with Yourmembers plugin. If I make the calendar only viewable to paid members then no images/html – make it viewable to all. then it works fine. Thanks for heading me in the correct direction. Shame the 2 dont work together 🙁
D

The support post ‘Inserting an image into an event – Calender will not display’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!
[i]
[i]