Home Forums Event Espresso Premium iDeal error page after submit with no bank selected – output before wp loads

iDeal error page after submit with no bank selected – output before wp loads

Posted: January 20, 2013 at 11:24 am

Paua (Jeroen Wilms)

January 20, 2013 at 11:24 am

When no bank is selected and a user by accident submits a redirect is initiated to the transactions page. On this page an error is shown but completely out of HMTL. It is loaded even before the doctype and wordpress output.

It showed no error in the first test, but I edited the code as follows in the ideal_vars.php file on rule 123:

Choose your bank

When the option value contains anything – not any bank_id – it shows the error.

Basically all I need is the error message to reload in proper spot in the template’s html so it can be styled. I also then like the other payments gateways to show besides it – this is also not happening at this moment.

Seth Shoultes

  • Support Staff

January 21, 2013 at 11:28 am

Can you provide a link to where this happening? What version of Event Espresso are you using? Have you tried deactivating the bank payment gateway?

Chris Reynolds

  • Support Staff

January 21, 2013 at 1:16 pm


We will take a look at this and try to add it to an update for Event Espresso. We may or may not be able to get an ideal situation working (no pun intended) since that error is coming from iDeal and not Event Espresso and we can only work within the API that we are given, but if we can reproduce it we can send it off to our dev team to look into.

Paua (Jeroen Wilms)

January 22, 2013 at 6:36 am

It’s an currently active problem at
The issue shows as a registration is confirmed and the payment gateway is to be chosen. When then the user fails to choose a bank all hell breaks loose. Can you guys give it a look?!


  • Support Staff

January 23, 2013 at 1:04 pm

Hi Paua,

This has been fixed in the dev version of Event Espresso. The fix will be included in the very next version of Event Espresso.

You can remove the Choose a bank/Kiews uw bank non-option by removing this line of code from /gateways/ideal/ideal_vars.php:

<option value=''>Kies uw bank</option>

Paua (Jeroen Wilms)

January 25, 2013 at 7:29 am

Hi Josh,

Great to here you’ve found a fix for this! I’m already looking forward to EE 3.2 and this just increased that pleasure.

I’ve removed the line and it’s all sweet now. Thanks for the support!


  • Support Staff

January 25, 2013 at 11:35 am

Hi Paua,

The next version will actually be 3.1.30, so when you update to .30, there will be a few changes to the Ideal gateway, one is this fix, and the other will include some changes that will make the Event Espresso ideal gateway not conflict with the WooCommerce Ideal gateway.

Paua (Jeroen Wilms)

January 26, 2013 at 8:08 am

Great! Do you have any ETA on this?


  • Support Staff

January 28, 2013 at 10:59 am

The final version of 3.1.30 is available to download in the pre-release channel today. The official release is planned for this week.

The support post ‘iDeal error page after submit with no bank selected – output before wp loads’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso