Support

Home Forums Event Espresso Premium iCal not displaying

iCal not displaying

Posted: March 2, 2014 at 7:16 pm


Dan Rositano

March 2, 2014 at 7:16 pm

The iCal icon for my event dates and calendar are not showing event though I have the template setting set to “yes”. Are there items that can conflict with iCal?


Dean

March 3, 2014 at 1:14 am

Hi Dan,

There shouldn’t be anything that can conflict, but can you provide a link to an example page? That will help clarify what’s going on.


Dan Rositano

March 3, 2014 at 6:57 am

Sure. Here is a link to the calendar page: http://www.asamidwest.com/upcoming-events/. If you click on any event there should be an ical icon but there is not.


Dean

March 4, 2014 at 12:07 am

Hi,

Thanks for that.

Can you go to the Event Espresso Template Settings and make sure that the option “Display an “Add to my Calendar” icon/link in the event templates?” is set to Yes.


Dan Rositano

March 4, 2014 at 6:27 am

I have confirmed that it is set to yes.


Tony

  • Support Staff

March 4, 2014 at 6:59 am

Hi Dan,

It looks like you are using WP Super Cache.

You will need to add all Event Espresso pages (visible within Event Espresso -> General Settings) to the do not cache list.

As you have change the default pages your’s will be different page names to mine, but here is a quick example: http://take.ms/jQpxi

This is within Settings -> WP Super Cache -> Advanced.

You’ll then need to save the settings and rebuild the cache.

Is the iCal link then displayed?


Dan Rositano

March 4, 2014 at 7:29 am

I added the pages to the Do Not Cache List and re-built the cache. When I tested, the ical link was still not there. After that I decided to simply disable WP Super Cache and clear my browser cache. When I tested same issue; no ical icon was available.


Tony

  • Support Staff

March 4, 2014 at 7:49 am

Disabling the plugin does not actually remove the cache with WP Super Cache (or most for that matter) so simply disabling the plugin will not actually fix caching issues.

The registration page is still being served from cache, you can see this by viewing the source, at the bottom of the page you’ll see this: http://take.ms/qZEQA

Wait a few seconds, refresh the page and look at the source once more. Notice the time didn’t change?

Clearing your Browser cache removes the cahce from your local install, but not the server.

You’ll need to re-enable WP Super Cache, Go to Settings -> WP Super Cache.

Disable Caching, then Delete the Cache. Like this: http://take.ms/qTj4y

Then reload the page. WP Super Cache should then not be caching the page.

Also, have you modified the event_list_display.php template? On line 183 of that file should be

<?php echo apply_filters('filter_hook_espresso_display_ical', $all_meta); ?>

This line is used to display the ical.


Dan Rositano

March 4, 2014 at 8:10 am

I followed the instructions for disabling the cache and deleted. Viewed the source and it apperas that the page is not chached. I also confirmed that the code on line 183 was correct. Still no luck seeing the icon.


Tony

  • Support Staff

March 4, 2014 at 8:35 am

In this case I would try a full troubleshoot.

Switch to a default WordPress theme (you can do this without actually changing the theme using a plugin such as Theme Test Drive) such as twentyfourteen and re-test. Is the iCal display then?

Temporarily de-activate all other plugins other than Event Espresso and refresh the registration page.

Then if it is displayed activate the plugins one by one to find which one is causing the issue and report back so we can investigate.


Dan Rositano

March 4, 2014 at 9:24 am

Will do. I will try during off-peak hours and get back to you.

Thanks!


Josh

  • Support Staff

March 4, 2014 at 3:14 pm

Hi Dan,

You can also test a different theme without disrupting the look of the site for everyone else by installing the theme test drive plugin

My guess on the reason why you’re not seeing the ical link may be that the option needs to be reset. Can you try changing the ical template option to No, then save, then change to Yes, then save? This will ensure that the setting gets saved into the database.


Dan Rositano

March 4, 2014 at 5:02 pm

The ical issue has been resolved. I think you hit the nail on the head when you had be turn off the ical setting and then turn it back on to re-save to the database. After I switched to the twenty eleven them it still didn’t show up but when I turned off and back on again it shows up in both the twenty eleven and my theme.

The only thing I can’t seem to find now is the ical feature where you can sync the entire calendar to your client. I thought there used to be an option on the calendar page prior to my issue.

Thanks.


Dean

March 5, 2014 at 1:15 am

Hi Dan,

It’s good to hear the issue has been resolved.

There is no way currently to synch the entire calendar in one go.

The support post ‘iCal not displaying’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Dean 5 years, 9 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!