Support

Home Forums Event Espresso Premium iCal Issue caused by Description

iCal Issue caused by Description

Posted: July 15, 2015 at 7:13 am


Wilson Cooke

July 15, 2015 at 7:13 am

Hi,

I currently have an issue with the iCal feature, after downloading the iCal file on desktop, when I try to open the file (for use in Google Calendar or Outlook), it opens as an attachment in an email, rather than being opening as a calendar event.

I have debugged it and I have narrowed down to a single issue. This only happens when the Content field has been populated for an event (which is pulled through as the description).
Anytime there is even the slightest bit of content, it seems to be corrupting the iCal file. As soon as you remove the content, it works as expected, as is added as a calendar event.

I assume this is a bug? We would like to still be able to use this field as we’ve populated a lot of events already.

What can I do to fix this? or is this something that could be picked up in an upgrade?

Thanks

Adam


Lorenzo Orlando Caum

  • Support Staff

July 15, 2015 at 11:51 am

Hi Adam, what version of Event Espresso are you currently experiencing this issue with?


Lorenzo


Wilson Cooke

July 16, 2015 at 2:12 am

Hi Lorenzo,

We’re currently running Version 4.7.1.p.

We’ve also noticed that the issue only happens when the “description” breaks onto multiple lines (returns in the editor). If the content is all on one single un-returned line, it works fine.

Thanks

Adam


Dean

July 16, 2015 at 3:50 am

Hi Adam,

I tested this with the latest version of EE and couldn’t replicate the issue. Can you try updating EE and see if the issue persists? We haven’t changed anything specifically regarding icals, so it may not change anything but it will at least confirm version isn’t the issue.

Can you provide a copy of the ical file?


Wilson Cooke

July 17, 2015 at 3:29 am

Hi Dean,

I’ve updated the following to the latest versions:
– Event Espresso: Version 4.7.9.p
– Event Espresso – Calendar (EE 4.3+): Version 3.2.4.p

and we are currently running WP 4.2.1

The problem unfortunately persists. I’ve attached a copy of the iCal file (replacing client info etc) and a couple of screenshots of the content in place, and issue.

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//[CLIENT]//NONSGML PDA Calendar Version 1.0//EN
CALSCALE:GREGORIAN
BEGIN:VEVENT
UID:d2e5fbc502055af1db00a4218bcd10e7
ORGANIZER:MAILTO:4
DTSTAMP:20150717T091124Z
LOCATION:Liverpool Road\, Castlefield\, Manchester\, GB-GTM\, GB\, M3 4FP
SUMMARY:Video communications for the legal sector
DESCRIPTION:Join us at this exclusive complimentary roundtable dinner event to find out why the legal sector is adopting the latest technology – Register your interest.

Issues such as improving customer care\, minimising costs and maximising revenue are now the key points on which legal practices are seeking to differentiate themselves. The UK's leading legal firms are already adopting Video Communications to enhance their offering to clients\, providing instant access to legal specialists\; to bring case teams together across multiple sites\; and to increase revenue generation by cutting travel time and maximising billable hours\, enabling fee earners to increase their case-loads.

Join us to hear from leading legal sector experts on how they use video communications to solve their most pressing business challenges – Register your interest today.

Availability is limited so please register your interest today!
STATUS:Confirmed
CATEGORIES:Workspace technologies
URL;VALUE=URI:[URL]
DTSTART:20150803T170000Z
DTEND:20150803T193000Z
END:VEVENT
END:VCALENDAR

Event Description Editor

Screenshot of the issue in action


Dean

July 17, 2015 at 6:05 am

Hi,

Thanks for the extra info.

I’ve confirmed it has nothing to do with line breaks, but I’m not 100% sure what the issue is.

I used one of my events ical, it imported correctly. Swapped the description directly in the file with the description you posted above: it failed to import. Swapped it to some hand written text with line breaks: it worked just fine.

I took the entire ical above, swapped the [client] to just client and added a url. It failed to import. Swap the text to hand written and it works.

The issue is somewhere in the text. I’m wondering if there is some hidden formatting – I tried several format strippers but nothing worked and Notepad should strip all formatting.

How did you add the event description? Did you type it in or copy and paste it? if it was copy and paste, where was the original text (Word? Google Docs? PDF?)?


Wilson Cooke

July 28, 2015 at 3:34 am

Hi Dean,

Apologies for the delayed reply. I did some more testing, I removed all content from the description, left just one line and it worked fine, I added a second line the issue appeared again.

That’s with just added the text directly (no copy+pasting).

Test with just two lines.


Tony

  • Support Staff

July 28, 2015 at 5:09 am

Hi Wilson,

I get slightly different results than you when using your ics file but I’m on Windows so that’s usually expected 😉

When I open your ics I only see the first line of text (the ics opens as expected, not as an attachment):

Join us at this exclusive complimentary roundtable dinner event to find out why the legal sector is adopting the latest technology – Register your interest.

See – http://take.ms/grD8K

If I edit the file and escape the line breaks using \n it works as expected – http://take.ms/vNxpb

Can you try opening this – http://take.ms/JuNr4

Does it work as expected?


Wilson Cooke

July 28, 2015 at 7:33 am

Hi Tony,

Yes, that does seem to work. It opens as an .ics rather than an attachment.

I suppose finding a way to escape the content would be a quick patch, but surely we shouldn’t have to be doing this in the first place? Especially if the description is being automatically pulled from the content area of the event?

What would you suggest I do from here?


Tony

  • Support Staff

July 28, 2015 at 9:39 am

I suppose finding a way to escape the content would be a quick patch, but surely we shouldn’t have to be doing this in the first place?

No you shouldn’t and we are not asking you to 😉

I just wanted to confirm if the issue was due to the new lines within the ics, as the file I provided works as expected for both you and I, I would say that is confirmed.

I have created a ticket for our developers to investigate this and will update this thread with any feedback provided.


Wilson Cooke

July 28, 2015 at 10:53 am

Haha thanks Tony, much appreciated!

Adam

The support post ‘iCal Issue caused by Description’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Wilson Cooke 4 years, 4 months ago ago

Topic Tags

Tagged: ,

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!