Support

Home Forums Event Espresso Premium iCal button has encoding issues with Webkit

iCal button has encoding issues with Webkit

Posted: September 23, 2014 at 3:14 am


tigerton

September 23, 2014 at 3:14 am

Hi!

This is related to these issues:
http://eventespresso.com/topic/ee4-3-ical-button-value-encode-error/
http://eventespresso.com/topic/split-ee4-3-ical-button-value-encode-error/

And it seems it’s not quite fixed yet. The button do show up in webkit-browsers (safari, chrome) but it’s encoding seems to be wrong since it only shows a square rather than the dashicon it’s supposed to.

Also, it’d be swell if there where a filter in which we can alter the value of the button. Then I could just override the CSS and voila, I have a textbutton instead. Personally I like the icon but to some visitors it might be a bit too arbitrary.

thank you!
//Jonathan


Dean

September 23, 2014 at 4:21 am

Hi,

I’m not seeing it not show the icon, can you provide an example please?

Also, there is a filter available to change it:

$iCal_type = apply_filters( ‘FHEE__EED_Ical__generate_add_to_iCal_button__iCal_type’, ‘submit’ );

The options would be submit (the default), button or icon. The latter two should allow more freedom to modify via CSS.

The full code can be found here: /wp-content/plugins/event-espresso-core-reg/modules/ical/EED_Ical.module.php


tigerton

September 23, 2014 at 6:59 am

It’s only running on my local vagrant server atm but here’s two images showing the issue

https://dl.dropboxusercontent.com/u/10298919/screen1.png
https://dl.dropboxusercontent.com/u/10298919/screen2.png


tigerton

September 23, 2014 at 7:27 am

Okay so now I’m getting a block from Firehost CDN when trying to create a new ticket?!

Here’s my other ticket which I tried to post, perhaps you can do it for me manually or piggyback on this ticket..

__________________
Hi!

It seems EE isn’t reading my POedit files for swedish translation.
Before you think “oh not another one of these” I should say that I’ve read this page: http://eventespresso.com/wiki/how-to-change-wording-with-poedit/ and I’ve translated many plugins and themes before. I first noticed the issue when none of the information on the ticket details are being translated but as I looked into it it seems nothing is being translated.

I’ve tried putting the PO and MO files in both uploads/espresso/languages (had to create the folder) and directly in the plugins languages folder. I’ve tried to use a localization plugin (codestyling localization) to translate directly from WP admin. It says there’s about 5000 strings but can only read the first 9. Also, trying to “recount” all available translations leads to an unknown error.

Any thoughts?

best regards
/Jonathan


tigerton

September 23, 2014 at 7:32 am

Some additional details:

The files are named correctly and they originate from your own github repo.

I’ve set wp_lang in wp-config.php to sv_SE and in any case everything else is being translated, just not EE.

I have no plugins activated that is affecting translations/languages

the folders have 755

Running WP 4.0

Running latest EE 4.4.2.p

It’s a WPMU Network but EE is only activated on a single site and is otherwise running fine.


Lorenzo Orlando Caum

  • Support Staff

September 23, 2014 at 9:45 am

Hi Jonathan,

Could you give this a try:

http://translate.eventespresso.com/projects/event-espresso-4/sv/event-espresso-sv_SE

They are more up to date than Github.


Lorenzo


tigerton

September 23, 2014 at 10:04 am

Hi Lorenzo,

Unfortunately that doesn’t solve my problem since the issue is that the translations aren’t reading at all 🙂

I have tried them tho and no luck.


Lorenzo Orlando Caum

  • Support Staff

September 23, 2014 at 4:08 pm

Hi Jonathan,

I’ve asked a team member to check into this further and I have found a workaround by using the LOCO Translate plugin:

https://wordpress.org/plugins/loco-translate/

It works for me with the current version of Event Espresso 4 and WordPress 4.0.


Lorenzo


tigerton

September 24, 2014 at 3:24 am

I will try your workaround but first, is it possible I’ve got the naming wrong?

“event-espresso-sv_SE.mo”
and one .po file with same name 🙂


tigerton

September 24, 2014 at 3:36 am

EDIT:

I know that name is incorrect.. however it does not work with “event_espresso-sv_SE.mo etc. either


tigerton

September 24, 2014 at 4:05 am

SOLVED:
After I did some more digging it turns out that there was something wrong with the language settings in WordPress.
In the wp_sites table the language was set to sv_SE but in the wp_options for the single site (its a network as previously stated) the WPLANG option was empty. I filled in sv_SE and now its working 🙂

So sorry for taking up your time and thanks for the support. And thanks for the great tip of loco translation. Much cleaner than codestyling localization


Dean

September 24, 2014 at 4:16 am

Thanks for letting us know how you resolved it!

The support post ‘iCal button has encoding issues with Webkit’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Dean 5 years ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!