Support

Home Forums Event Espresso Premium How to stop Event Espresso Events showing on my Google 'events' listing

How to stop Event Espresso Events showing on my Google 'events' listing

Posted: February 10, 2019 at 9:34 pm


Wolff_Tickets

February 10, 2019 at 9:34 pm

We are having trouble finding out where to turn off Google events from pulling the information from website/event espresso events. We do not want some events to be showing to the public or on Google.


Josh

  • Support Staff

February 11, 2019 at 9:43 am

Hi,

You can install & activate these two plugins:

https://wordpress.org/plugins/wordpress-seo/
and
https://wordpress.org/plugins/event-espresso-smooth-integration/

Then you go to edit the event in question and go to the “Yoast SEO” box. Then you click the Advanced Settings tab. Then you set Allow search engines to show this Event in search results? to No.

Then you click the update button to save the changes.

Please note: When you request the search engines to stop indexing a specific page, it will take some time until they re-index the site for the changes to take effect.


Wolff_Tickets

February 14, 2019 at 5:04 pm

Hi Josh, we cannot seem to locate this step ‘Then you set Allow search engines to show this Event in search results? to No.’ we can see the Advanced Setting Tab but the options are different.
Thanks


Tony

  • Support Staff

February 15, 2019 at 3:14 am

You should see something like this – https://monosnap.com/file/vZOARVQUwT1T4ooI6G6k1A8Aj2RfJB

If not can you post a screenshot of what you do see:

https://eventespresso.com/wiki/troubleshooting-checklist/#screenshots


Wolff_Tickets

February 17, 2019 at 5:08 pm

Hi Tony, can you please tell me the steps you took to get to that screen? Thanks


Tony

  • Support Staff

February 18, 2019 at 5:29 am

I followed the steps Josh posted:

Then you go to edit the event in question and go to the “Yoast SEO” box. Then you click the Advanced Settings tab. Then you set Allow search engines to show this Event in search results? to No.

Edit your event and look for the Yoast SEO metabox – https://monosnap.com/file/lOJSVSIMZJlpv1NQMzf8Uy4VsXmbMi

So Event Espresso -> Events -> {Click on event}.

In that page find the above, click the cog icon and you’ll have the setting for that specific event.

  • This reply was modified 6 months, 1 week ago by  Tony.


Wolff_Tickets

February 24, 2019 at 9:39 pm

This reply has been marked as private.


Wolff_Tickets

February 24, 2019 at 9:44 pm

This reply has been marked as private.


Tony

  • Support Staff

February 25, 2019 at 2:20 am

Ok, what version number of Yoast are you using? You’ll find that in Dashboard -> Plugins.

It looks like you are using an older version, the latest versions look like my screenshot.

The setting you want to change is ‘Meta Robots Index’ and set it to no index.

The support post ‘How to stop Event Espresso Events showing on my Google 'events' listing’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 6 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!