Support

Home Forums Event Espresso Premium HELP! Students not able to complete payment

HELP! Students not able to complete payment

Posted: December 14, 2020 at 2:16 pm


socialsparkmedia

December 14, 2020 at 2:16 pm

I’m getting reports from students that they are unable to complete payment for their registration using Stripe. This started last week, I saw another post with the same problem and updated after you told that person to update. I sent out the payment links but they still can’t complete the transaction. These are $500 classes and I’m afraid I’m going to lose business. Is this a known problem? What should I do?


socialsparkmedia

December 14, 2020 at 2:18 pm

This reply has been marked as private.


Tony

  • Support Staff

December 14, 2020 at 2:38 pm

Hi there,

There’s a JaaScript error being thrown on the page when not logged in, if you disable AutoOptmize, if you disable JS optimization within AutOptimize and test whilst not logged in does it work then?

Side note, your site was set to not create payment logs which will be needed to troubleshoot what is happening here so I’ve enabled them to store logs for 7 days. This can be removed once the above is fixed.


socialsparkmedia

December 14, 2020 at 2:42 pm

This reply has been marked as private.


socialsparkmedia

December 14, 2020 at 2:43 pm

Ok, I’ll try that
It’s been that way for awhile, did something change?


socialsparkmedia

December 14, 2020 at 2:55 pm

This reply has been marked as private.


socialsparkmedia

December 14, 2020 at 3:22 pm

This reply has been marked as private.


Tony

  • Support Staff

December 14, 2020 at 3:27 pm

That error isn’t from Event Espresso, it’s your Stripe account and can happen if they’ve frozen/deactivated your account for any number of reasons.

Log into your Stripe account and check for any messages shown there, any issues on your account show?

Also, may I ask why you are using Stripe checkout vs Stripe elements?


socialsparkmedia

December 14, 2020 at 3:31 pm

OMG…Turns out that after 3 years of processing Stripe decided that they needed more info about the owner and PAUSED THE ACCOUNT! I’ve given them what they needed, now hopefully they’ll start again.

But I’d still like to fix the problem of the insecure content for the credit card image. How can I fix that? and is there a way to select it by default, since it’s the only payment method? I’m wondering if some people miss that and think it’s not working and abandon because of that.

Thanks for your help!


socialsparkmedia

December 14, 2020 at 3:40 pm

Well, I thought that would fix it…It let me pay, but now it’s stuck on the page with “proceed to finalize registration” button, and when I look in the registrations it still says pending… sorry.


socialsparkmedia

December 14, 2020 at 3:42 pm

I don’t know anything about Stripe Checkout vs Stripe Elements. If I should be using Elements I can change.


Tony

  • Support Staff

December 14, 2020 at 3:51 pm

Go to Event Espresso -> Payment methods -> Stripe.

That URL is likely used in the Button URL section, make sure the URL there is using HTTPS.

In that same section you can also set the ‘Open by default’ option to yes so that it automatically opens on the payment options step.


Tony

  • Support Staff

December 14, 2020 at 4:01 pm

The above error is where the payment logs come in handy but it looks like the user account provided no longer works so I can’t take a look?


socialsparkmedia

December 14, 2020 at 4:02 pm

Ok, I’ve gotten Elements installed and made those two changes. I tried to do the transaction again and it lets me pay, but then it stays on the registration screen and doesnt’ give me any indication that it’s complete. See screenshot: https://www.screencast.com/t/mIINcQgyg


socialsparkmedia

December 14, 2020 at 4:04 pm

This reply has been marked as private.


Tony

  • Support Staff

December 14, 2020 at 4:07 pm

The minimum payment amount with Stripe is 50c

So currently the payments throw this error:

Amount must be at least $0.50 usd

Try again with value more than 50c.


socialsparkmedia

December 14, 2020 at 4:24 pm

Thank goodness, that worked! How can I delete all of those dummy .00 transactions? I deleted the registrations.

Thank you so much for sticking with me through this, Tony. I really appreciate all the great support y’all give every time I need it.

Fran


Tony

  • Support Staff

December 14, 2020 at 4:47 pm

The 00 transactions within EE?

Did you just trash the registrations or perm delete them? (I’m guessing trashed them as Perm delete should have removed the transactions already)


socialsparkmedia

December 14, 2020 at 5:04 pm

I just trashed them, so now I’ve permanently deleted all but 1 that is locked because it says it has a payment associated. But I cancelled the registration and refunded the money, so I don’t know what else I need to do so I can delete it.


Tony

  • Support Staff

December 14, 2020 at 5:05 pm

Edit the transaction itself in EE, then delete each of the payments/refunds etc assigned to it, which should then allow you to delete the registration.


socialsparkmedia

December 14, 2020 at 5:05 pm

Nevermind! I finally saw the teeny-tiny trashcan in the payments box. ๐Ÿ˜‰


Tony

  • Support Staff

December 15, 2020 at 5:25 am

๐Ÿ™‚ I’m glad you foud it.

Any further problems just let us know.

The support post ‘HELP! Students not able to complete payment’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 months, 1 week ago ago

Topic Tags

Tagged: 

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!