Support

Home Forums Event Espresso Premium Grid/Table show_expired = false

Grid/Table show_expired = false

Posted: October 31, 2014 at 9:46 am


Michael

October 31, 2014 at 9:46 am

Hi, this option is not working for me on either the grid or the table.
show_expired = false

When I toggle this for the Calendar, it doesn’t show Sold Out events. I’d like this to be true for the Grid and the Table as well. Thanks


Tony

  • Support Staff

November 1, 2014 at 5:26 am

Hi Michael,

We have a fix for this due out with the next version of the Templates.

Currently if you use show_expired=0 that should work as expected.


Michael

November 3, 2014 at 7:54 am

thanks Tony, but I’m not having luck with that shortcode either.

Also, can you let me know the best way for me to keep my grid and table template edits after an upgrade? Currently I have made edits to each template directly. I know I can copy my edited templates over after each update, but I think there is a better way.


Lorenzo Orlando Caum

  • Support Staff

November 3, 2014 at 8:29 am

Hi,

You can copy the template files from here:

wp-content/plugins/name-of-template-addon/templates

…to here:

wp-content/uploads/espresso/templates


Lorenzo


Michael

November 3, 2014 at 8:35 am

does it need a sub-folder with the plugin name? thanks


Lorenzo Orlando Caum

  • Support Staff

November 3, 2014 at 10:32 am

No it doesn’t. I checked one of the recent tutorials that I created for the table template:

https://gist.github.com/lorenzocaum/6202e12ab276c08fc9dd


Lorenzo


Michael

November 4, 2014 at 10:03 am

Checking back in on this: Tony, the shortcode you provided is not working for me for Sold Out events.


Tony

  • Support Staff

November 4, 2014 at 12:06 pm

Hi Michael,

Expired events are events in which all of the datetimes have passed so Sold out events are not classed as expired.


Michael

November 4, 2014 at 1:05 pm

OK, got it. The Calendar plugin, however, treats Sold Out events as Expired. That is, if you aren’t showing Expired events on the Calendar, then Sold Out events will not show.

My goal is to not show SOld Out events in the Grid and the Table. Is this possible? Thanks


Michael

November 4, 2014 at 4:53 pm

ah, I got it.
add_post_type_support( ‘espresso_events’, ‘genesis-seo’ );

sorry-trying to meet a deadline.


Michael

November 4, 2014 at 4:54 pm

disregard-wrong thread


Josh

  • Support Staff

November 5, 2014 at 12:39 pm

Hi Michael,

It turns out the there’s a bug in the calendar add-on that makes it so the sold out events don’t display. Just so you’re aware on the next update Sold Out Events will show, but we’re adding a filter to exclude them in the calendar.

With the grid template, it’s possible to use the posts_where filter to add an additional WHERE clause to exclude specific events with specific statuses.

One thing to keep in mind when building the query is if there are multiple tickets for one event, you’ll need to make sure the query excludes the event if all the tickets are sold out.


Michael

November 11, 2014 at 1:05 pm

Thanks Josh. This is a bit beyond me right now but I will return to it when I have time.


Michael

November 13, 2014 at 11:23 am

Hi–I’m able to use show_expired=0 on the grid, but it doesn’t work on the table. I tried putting it at different places in the shortcode in case the order mattered, doesn’t seem to.
here’s my full shortcode:
[ESPRESSO_EVENTS_TABLE_TEMPLATE order_by = start_date, sort = ASC, limit = 100, show_expired=0, table_style = metro, template_file = espresso-events-table-template-toggle.template.php]

tested this on 4.4.5 with table 1.2


Michael

November 13, 2014 at 11:24 am

also, how can I show more than 10 events per page in the table? thank you


Tony

  • Support Staff

November 13, 2014 at 11:45 am

The default for the show_expired attribute is false.

So completely removing the show_expired attribute from the shortcode has the same effect as show_expired=false (when functioning correctly)

By default expired events are events in which all of the datetimes have passed that have passed.

To set the number of events per page add the table_pages parameter, for example ‘table_pages=20’ would set the pages to show 20 events each.


Michael

November 13, 2014 at 12:43 pm

thanks Tony. Removing the parameter fixed show_expired for the table.

But setting table_pages breaks the table; no events are shown when set.


Tony

  • Support Staff

November 13, 2014 at 1:27 pm

That’s strange, here is the shortcode I’m using:

[ESPRESSO_EVENTS_TABLE_TEMPLATE table_pages = 20 template_file = espresso-events-table-template-toggle.template.php]

And the output – http://take.ms/SOsDq

Are you using a customised template?


Michael

November 13, 2014 at 1:38 pm

ah-that worked for me. Putting that as the last parameter before the template_file, and removing the comma! thanks


Tony

  • Support Staff

November 14, 2014 at 9:08 am

No Problem,

I’m glad this is now working for you 🙂

The support post ‘Grid/Table show_expired = false’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 4 years, 8 months ago ago

Topic Tags

Tagged: , ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!