Support

Home Forums Event Espresso Premium Grid View Add On not working

Grid View Add On not working

Posted: November 13, 2015 at 8:07 am


Auric

November 13, 2015 at 8:07 am

I have installed the Grid View add on and used the following shortcode [ESPRESSO_GRID_TEMPLATE]. All that happens is I get events listed under one another, not a grid.


Tony

  • Support Staff

November 13, 2015 at 8:19 am

Hi there,

Can you link us to the page so we can view this please?


Auric

November 13, 2015 at 8:22 am

http://corp.capechamber.auric-consulting.com/


Tony

  • Support Staff

November 13, 2015 at 8:30 am

Looks like none of the styles/scripts for the add-on are loading on that page.

How are you using the shortcode? Through the page editor or via a template using do_shortcode()?


Auric

November 13, 2015 at 8:35 am

Using [ESPRESSO_GRID_TEMPLATE] shortcode. The theme we’re using as its own page builder but all our other plugins work fine. I found something about requiring wp_footer(), but I have no idea how to check that.


Josh

  • Support Staff

November 13, 2015 at 9:14 am

I checked your site and there’s a lot of JavaScript files near the closing body tag on the page, so that’s a good indication that wp_footer() is in place.

Can you try putting the grid view shortcode right inside the same content area where you have the text that says this?

Established in 1804, the Cape Chamber of Commerce and Industry is the oldest member-based business organisation in Africa. It is mandated to serve, enable and lead business. This is achieved through a plethora of services, networking opportunities as well as robust advocacy on behalf of business.


Auric

November 16, 2015 at 12:32 am

I tried that and got the same result.


Auric

November 16, 2015 at 12:57 am

I added the [ESPRESSO_GRID_TEMPLATE] shortcode to a page built without using the built-in page builder and it works fine.
http://corp.capechamber.auric-consulting.com/test-page-2/
So there must me a conflict of some kind.
Is this something you guys can resolve or is it a problem for the theme’s programmers? I’m hoping you can help because the support from AIT Themes is terrible.


Auric

November 16, 2015 at 2:42 am

Hi Josh, I have sorted this out. I rebuilt the page in the AIT Themes page builder from the ground up adding only items that were visible. I managed to add all the bits I needed without triggering any conflict. I’m not sure what caused the problem, but it’s sorted. Graham


Auric

November 16, 2015 at 4:02 am

It’s working but there is an issue. The hover action for the events in the grid displays the events but for some reason there are <br> added to space it, so with long event names it doesn’t look good. Is there any way to remove the <br> from the hover text? Using CSS I can vertically center align and tweak the line-height to get it to look better.


Auric

November 16, 2015 at 5:18 am

Also the format of the event pages themselves is all over the place – http://corp.capechamber.auric-consulting.com/events/supervisory-skills/


Lorenzo Orlando Caum

  • Support Staff

November 16, 2015 at 8:15 am

Hi Auric,

Could you let us know what isn’t working on the single events pages?

Other than a link issue, the formatting appears to be fine. Here is what I see on my end:

http://cl.ly/3r070f1p0c2u


Lorenzo


Auric

November 16, 2015 at 8:22 am

Hi Lorenzo – yes, that’s what I see. The core event details are fine but where the title/prices/featured image is displayed there’s something not right. I’ve been trying to find what CSS is messed up but no luck so far. Additionally if you check the HTML around the event title, Supervisory Skills in this case, there is an extra closing tag />, so you’ll see ‘”Supervisory Skills” />’ for some reason.


Lorenzo Orlando Caum

  • Support Staff

November 16, 2015 at 8:58 am

Hi Auric, I think the lightbox option may be interacting with the event status. Could you go to Event Espresso –> Events –> Templates in your WP dashboard?

Then look for the event status toggle for single event pages and turn that off.


Lorenzo


Auric

November 16, 2015 at 10:09 am

Thanks, that seems to be the answer. The CSS still needed some tweaking but at least it’s looking good now. Thanks Lorenzo.


Lorenzo Orlando Caum

  • Support Staff

November 16, 2015 at 11:00 am

Thanks for confirming Auric. Were there any other questions that we could help you with?


Lorenzo


Auric

November 19, 2015 at 5:50 am

This is resolved, please close.

The support post ‘Grid View Add On not working’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Auric 3 years, 12 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.