Support

Home Forums Event Espresso Premium Google Maps not displaying correctly on our EE events

Google Maps not displaying correctly on our EE events

Posted: September 29, 2018 at 1:20 pm


manders

September 29, 2018 at 1:20 pm

Recently we are seeing an error – This page can’t load Google Maps correctly” and shows For Developments Purposes only – why is this not displaying correctly again?


Tony

  • Support Staff

October 1, 2018 at 3:42 am

Hi there,

In short, Google Maps is no longer free and the watermark ‘for development purposes only is returned when any of the following is true:

  • The request is missing an API key.
  • Billing has not been enabled on your account.
  • The provided billing method is invalid (for example an expired credit card).
  • A self-imposed daily limit has been exceeded.

If you can link me to an event page I can view we may be able to tell which of the above needs fixing from the response from google.

More info can be found here: https://stackoverflow.com/questions/50977913/google-maps-shows-for-development-purposes-only

The support post ‘Google Maps not displaying correctly on our EE events’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 weeks, 5 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!