Support

Home Forums Event Espresso Premium General Settings page will not load

General Settings page will not load

Posted: November 9, 2018 at 9:09 am


siteclub

November 9, 2018 at 9:09 am

I am having some issues with event espresso. Our currency changed from CAD to USD, and we cannot change it as the GENERAL SETTINGS page doesn’t load. I checked the
known conflicts list and don’t see anything.

Getting the following error in logs:

Full error: 2018/11/09 16:08:26 [error] 12248#12248: *1556121 FastCGI sent in stderr: "t/plugins/event-espresso-core-reg/admin_pages/general_settings/OrganizationSettings.php:80
Stack trace:
#0 [internal function]: EventEspresso\admin_pages\general_settings\OrganizationSettings->__construct(Object(EE_Registry), Object(EE_Organization_Config), Object(EE_Core_Config), Object(EventEspresso\core\services\address\CountrySubRegionDao))
#1 /home/nscece/webapps/nscece/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(1262): ReflectionClass->newInstanceArgs(Array)
#2 /home/nscece/webapps/nscece/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(773): EE_Registry->_create_object('EventEspresso\\a...', Array, '', false)
#3 /home/nscece/webapps/nscece/wp-conte" while reading upstream, client: 172.68.58.165, server: www.nscece.ca, request: "GET /app/wp-admin/admin.php?page=espresso_general_settings HTTP/1.1", upstream: "fastcgi://unix:/var/run/nscece.sock:", host: "www.nscece.ca", referrer: "https://www.nscece.ca/app/wp-admin/admin.php?page=espresso_packages"

Is there a way we can quickly switch to CAD using a database replace or something? This is very urgent as our client is taking payments on their site for an upcoming event.

Thanks,
Alex


Josh

  • Support Staff

November 9, 2018 at 9:56 am

Hi Alex,

I’m afraid there isn’t a viable option to replace the values in the database for this, because the ee_config object is stored in the database as a serialized object.

Since the error message appears to be truncated, maybe you can activate WP_DEBUG mode so we can get the error message generated by WordPress? You can activate WP_DEBUG mode by going in to the wp-config.php file and change

define( 'WP_DEBUG', false );
to
define( 'WP_DEBUG', true );

Then you’ll try to load the General Settings page again and this time it will output an error message.


siteclub

November 9, 2018 at 10:41 am

Fatal error: Uncaught TypeError: Argument 4 passed to EventEspresso\admin_pages\general_settings\OrganizationSettings::__construct() must be an instance of EE_Network_Core_Config, instance of EventEspresso\core\services\address\CountrySubRegionDao given in /home/nscece/webapps/nscece/wp-content/plugins/event-espresso-core-reg/admin_pages/general_settings/OrganizationSettings.php:80 Stack trace: #0 [internal function]: EventEspresso\admin_pages\general_settings\OrganizationSettings->__construct(Object(EE_Registry), Object(EE_Organization_Config), Object(EE_Core_Config), Object(EventEspresso\core\services\address\CountrySubRegionDao)) #1 /home/nscece/webapps/nscece/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(1262): ReflectionClass->newInstanceArgs(Array) #2 /home/nscece/webapps/nscece/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(773): EE_Registry->_create_object('EventEspresso\\a...', Array, '', false) #3 /home/nscece/webapps/nscece/wp-content/plugins/event-espresso-core-reg/ in /home/nscece/webapps/nscece/wp-content/plugins/event-espresso-core-reg/admin_pages/general_settings/OrganizationSettings.php on line 80


Josh

  • Support Staff

November 9, 2018 at 11:00 am

I wonder if there’s a missing file within your copy of the Event Espresso 4 plugin. Can you try reinstalling? You can download a fresh copy of EE4 from your account page, then go to your site’s WP dashboard Plugins page. Then you deactivate & delete EE4, and install & activate the new copy.


siteclub

November 9, 2018 at 11:32 am

Hi Josh,

I deleted the plugin and reinstalled it as per your instructions, same issue. I also tried re-uploading the files via FTP, same issue. Any other suggestions?


Josh

  • Support Staff

November 9, 2018 at 12:02 pm

I would not advise to re-upload the files via FTP. That could actually cause issues, especially if the files were not deleted from the server before re-uploading.

May I ask is there any PHP byte code caching set up on this server? e.g. APC, Opcache, or even hhvm?


siteclub

November 9, 2018 at 12:07 pm

I renamed the old folder before uploading it via FTP to avoid any issues.

There is no opcache and we disabled cloudflare and wp rocket, the issue persists.


Josh

  • Support Staff

November 9, 2018 at 12:15 pm

That’s also problematic (renaming the older folder). Can you delete it instead? Then, you go to WP > Plugins and if there are more than one listing of Event Espresso there, delete all but one of them? Then, you deactivate the remaining plugin, then re-activate.


siteclub

November 9, 2018 at 12:20 pm

Still having the same issue.

I’m currently copying the website to another environment (plesk) instead of runcloud to see if that fixes the issue. Will update here.


Josh

  • Support Staff

November 9, 2018 at 12:29 pm

Runcloud’s documentation says:

With Atomic GIT Deployment, you don’t have to reload your PHP-FPM to clear the PHP Opcache. We will clear it automatically without reloading your PHP.

https://runcloud.io/docs/atomicdeployment/deployment-script.html#writing-your-deployment-script

If I assume you’re not using Atomic Git deployment, then maybe there’s a way to clear the PHP Opcache manually.


siteclub

November 10, 2018 at 8:00 am

Hi Josh,

I’ve tried moving the site to another server in a plesk environment, I’m having the same issue. Do you have any other suggestions?

Thanks


siteclub

November 10, 2018 at 12:41 pm

Hi Josh,

I disabled all other plugins on the site, as well as changed the theme to 2017, the issue persists. I’m still getting an error in my plesk logs, but the error isn’t appearing when I set WP_DEBUG to true.

AH01071: Got error 'EE_Core_Config), Object(EventEspresso\\core\\services\\address\\CountrySubRegionDao))\n#1 /var/www/vhosts/nscece.ca/httpdocs/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(1262): ReflectionClass->newInstanceArgs(Array)\n#2 /var/www/vhosts/nscece.ca/httpdocs/wp-content/plugins/event-espresso-core-reg/core/EE_Registry.core.php(773): EE_Registry->_create_object('EventEspresso\\\\a...', Array, '', false)\n#3 /var/www/vhosts...\n', referer: https://www.nscece.ca/wp-admin/update-core.php


Josh

  • Support Staff

November 12, 2018 at 8:26 am

We can look into this other issue, but on the original site, did you look into how to clear the PHP Opcache? If not, I can advise to contact your host to find out how to properly update files on the server so that the opcache gets cleared as opposed to switching hosts because opcache isn’t necessarily a bad thing to have.


siteclub

November 12, 2018 at 8:46 am

Hi Josh, I can confirm that we don’t use OPcache on both the servers we tested this on. We host these ourselves using Runcloud & Plesk so I am 100% sure.


Josh

  • Support Staff

November 12, 2018 at 8:48 am

May I ask why does Runcloud’s documentation mention Opcache if no opcache?

With Atomic GIT Deployment, you don’t have to reload your PHP-FPM to clear the PHP Opcache. We will clear it automatically without reloading your PHP.

https://runcloud.io/docs/atomicdeployment/deployment-script.html#writing-your-deployment-script


siteclub

November 12, 2018 at 9:01 am

Hi Josh,

I apologize, I didn’t make myself clear, this is Alex’s colleague – Mukul. I manage the servers for our business.

Yesterday, to isolate the issue I went ahead and cleared opcache on Runcloud and Plesk, then I disabled it manually by modifying the opcache.ini file for PHP 7.2

/etc/php72rc/conf.d/opcache.ini as so :

zend_extension=opcache.so
opcache.enable=0
opcache.revalidate_freq=0
opcache.max_accelerated_files=7963
opcache.memory_consumption=192
opcache.interned_strings_buffer=64
opcache.fast_shutdown=1

Then I restarted php 7.2 on the server and nothing changed with the issue. I also deactivated all other plugins except EE and switched the 2017 wp default theme on the site and we still had the issue.

So yes, I can confirm that OPCache is currently not active and I don’t think that is the issue.

Please let me know if you have any more suggestions or questions. This a high priority production issue for us, so any help would be much appreciated.

Our problem is that customers are being charged in USD instead of CAD and if there is any workaround to correct that, it can buy us some time to fix the actual issue.


Josh

  • Support Staff

November 12, 2018 at 9:35 am

Hi,

I checked with the developers and Opcache is the only thing they could think of that would cause the changing of the order of class constructor parameters (which is the issue that’s happening on your runcloud served site).

EE is loading the constructor parameters for classes using PHP Reflection
so the only way that a parameter could be passed incorrectly is if the system has two different schemas for a class ie: schema A says param #4 is X class and schema B says param #4 is Y class.

Maybe you can try running these commands in the terminal of the runcloud server?

php -i | grep -I apcu
php -i | grep -I opcache


siteclub

November 12, 2018 at 9:59 am

The apcu one didn’t give back a response. Here is the one for opcache:

root@web01:~# php -i | grep -I opcache
/etc/php72rc/conf.d/opcache.ini,
opcache.blacklist_filename => no value => no value
opcache.consistency_checks => 0 => 0
opcache.dups_fix => Off => Off
opcache.enable => Off => Off
opcache.enable_cli => Off => Off
opcache.enable_file_override => Off => Off
opcache.error_log => no value => no value
opcache.file_cache => no value => no value
opcache.file_cache_consistency_checks => 1 => 1
opcache.file_cache_only => 0 => 0
opcache.file_update_protection => 2 => 2
opcache.force_restart_timeout => 180 => 180
opcache.huge_code_pages => Off => Off
opcache.inherited_hack => On => On
opcache.interned_strings_buffer => 64 => 64
opcache.lockfile_path => /tmp => /tmp
opcache.log_verbosity_level => 1 => 1
opcache.max_accelerated_files => 7963 => 7963
opcache.max_file_size => 0 => 0
opcache.max_wasted_percentage => 5 => 5
opcache.memory_consumption => 192 => 192
opcache.opt_debug_level => 0 => 0
opcache.optimization_level => 0x7FFFBFFF => 0x7FFFBFFF
opcache.preferred_memory_model => no value => no value
opcache.protect_memory => 0 => 0
opcache.restrict_api => no value => no value
opcache.revalidate_freq => 0 => 0
opcache.revalidate_path => Off => Off
opcache.save_comments => 1 => 1
opcache.use_cwd => On => On
opcache.validate_permission => Off => Off
opcache.validate_root => Off => Off
opcache.validate_timestamps => On => On


Josh

  • Support Staff

November 12, 2018 at 11:20 am

If you can complete the secure form on this page, we can investigate further:

https://eventespresso.com/send-login-details/


siteclub

November 12, 2018 at 4:55 pm

Hi Josh,

I have setup SFTP and a WP admin account and submitted the info at the above link.

Thanks,

Mukul


Josh

  • Support Staff

November 13, 2018 at 9:39 am

Hi,

Thanks for sending. While I cannot figure out why your site is getting the params mixed up on the General Settings page, I did find that you can access the Country settings page.

You can access the Country settings page by going to your live site’s WP dashboard, then input this into the end of the URL:
/wp-admin/admin.php?page=espresso_general_settings&action=country_settings

There, you can set the Country Currency Code to CAD. You’ll set that for the United States in this case, because your site isn’t allowing to change anything on the General settings page. After you make the change, you click Save. Then you’ll likely need to clear all caches. This will effectively change the currency on the site to use Canadian dollars.


Josh

  • Support Staff

November 13, 2018 at 1:47 pm

Update:

One of the developers was able to investigate your site today, and added a bit of code to the dev site’s /core/EE_Network_Config.core.php file, and the General Settings page loads there now. It may be one of the other plugins loading things onto that page managed to alter one of the properties, so the fix just makes sure those properties are set up correctly. You can copy that file over to your production site, then the production site’s General Settings page should load OK.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Josh 6 days, 3 hours ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[i]
[i]