Support

Home Forums Event Espresso Premium "From" Email address

"From" Email address

Posted: August 5, 2020 at 8:46 am


SteveMBragg

August 5, 2020 at 8:46 am

Hi all

Even though I have set up EE with a Primary Contact email address of : enquiries@ntlbiologica.com, people are getting their confirmations from the site admin email (mine: steve@datasystemsmanagement.co.uk).

THis means that they are communication with me and not the client. How do I stop this please?

Regards

Steve B


Tony

  • Support Staff

August 5, 2020 at 9:55 am

Hi Steve,

Which specific email are you referring to?

By default Event Espresso uses the [CO_EMAIL] shortcode within its message templates ‘To’ field, which parses to the ‘Primary Contact Email Address’ field set in General Settings.

If you go to Event Espresso -> Messages -> Default message templates (assuming you aren’t using custom templates for you events?)

Find ‘Registration Approved’ in the list and click on ‘Edit Registrant’.

When that loads, what is set in the ‘From’ field of that template?


SteveMBragg

August 5, 2020 at 11:44 am

Hi Tony

That field shows: [CO_EMAIL]

But customers are getting emails from “steve@datasystemsmanagement.co.uk” NOT the email set in the EE Settings.

In your system is [CO_EMAIL] the same as the site Admin Email?

Steve


Tony

  • Support Staff

August 5, 2020 at 1:53 pm

In your system is [CO_EMAIL] the same as the site Admin Email?

No, it is the value set in Event Espresso -> General Settings -> Your Organization -> Primary Contact Email

On initial activation of EE we copy the value from Dashboard -> Settings -> General -> Administration Email Address but after that there’s no connection.

Are you using any SMTP plugins or transactional email services?


SteveMBragg

August 6, 2020 at 2:04 am

No I am not (SMTP plugins). Email is controlled by the core WP installation.

Customers are receiving their booking notifications then writing to me as the site developer and not the customers email address.

Steve


SteveMBragg

August 6, 2020 at 3:42 am

Hi Tony

This is an email sent to me by one of the clients customers when I asked how she was writing to me. This is what she said:

“Good morning Steve

Your email appears on the registration confirmation as well as that of NTL Biologica. I emailed both addresses hoping to receive a reply from either of you.

Thank you for answering my query. Much appreciated.”

Any help welcome

Steve


SteveMBragg

August 6, 2020 at 4:12 am

Hi Tony

I have found what is going on. On the registration email is a box with the social media “connect with us” stuff.

This has my emails address in it. Where do I change this please?

It says this:

“CONNECT WITH THIS EVENT:

Facebook

Twitter

CONTACT INFO:

Phone:
Email: steve@datasystemsmanagement.co.uk

Steve


SteveMBragg

August 6, 2020 at 7:24 am

Hi Tony

I think I have found the issue, in the body of the email format.

THanks

Steve


Tony

  • Support Staff

August 6, 2020 at 8:45 am

Ok, so users are not getting the email from your email address then and it that makes sense.

The ‘Connect with this event’ section uses event-specific values so will be using the event [EVENT_AUTHOR_EMAIL] shortcode. You can switch that out to use [CO_EMAIL] to use the Primary Contact email for all, or switch our the author of the events so you are no longer set as the event author.

Changing the shortcode is done in Event Espresso -> Messages -> Default message templates -> Registration Approved -> Edit Registrant.

In the event list section swap out the [EVENT_AUTHOR_EMAIL] shortcodes listed, I recommend doing this in text mode:

https://monosnap.com/file/8plnCN9lexDASs5MR3uicub2F61KmX

Changing the author is done when you edit the event:

https://monosnap.com/file/TZ6EfUicxplwFPNHskjHYRbHe7OrJi

Either one of those will prevent your email from showing in that section, obviously, EE would use the email address for whichever user you select as the Event Author.


SteveMBragg

August 6, 2020 at 9:19 am

Thanks. I did find that you can’t seem to change the shortcode in WYSIWYG mode only in the TEXT mode. Which I have now done
Cheers

Steve


Tony

  • Support Staff

August 6, 2020 at 10:09 am

No problem, glad you figured it out.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 2 months, 3 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!