Support

Home Forums Event Espresso Premium Fatal Error on line 1327

Fatal Error on line 1327

Posted: June 18, 2016 at 5:23 am


jamesashford

June 18, 2016 at 5:23 am

HI,

Just got everything set up and ran a test and worked perfectly.

Then tried again and now I’m getting a fatal error on the registration page.

It doesn’t have a theme or any other plugins yet so there can be no conflict.

This is the page

http://www.trainwithpremier.com/index.php/registration-checkout/

This is the error message

Fatal error: Call to a member function unlock() on null in /var/www/vhosts/trainwithpremier.com/wp-content/plugins/event-espresso-core-reg/modules/single_page_checkout/EED_Single_Page_Checkout.module.php on line 1327

Any ideas?

Ta


jamesashford

June 18, 2016 at 5:29 am

Only seems to be the case if I’m logged into the site?!?!? So it’s not really a problem.

Weird that it started doing that though.

Ta


jamesashford

June 18, 2016 at 5:45 am

Actually, It’s happening again.

It appears that once you’ve been through the payment process once it’s fine (just done it in a new browser where I’m not logged in).

Then when you try again you get the same error.

Any ideas?

Ta


Lorenzo Orlando Caum

  • Support Staff

June 18, 2016 at 10:33 am

Hi James,

Are you seeing this on the latest version of Event Espresso?

https://eventespresso.com/wiki/ee4-changelog/


Lorenzo


jamesashford

June 19, 2016 at 4:31 am

Hi Lorenzo,

Thanks for the fast reply.

There’s nothing there about it and I have version 4.9.1 in any case.

It seems to have cleared now. It appears that it’s a time thing, so If you try and make another purchase shortly after making one, that’s when the error appears.

There also just appears to be a few other things wrong and I haven’t messed about with anything.

So nearly all of the emails which go out appear spannered too and all the html is broken.

The one’s going out to admin are fine, but ones going to the registrant are broken. Never changed them and reset them but still not working.

I just want to make sure EE4 is solid and reliable.

I’m happy to pay for support to get things corrected but I thought it was almost plug and play.

Cheers,

James


Lorenzo Orlando Caum

  • Support Staff

June 20, 2016 at 4:06 am

Hi James,

The local email server may be making some changes as those emails are being sent out. Try setting up a free transactional email server like Mailgun or Sendgrid to correct this issue:

https://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/

That will take over sending emails from the local email server through the native wp_mail function.

Here is a step by step guide for Sendgrid:

https://gist.github.com/lorenzocaum/4677f472b012a5a88630


Lorenzo

The support post ‘Fatal Error on line 1327’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Lorenzo Orlando Caum 3 years, 5 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.