Support

Home Forums Event Espresso Premium Events Disappeared

Events Disappeared

Posted: May 8, 2013 at 3:02 pm


lfhershberger

May 8, 2013 at 3:02 pm

Hi, upgraded to 3.1.32p today and my events are no longer showing on the listing page or individual pages. Only the shortcode shows up [ESPRESSO_EVENTS].

Main Events Page: http://www.lesliehershberger.com/events/

Individual Event Page: http://www.lesliehershberger.com/events/?ee=22

did the shortcode change or is something going wrong?

Thanks!

-ryan


Josh

  • Support Staff

May 8, 2013 at 5:50 pm

Hi Ryan,

I’m sorry for the trouble. Can you go into Event Espresso>General Settings and check the page settings set there? The main registration page setting should be set to point to the page you have with the [ESPRESSO_EVENTS] shortcode on it.


lfhershberger

May 8, 2013 at 9:43 pm

Hey Josh – yeah, it was set correctly, same settings as before to a page titled Events with url .com/events. I set up a test page and switched the general settings to that page and it worked. I then set it back to the original events page and it’s still not working. I’d prefer not to have to delete this page and do it again, and not even sure if that would solve the problem. Any idea what’s going on here? I can pass an admin login if you’d like.

thanks!

-ryan


Josh

  • Support Staff

May 9, 2013 at 7:50 am

The “events” slug is also used by the custom post type feature, so there may be a conflict going on, especially if the custom post types feature is turned on in Event Espresso>Template settings.

Aside from that, the only other solution I can think of would be to switch the main registration page to use a different page slug. The title of the page could still be events, but the slug would need to be different.


lfhershberger

May 9, 2013 at 10:01 am

huh weird. it worked fine before but only stopped working after the update. Just turned off the custom post type feature since we’re not using it, but still not working.

really prefer not to have to change the slug since it’s been in use for so long. When changing the slug it works, so guessing it’s something to do with the slug. wonder if wiping that custom post type from the db would help.


lfhershberger

May 9, 2013 at 11:08 am

Also, I know see a cal icon to import the event rather than the actual date displaying:

http://cl.ly/image/2Y391C0D2c2M

How do we get the date text back?


Josh

  • Support Staff

May 9, 2013 at 11:50 am

It looks like the other events all have dates, it’s the first one where the date is missing. You can check to see if there is a start + end date and time entered for the first event in the list.

With the other issue you’re having with the page with the slug of “events”, it may help to flush the rewrite rules by going to the WP->Settings->Permalinks page and saving the settings there.


lfhershberger

May 9, 2013 at 12:07 pm

ah, right you are! thanks 🙂

tried flushing rewrite, but still didn’t work. guessing I’d have to go into the db somewhere to fix that. oh well, we’ll just roll with this for now.

thanks!

-ryan


Josh

  • Support Staff

May 10, 2013 at 3:32 pm

It might be worth looking in the wp_options table under “rewrite_rules”. It’s all serialized data there though, so it should be handled with care (make a backup of the database and copy the contents of the option_value) before making any changes there.

The support post ‘Events Disappeared’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 6 years, 7 months ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!