Support

Home Forums Events Calendar Add-on Events calendar not showing

Events calendar not showing

Posted: July 12, 2012 at 11:48 pm


Sean Rietze

July 12, 2012 at 11:48 pm

When I use the shortcode [ESPRESSO_CALENDAR] by itself on a page, the events calendar is not displayed. Not sure if the jquery is getting executed or not? CSS? I have created a couple open events for testing. Event list page works and so does calendar in sidebar, just not embedded in page. thanks for your help.

http://votenoprop123.com/event-calendar/


Seth Shoultes

  • Support Staff

July 13, 2012 at 7:21 am

Your theme is adding paragraph tags around the calendar script. Try adding [raw][/raw] tags around the calendar shortcode.

Should look like this:
[raw][ESPRESSO_CALENDAR][/raw]


Josh

  • Support Staff

July 13, 2012 at 7:23 am

Looks like the theme is auto-formatting paragraph tags within the calendar JavaScript. Try wrapping the calendar shortcode in [raw] short tags.
[raw][ESPRESSO_CALENDAR][/raw]

See the troubleshooting section of the calendar documentation for more info.

https://eventespresso.com/wiki/calendar/#troubleshooting

enter image description here


Sean Rietze

July 16, 2012 at 3:13 pm

Thanks. The [raw] shortcode did the trick. Works great.


Hawaiisportmag

July 26, 2012 at 7:31 pm

Hi,
the calendar shortcode [ESPRESSO_CALENDAR], is not by itself on a page for me.
I tried the [raw] tags and it didn’t help.
website: http://www.hawaiisportmag.com
I have also created a couple open events for testing.
We are looking forward to use the calendar.
Thank you for your help.


Josh

  • Support Staff

July 26, 2012 at 9:25 pm

Hi Tai,

It looks like the scripts are missing from the footer. Check the footer.php file of the theme for the wp_footer() function. See this section of the calendar documentation for more info: https://eventespresso.com/wiki/calendar/#troubleshooting


Hawaiisportmag

July 27, 2012 at 6:01 pm

Thank you for the quick reply.
However, I added the code: just before the closing body tag, but the calendar still not showing up. Waht should I do next?
thanks!


cg

July 29, 2012 at 10:54 pm

Hello,

I’d like to know also. I’ve read through the wiki and created a calendar template but that did nothing. Also added raw code and again, nothing. Everything else seems to be in order (I don’t see any js conflicts and the footer is in order).

The only other plugins installed are yours.

I don’t know what else the issue could be. What else do I need to do please?

  • This reply was modified 8 years, 7 months ago by  cg. Reason: Clarification


Seth Shoultes

  • Support Staff

July 30, 2012 at 12:00 am

tai and cg,

Please post a link to the pages that are not working.


cg

July 30, 2012 at 7:36 am

http://coineducation.com/class-schedule/


Josh

  • Support Staff

July 30, 2012 at 9:50 am

Hi cg,

The active WordPress theme’s custom.js is throwing an error at line 11.


Josh

  • Support Staff

July 30, 2012 at 10:10 am

@Tai,

check the tabs.js file in the current WordPress theme. It’s referencing jQuery with the $, which is throwing an error because jQuery is being loaded in safe mode.

Swap out the $ for jQuery, or wrap the entire function in a no-conflict wrapper: http://digwp.com/2011/09/using-instead-of-jquery-in-wordpress/


cg

July 30, 2012 at 10:40 am

Hi Josh,

Thanks but what does that mean please? How do I resolve it?


Josh

  • Support Staff

July 30, 2012 at 12:25 pm

It’s an issue specific to this theme. You may need to contact the theme developer/author for information on how to fix this, as we do not offer support for 3rd party themes.

That said, the specific error message is: Uncaught TypeError: Object [object Object] has no method ‘validate’ ,
and looking at the page source, I can’t find the jQuery validate plugin. Without this plugin, jQuery will not have a validate method so that would explain the “no method validate” error.

Check a fresh copy of this theme to see if it enqueues and includes this script. It usually is something like jquery.validate.min.js and can be found in the theme’s js directory. Event Espresso also uses this script, but only on pages where there’ll be a form that needs validation.


cg

July 30, 2012 at 12:46 pm

Hi Josh,

Okay, thanks. I will follow up with the theme developer!


Hawaiisportmag

August 1, 2012 at 10:02 pm

Josh,
thank you for your reply and tips.
however, I am stuck…and the calendar still not working:(
what should I do?!
thanks again


Josh

  • Support Staff

August 2, 2012 at 10:00 am

Hi Tai,

Try this:

1) Open up the tabs.js file from the scripts/js/ folder of the current WordPress theme.
2) Change it so it loads in no-conflict mode:

jQuery(document).ready(function($) {
    $('#londontabs > ul').tabs({ fx: { height: 'toggle', opacity: 'toggle' } });
    $('#tabsheader > ul').tabs({fx: {height:'toggle', opacity:'toggle'}});
    $('#featuredvid > ul').tabs();
});
    jQuery(document).ready(function($){
        $("#featured > ul").tabs({fx:{opacity: "toggle"}}).tabs("rotate", 5000, true);
    });

/*window.onload = function() {$('#Picture').hide().fadeIn(3000);};*/

2) Open up the custom.js file from the same theme and make the same changes:

// JavaScript Document

jQuery(function($) {
$(".imgf").css("opacity","1.0");
$(".imgf").hover(function () {
$(this).stop().animate({
opacity:0.5
}, "slow");
},
function () {
$(this).stop().animate({
opacity: 1.0
}, "slow");
});
});

jQuery(function($) {
$(".shareimg").css("opacity","0.7");
$(".shareimg").hover(function () {                                      
$(this).stop().animate({
opacity: 1.0
}, "slow");
},    
function () {        
$(this).stop().animate({
opacity: 0.5
}, "slow");
});
});


jQuery(document).ready(function($) {
$('.toparrow').click(function(){
$('html, body').animate({scrollTop:0}, 'slow'); return false;
});
});

jQuery(document).ready(function($){
$("ul.firstnav-menu").superfish({
animation: {opacity:'show', height:'show', width:'show'},   // slide-down effect without fade-in
delay:200,               // 1.2 second delay on mouseout
autoArrows: false,
speed: 'fast',
dropShadows: false
});
})

jQuery(document).ready(function($){
$("ul.secondnav-menu").superfish({
animation: {opacity:'show', height:'show', width:'show'},   // slide-down effect without fade-in
delay:200,               // 1.2 second delay on mouseout
autoArrows: false,
speed: 'fast',
dropShadows: false
});
})

jQuery(document).ready(function() {
    jQuery('#slide_').jcarousel();
});

jQuery(document).ready(function($){
            $("a[rel^='prettyPhoto']").prettyPhoto({
            default_width:640,
            default_height:344
            });

    });

3) Contact the theme author and request that they update the theme so jQuery can load in safe (no-conflict) mode. This will reduce the amount of support required for anyone using this theme.


Hawaiisportmag

August 2, 2012 at 2:31 pm

Josh,
your support is great! thank you!
it is working now:)
have a great aloha friday!


cg

August 2, 2012 at 2:35 pm

Hi Josh,

Its been a few days since I followed up with the theme developer. It doesn’t appear that their support forum is very active.

What are my options to get this working?


Josh

  • Support Staff

August 2, 2012 at 3:05 pm

You might try deleting the following lines from the theme’s custom.js file:

//Contact validate
jQuery(document).ready(function(){
    jQuery("#contactForm").validate();
});

And then use a plugin for the contact form. The contact form 7 plugin would be my recommendation.

Beyond that, we offer support tokens for premium support where we’ll fix the theme.


Rachel roberts

August 9, 2012 at 1:15 pm

Hello!

I’m trying to insert the calendar, but it’s not showing up. Basically the events page ends up looking just like the home page. I’ve tried the [raw] tags, but they don’t seem to work.

http://mydesignandwine.com/wordpress/events/


Josh

  • Support Staff

August 9, 2012 at 2:00 pm

Hi Rachel,

Is this page set to use the same template that the home page is using? That’s what I would check first.


Rachel roberts

August 9, 2012 at 2:46 pm

I’ve tried all the possible templates, and no matter what template I select, it still shows up the same. :/


Josh

  • Support Staff

August 9, 2012 at 3:08 pm

Let’s take a step back then. Can you try switching to the twentyeleven theme temporarily?


Rachel roberts

August 9, 2012 at 4:21 pm

Yep, that shows it.


Josh

  • Support Staff

August 10, 2012 at 8:22 am

Can you contact the theme author and check with them to see if they allow 3rd party shortcodes? I am not familiar with how that theme works, or why it would override the content on that page.

A possible solution would be to create a custom page template to display the calendar. At the very end of this doc, there is an example of how to create a custom calendar page template.


Chris Reynolds

  • Support Staff

August 21, 2012 at 11:46 am

@cg
There are 70 javascript errors on the page and 2 warnings that insecure content is being served when viewing the site in https. The insecure content warnings are being thrown by your Google webfont (there are ways of automatically getting an https or http url from Google depending on whether the page is being viewed in https — this could be done by using the Google Web Font loader script or adding a conditional statement to your header or the theme’s functions.php (wherever you’re loading the webfont) to check for ssl eg: if (is_ssl()) { /* do something secure */ } else { /* do something else */ }) and by your logo image which is being loaded in http (http://coineducation.com/wp-content/uploads/2012/07/CESC_LOGO_300x90.png — this can be resolved by using the home_url() function in WordPress rather than hard-coding it or using some other means of getting the root directory). However, the insecure content issues are secondary…

Most of the javascript errors are coming from Google Maps, and I’m assuming they’re relating to the map you have in your footer. The other javascript error is coming from prettyPhoto which is trying to be added to a custom.js file that Josh referred to earlier. If contacting the theme developer has not yielded any results, what you might try is just commenting-out or removing those lines in your /wp-content/themes/bizway/js/custom.js file, e.g. find this:

/*--------gallery--------*/
jQuery(document).ready(function(){
    jQuery(".gallery:first a[rel^='prettyPhoto']").prettyPhoto({
        animation_speed:'normal',
        theme:'light_square',
        slideshow:8000, 
        autoplay_slideshow: true
    });
});

and change it to this:

/*--------gallery--------*/
/* commenting this out for testing
jQuery(document).ready(function(){
    jQuery(".gallery:first a[rel^='prettyPhoto']").prettyPhoto({
        animation_speed:'normal',
        theme:'light_square',
        slideshow:8000, 
        autoplay_slideshow: true
    });
});
*/

This will remove the gallery javascript (which you may or may not be using) but it will determine whether that’s what’s causing the issue or not. If that doesn’t solve the problem, try removing the Google Map in the footer (not sure if that’s being added via a plugin or if you’re hard coding it in a text widget).


cg

August 22, 2012 at 9:24 am

Hi Chris,

Actually, the map is a regular WP widget with iframe code I grabbed from Google Maps. I do need a map there so any other alternatives?

I will take care of the rest.

Thanks


Chris Reynolds

  • Support Staff

August 22, 2012 at 10:22 am

There probably are alternatives, but I would just try it without for now, to see if that helps with your calendar issue. If the calendar displays without the map, add the map back in and test again. If it disappears, I’d start hunting for an alternative — either use the code directly from Google or a different plugin/widget or get a static map image that links to the Google Map…


cg

August 22, 2012 at 11:16 am

Hi,

I added that code you gave me and removed the map but the calendar still isn’t showing.


Chris Reynolds

  • Support Staff

August 22, 2012 at 11:48 am

There’s still a javascript error coming from prettyPhoto, so that part hasn’t been resolved yet. Which means that’s much more likely to be the problem than the map. If you comment out that function as I suggested here and still get the problem, I’ll download the BizWay theme and do some testing locally to see if I can track down the issue. Currently that looks to be the most likely candidate.


cg

August 22, 2012 at 12:24 pm

Hi Chris,

I did comment out the function. I used Notepad to edit the js file. Not sure if that’s what I was supposed to use but when I download the file from my server, I can see the comment out is there.

Maybe you can take a look into the theme and let me know please.


Chris Reynolds

  • Support Staff

August 22, 2012 at 12:47 pm

I installed BizWay version 1.6 and I was able to get the calendar to display by commenting out the validation function in custom.js:

//Contact validate
/*jQuery(document).ready(function(){
    jQuery("#contactForm").validate();
});*/

The version that I downloaded did not have a prettyPhoto function at all…maybe you’re using an older version?


cg

August 22, 2012 at 1:17 pm

Hi Chris,

Yes, I am definitely using an older version, BizWay v. 1.2. I just downloaded it only a few weeks ago from the WP theme repository.

Is that the same place where you found BizWay 1.6?


Nevermind, I see they updated the theme on 07-23. Okay, will update and report back!

  • This reply was modified 8 years, 6 months ago by  cg.


cg

August 22, 2012 at 1:22 pm

Hi Chris,

Can you provide an example of how you commented out this function? I just want to make sure that I’m doing the right thing.


cg

August 22, 2012 at 1:33 pm

I see where you actually provided the code for me…. lol… I’m a little sleep deprived.

But yes! It’s working! So thankful! Thanks a million Chris!


cg

August 22, 2012 at 1:59 pm

Hi Chris,

I noticed that my calendar is showing the same month, twice.

Also, the event that’s showing is only held on Saturdays. Why is it showing every day of the week?

Here’s the link:

http://coineducation.com/registration/class-schedule/


Chris Reynolds

  • Support Staff

August 22, 2012 at 2:26 pm

I’m looking at your calendar page now and I don’t see it displaying at all. However, generally if the calendar is displaying twice, it’s because you are using the calendar widget and haven’t set the calendar page in the widget settings. (Or you’re actually using the shortcode twice.)

And since I can’t see your calendar, I can’t tell you exactly why it’s displaying on every day of the week unless you have set the event start date to be one saturday and the event end date to be a saturday several weeks in advance. That makes Event Espresso think that the event spans the entire time. If you are trying to display an event that occurs on multiple different Saturdays, you will need separate events for each occurrence.


cg

August 22, 2012 at 2:33 pm

I am looking at my calendar, while logged in and logged out. Not really sure why you can’t see it.

I thought the point of recurring events was simplify the process of adding the events. I have classes that meet for 12 week sessions (on Saturdays) throughout the year. That seems a bit tedious to me.


Chris Reynolds

  • Support Staff

August 22, 2012 at 2:52 pm

I had to refresh my cache, I see the calendar(s) now. Though I’m not sure why it’s displaying twice (unless it’s one of the options I mentioned).

Now that I’m looking at your calendar, I can see that you set the event start date for “Oracle Database Administration Program [6-week Bootcamp]” to November 3, 2012 and the event end date to December 8, 2012 — that means that, according to how you set up the event, the event starts at 9am on November 3 and ends at 5pm on December 8. What I have suggested in the past is to create a separate event for each class in the series. Then edit the second event and all events after it by setting an alternate registration URL to be that of the first event. That way, when they click on other events in the series, they’ll be redirected to the first event to register.

Tedious, yes, but this is the only way the system can handle multiple events in a series, which is what you are trying to do. There will be more robust support for this when 3.2 comes out.


cg

August 22, 2012 at 2:55 pm

When is 3.2 coming out?


Chris Reynolds

  • Support Staff

August 22, 2012 at 3:20 pm

Approximately 83 tickets from now.


Peter Button

September 3, 2012 at 9:42 pm

I have the same problem where I added the calendar shortcode to my cooking school page. It showed up blank so I wrapped the calendar shortcode in [raw] short tags… as follows
[raw][ESPRESSO_CALENDAR][/raw]

The part of the page where I wanted the calendar to appear ended up looking like this

[raw]

[/raw]


Seth Shoultes

  • Support Staff

September 3, 2012 at 10:18 pm

@peter what is the URL to the site?

The support post ‘Events calendar not showing’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Seth Shoultes 8 years, 5 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!