Support

Home Forums Translations Event espresso 4 decaf to swedish

Event espresso 4 decaf to swedish

Posted: September 19, 2018 at 7:09 am


Sven Ryglert

September 19, 2018 at 7:09 am

Panel language set to Swedish
Settings in Espresso set to Swedish
The files:
event-espresso-4-sv_SE.mo
event-espresso-4-sv_SE.po
is looking good in file size and translation
I have created /wp-content/uploads/espresso/languages and uploaded the po and mo and the index.php files into the folder

Still not working

There is an /wp-content/plugins/event-espresso-decaf/languages folder. I have tried to use that folder but no success.

Am I missing something?

WordPress Version: 4.9.8
PHP Version: 7.2.8
MySQL Version: 5.5.5
Event Espresso Version: 4.9.67.decaf
WordPress Address (URL): http://minibiggame.torsaspaintball.se
Site address (URL): http://minibiggame.torsaspaintball.se


Sven Ryglert

September 19, 2018 at 7:20 am

And yes, I have been trying to deactivate all other plug-in and changed the theme to 2015 whit no result.


Tony

  • Support Staff

September 20, 2018 at 5:05 am

Hi there,

The files:
event-espresso-4-sv_SE.mo
event-espresso-4-sv_SE.po
is looking good in file size and translation

Just to confirm, where did you download those files from?

I have created /wp-content/uploads/espresso/languages and uploaded the po and mo and the index.php files into the folder

That should override the default MO file as long as WP has the correct permissions to access that directory.

There is an /wp-content/plugins/event-espresso-decaf/languages folder. I have tried to use that folder but no success.

Please do not use this directory, EE will download a default MO file and use that, each time EE updates any modifications made will be lost.

Did you originally have a event_espresso-sv_SE.mo file in that directory?


Sven Ryglert

September 24, 2018 at 1:16 am

I downloaded from https://translate.eventespresso.com/projects/event-espresso-4/

The permissions for the upload and subfolders have the numeric 750

Ok. I have been removing the files from /wp-content/plugins/event-espresso-decaf/languages

No, there was just ee-js.pot, ee-js.pot.php and index.php ine there


Sven Ryglert

September 24, 2018 at 1:26 am

Event Espresso is also ignoring the WordPress settings for time (H:i)


Tony

  • Support Staff

October 3, 2018 at 8:08 am

I’ve spent some time trying to reproduce this but so far everything is working as expected.

I’ve set my WordPress language to Svenska so it uses sv_SV – http://take.ms/6O8VX

As you can see EE is correctly translated and that is using the default sideloaded file that would normally be within /plugins/event-espresso-decaf/languages

Adding your own version to /wp-content/uploads/espresso/languages/ would override the original file and use the custom translation file.

Are you using WP multisite? Or maybe a multi language site?

It seems strange that no languages files work at all and the ‘standard’ .mo file isn’t being downloaded to the core plugin itself.

Event Espresso is also ignoring the WordPress settings for time (H:i)

I’ve also set my sites time format to use H:i which is respected on the front end of the site – http://take.ms/LOsyj

On which page/location do you see this?

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for translations.
Post any questions about the language files or translating Event Espresso here. Interested in helping translate Event Espresso? View our guide on how to translate Event Espresso.

Status: publish

Updated by  Tony 1 week, 4 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!