Posted: June 19, 2015 at 3:22 pm

Wassim Zeidan

June 19, 2015 at 3:22 pm

I installed a new theme and I had some compatibly issues so I enabled debug mode in wp-config.php and I received the following errors

Notice: Use of undefined constant WPLANG – assumed ‘WPLANG’ in /home/lebtour/public_html/wp-content/plugins/event-espresso/espresso.php on line 285 and 308
The solution was just by adding define(‘WPLANG’, ”); in wp-config.php

Strict Standards: Non-static method EE_VLM_DSCNT::instance() should not be called statically in /plugins/espresso-volume-discounts-pr/espresso-volume-discounts.php on line 1452

Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /plugins/espresso-volume-discounts-pr/espresso-volume-discounts.php:1452) in /plugins/event-espresso/espresso.php on line 55

Any idea to solve this?


June 22, 2015 at 2:06 am

Hi Wassim,

The Strict standards notification will not show once WP_DEBUG is disabled (which it should be for live sites). The Strict standards is not an error as such, it is just advising that Strict standards are not being followed for that particular line.

If you need WP_DEBUG running but wish to hide Strict Standards notifications you could follow this StackExchange post and create a must use plugin which will disable Strict notifications:

The support post ‘Errors’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Dean 5 years ago ago

Topic Tags


This topic is: not resolved
Do NOT follow this link or you will be banned from the site!