Support

Home Forums Event Espresso Premium Errors occurred communicating with Mijireh

Errors occurred communicating with Mijireh

Posted: December 30, 2014 at 1:04 pm


Matt tuttle

December 30, 2014 at 1:04 pm

Hello,

I’m getting the following error after clicking “Finalize Registration” here: https://pkug.org/conferences/rapid-response-2015/event-registration/?ee=_register

Has anyone else run into this and how did you fix it?


Sidney Harrell

December 30, 2014 at 4:46 pm

I’m just getting a “Nothing in your event que” error message when I click that link. If you are getting a different error message, can you take a screenshot of it? (post the screenshot to something like dropbox, so you can post a link to it here)


Matt tuttle

December 31, 2014 at 4:18 am

Here’s a link to the screenshot.

https://pkug.org/wp-content/uploads/2014/12/ee-error.jpg


Lorenzo Orlando Caum

  • Support Staff

December 31, 2014 at 5:12 am

Hi, could you double-check that your API credential for Mijireh is set correctly in the payment settings page and has no extra spacing before or after it?


Lorenzo


Matt tuttle

January 2, 2015 at 7:15 am

Hi Lorenzo,

I just double checked and there are no extra spaces.
If I send you login credentials can you take a look to make sure I set thigns up correctly?


Tony

  • Support Staff

January 2, 2015 at 7:44 am

Hi Matt,

How are you securing your pages currently?

The error ‘Errors occurred communicating with Mijireh: Uh oh, something bad happened! We’ve been notified of the issue and will try to resolve it shortly..’ is from Mijireh themselves so you may need to contact them regarding this.


Matt tuttle

January 5, 2015 at 3:34 am

OK, I got a message from Mijireh stating that this is an EE issue. Can anyone assist me with this?


Tony

  • Support Staff

January 5, 2015 at 6:41 am

Hi Matt,

If you can send login details using this form:

https://eventespresso.com/send-login-details/

I’ll take a look over your Mijireh settings and see if I can see a reason for this.


Tony

  • Support Staff

January 5, 2015 at 12:07 pm

Hi Matt,

I can’t see any issues with the Mijireh settings.

Did Mijireh provide any details as to exactly what the issue with EE is?

One thing I did notice is that your theme (well actually some custom JS in custome.js within the theme) is throwing a fatal error. The problem with JavaScript is that once an error is thrown, now other JS after that error will load.

In your custom.js file you have:

$(document).ready(function(){

You’ll want to change that to:

jQuery(document).ready(function($){

Running jQuery in noConflict mode.

Can you try installing a plugin such as Theme Test Drive and activating one of the default themes (TwentyFourteen for example) using that. Theme test drive allows you to test other themes without altering the main theme in use on the site for your visitors.

Then retest a registration, does the same happen?


Matt tuttle

January 6, 2015 at 4:19 am

Hi Tony,

Just tested Theme Test Drive with 2014 and the same connection error occurs. What else can I try?

Does this part of the error message help?
EED_Single_Page_Checkout – _process_finalize_registration – 1760


Tony

  • Support Staff

January 6, 2015 at 4:49 am

I’d like to try our Mijireh test account and see if that works.

I’d change the account or ours, make a test registration and then input your key once again, would that be ok?


Matt tuttle

January 6, 2015 at 4:50 am

That would be great! Please do.


Tony

  • Support Staff

January 6, 2015 at 5:51 am

I tested our account and found the same issue.

I’d just like to point out this is not an issue with EE itself, if it was, anyone using 4.4.8 would not be able to connect to Mijireh, all of my test sites can.

I did see one issue with the site setup and SSL, you have your EE pages secured but not your admin, with EE pages secured you need to also secure the Admin so that the front-end can communicate with the admin. I have done this within WP HTTPS using the ‘Force SSL Administration’ checkbox.

‘Something’ is either blocking or interfering with the communication between your server and Mijireh, this could be a plugin, a theme function, custom function etc.

This error:

Does this part of the error message help?
EED_Single_Page_Checkout – _process_finalize_registration – 1760

Does not help unfortunately.

Can you enable WP_Debug on the site?

We can then try another registration and see if any other useful errors are being thrown.


Matt tuttle

January 6, 2015 at 6:16 am

Debug is enabled.


Matt tuttle

January 6, 2015 at 6:27 am

I’m getting a new error now:
This registration step could not be completed. Please refresh the page and try again.


Tony

  • Support Staff

January 6, 2015 at 6:45 am

Hmm, ok. Due to the notices being thrown by the plugins you have active that will happen the notices are throwing the ajax requests off.

In that case in order to trouble shoot this you’ll need to disabled the plugins that are active on the site (except EE) and retry.

Currently notices are being thrown by the Slide Deck and Browser Specific CSS plugins. Although there may be others.

Do you have a development copy of the site on another server? Or on localhost?

I would advise copying the site to a dev server (or locally) so you can troubleshoot this there and then make the necessary changes to the live site when the cause is found.

One of the easiest methods to do this is using the Duplicator plugin.

You can also do this on the live site (although not recommended), visitors will notice the changes as you work. If you prefer to do this I would highly recommend creating a full site backup (all files and the database) before doing so.


Matt tuttle

January 6, 2015 at 9:46 am

Ok, I just received a new error:

Errors communicating with Mijireh: Operation timed out after 5001 milliseconds with 0 bytes received


Lorenzo Orlando Caum

  • Support Staff

January 6, 2015 at 11:21 am

Hi, it looks like its timing out after about 5 seconds.

Does your host have a firewall in use on your site?

We had an issue last year where a web host was blocking the servers for PayPal Pro. While the API credentials were valid, it timed out and could not connect.


Lorenzo


Tony

  • Support Staff

January 6, 2015 at 12:59 pm

Also check with your host what the CURL timeout is set to.

It looks like its set to 5 seconds, this may need to be increased.

You could try following this post:

http://fatlab.com/blog/2009/08/12/how-to-fix-wp-http-error-name-lookup-timed-out/

To increase the timeout limit and see if that makes any difference.


Matt tuttle

January 7, 2015 at 5:05 am

Tony,

Do you know what port needs to be open for the Mijireh gateway?


Tony

  • Support Staff

January 7, 2015 at 1:04 pm

I checked with our developers on this.

EE communicates with Mijireh using wp_remote_post() over HTTPS, this by default uses port 443 although as your site is secured, this seems to be working anyway.

I think this error:

Errors communicating with Mijireh: Operation timed out after 5001 milliseconds with 0 bytes received

May a red herring here.

How did you get to that error?

In your previous error shown here http://pkug.org/wp-content/uploads/2014/12/ee-error.jpg the text after “Errors occurred communicating with Mijireh:” is actually the response from Mijireh, so the connection is making it through.

The support post ‘Errors occurred communicating with Mijireh’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 4 years, 11 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!