Support

Home Forums Event Espresso Premium Error Messages when purchasing + adding

Error Messages when purchasing + adding

Posted: January 2, 2013 at 9:48 am


irobinson

January 2, 2013 at 9:48 am

Hello,

It was brough tto my attention today that we have some random error messages apear on the ticket purchasing page, and also when adding a new event in the back end. As far as i know we have not updated since the last time you guys helped us out.

When purchasing a ticket, at the top you see these errors:
Eg: http://rampworx.com/event-registration/?ee=46

> Error: Warning: Missing argument 2 for wpdb::prepare(), called in /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/templates/registration_page.php on line 81 and defined in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990

When adding an event we get the following after submitting:

> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 354 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990
>
> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 363 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990
>
> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 376 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990
>
> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 389 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990
>
> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 396 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990
>
> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 423 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990
>
> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 439 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990
>
> Warning: Missing argument 2 for wpdb::prepare(), called in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-content/plugins/event-espresso
> new/includes/event-management/update_event.php on line 463 and defined
> in
> /nfs/c04/h02/mnt/58530/domains/rampworx.com/html/v4/wp-includes/wp-db.php
> on line 990

Help?


Jonathan Wilson

January 2, 2013 at 10:43 am

Hello,

It looks like you may still be on an older version. We recently updated to accommodate for WP 3.5 changes. Did you update to WordPress 3.5? If so, you need to be sure you are on Event Espresso 3.1.29.1.

Let us know if you are still having issues after the update.


irobinson

January 2, 2013 at 11:19 am

John, i love you.
Thanks


Jonathan Wilson

January 4, 2013 at 3:36 pm

Glad I could help. 🙂


kolaughlin

January 11, 2013 at 2:39 pm

Jonathan, we also get these errors. I have verified that we have WP 3.5 and the latest version of EE. Can these errors be coming from the fact that we have not yet set up the payment gateway? I was just testing events as I entered them, but saw this error code right away. Thank you very much.

Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/T/a/k/TakeNoteDes/html/op2012/wp-content/plugins/espresso-members.1.9/member_functions.php on line 182 and defined in /home/content/T/a/k/TakeNoteDes/html/op2012/wp-includes/wp-db.php on line 990

Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/T/a/k/TakeNoteDes/html/op2012/wp-content/plugins/espresso-members.1.9/member_functions.php on line 189 and defined in /home/content/T/a/k/TakeNoteDes/html/op2012/wp-includes/wp-db.php on line 990


Josh

  • Support Staff

January 11, 2013 at 2:44 pm

Hi there,

The errors indicate that you have an older version of the WP user integration/members add-on. When you update Event Espresso, all the add-ons need to be updated too. Please head over to your account page to download the latest versions of the add-ons.

The support post ‘Error Messages when purchasing + adding’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso