Support

Home Forums Event Espresso Premium empty ESPRESSO_PAYMENTS / Thanks page

empty ESPRESSO_PAYMENTS / Thanks page

Posted: August 29, 2012 at 2:48 am


Runemester

August 29, 2012 at 2:48 am

Hi,

Testing the payment flow I’ve come across an issue with a blank thanks-page following a completed payment process using the Quickpay gateway in sandbox mode. Everythin seems in working order, the payments are processed and can be verified in the backend. But the page containing the ESPRESSO_PAYMENTS shortcode – in my case the page outputs a url like this: http://esrum.runemester.dk/tak/?id=194&attendee_action=post_payment&form_action=payment&chronopay_callback=true&transaction_id=72b32a1f754ba1c09b3695e0cb6cde7f503dcbc7ab0911.20811055 and displays an empty page (no content generated in the source following the pagetitle) after succesfully completing a credit card payment with quickpay. I’m unsure whether this is an issue with the gateway and/or template? I’ve no real clue where to start looking? Any suggestions are very welcome?

Thanks
Rune


Chris Reynolds

  • Support Staff

August 29, 2012 at 10:59 am

Do you have any content in the thank you page other than the title and the shortcode?


Runemester

August 29, 2012 at 11:19 am

Hi Chris,
No other content what so ever. Just the shortcode.


Chris Reynolds

  • Support Staff

August 29, 2012 at 2:02 pm

Do you have anything in /wp-content/uploads/espresso/templates?


Runemester

August 29, 2012 at 3:14 pm

Yes, I’ve copied the templates from the plugin directory there for customization purposes. I assume the templates in question are the payment_page and payment_overview – both are there in original shape without any custom changes. I’m running version 3.1.26.P by the way.


Chris Reynolds

  • Support Staff

August 29, 2012 at 6:05 pm

If those two templates are the same as the originals, you shouldn’t need them in that folder. Delete any files in the templates directory that you haven’t modified.


Runemester

August 30, 2012 at 8:28 am

Hi Chris,

I removed all unmodified templates. I get a new error resonse this time:
Warning: require_once(/home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/gateways//quickpay_vars.php) [function.require-once]: failed to open stream: No such file or directory in /home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/includes/functions/main.php on line 1058

Fatal error: require_once() [function.require]: Failed opening required ‘/home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/gateways//quickpay_vars.php’ (include_path=’.:/php/includes:/usr/share/php’) in /home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/includes/functions/main.php on line 1058

Deactivating the Quickpay gateway I can get it working with eg. invoice payments. I suspect the problem has something to do with the gateway?


Runemester

September 1, 2012 at 5:07 am

Ok – I’ve been looking some more into this and it seems the Quickpay gateway exists in two different versions. I originally installed and used the module from Quickpay but it seems the gateway has been included in the latest release of Event-espresso (3.1.26.P). Comparing the gateway’s files in the two versions I can spot quite a few differences. Could this have something to do with the issues I’m experiencing – possible conflicts or?

The problem I originally described (empty thanks page) was caused when using the original module from Quickpay’s site on the previous version of EE. The second error (described in my post above) occurs when using the Quickpay module included in the latest EE-release.

I removed all the files from the original gateway, did a clean reinstall of EE and am now still stuck with the empty Thanks page. This is quite a hurdle as the existence of the Quickpay module was an important factor in choosing EE as the ticketing solution in the first place.

Any suggestions?


Chris Reynolds

  • Support Staff

September 4, 2012 at 2:00 pm

I originally installed and used the module from Quickpay but it seems the gateway has been included in the latest release of Event-espresso (3.1.26.P). Comparing the gateway’s files in the two versions I can spot quite a few differences. Could this have something to do with the issues I’m experiencing – possible conflicts or?

Yes. Don’t use the version from the Quickpay site. We’ve been maintaining the code within Event Espresso and I can’t vouch for the version that is on their website but I suspect that it was written for an older version of Event Espresso. If you have that version installed and/or anything in your /wp-content/uploads/espresso/gateways directory, remove it and use the version that comes with Event Espresso.


Runemester

September 4, 2012 at 2:10 pm

I figured. And did just that. I removed all files from wp-content/uploads/espresso. Including gateways. Reinstalled Event Espresso and activated Quickpay – using test settings available from their site. That’s when the fatal error as described above occurred (and persists):

Warning: require_once(/home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/gateways//quickpay_vars.php) [function.require-once]: failed to open stream: No such file or directory in /home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/includes/functions/main.php on line 1058

Fatal error: require_once() [function.require]: Failed opening required ‘/home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/gateways//quickpay_vars.php’ (include_path=’.:/php/includes:/usr/share/php’) in /home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/includes/functions/main.php on line 1058


Chris Reynolds

  • Support Staff

September 4, 2012 at 5:38 pm

Something’s not working right. Those paths are wrong. You’re getting: /home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/gateways//quickpay_vars.php and it should be /home/www/esrum.runemester.dk/wp-content/plugins/event-espresso/gateways/quickpay/quickpay_vars.php (you’re missing gateways in the path). I’m not sure why that part of the path would be missing, but if you don’t have any events set up, I’d recommend just dumping the Event Espresso db tables and doing a fresh install.

db tables


Runemester

September 5, 2012 at 11:46 am

Hi Chris,

Thanks! I went through with your suggestions. No change. Same error message. I then proceeded to delete the entire database and delete all files from the server. Did a fresh reinstall of WordPress and EE on a fresh database using default settings. I still get the same error. I’m running out of ideas here – as far as I can see this has to be either an error in EE or possibly from the server configuration.


Sidney Harrell

September 5, 2012 at 9:14 pm

Can you look in wp-options at the entry for event_espresso_active_gateways and post the option_value?


Sidney Harrell

September 5, 2012 at 9:59 pm

Actually, can you fill out the form here: http://eventespresso.com/contact/
and choose “I am sending login info as requested”
Can you send wp-admin and ftp login credentials, and make sure you put the link to this forum thread in the form.
Thanks.


Franz Skaaning

September 10, 2012 at 4:08 pm

I have a similar problem here: URL: /event-registration/?page_id=23&regevent_action=post_multi_attendee

Error: Warning: require_once() [function.require-once]: Unable to access /var/www/wp-content/plugins/event-espresso/gateways//quickpay_vars.php in /var/www/wp-content/plugins/event-espresso/includes/functions/main.php on line 1058

Did you solve the problem? How?

  • This reply was modified 7 years, 7 months ago by  Franz Skaaning. Reason: Subscribing


Runemester

September 11, 2012 at 1:50 am

Hi Franz,
It was a bug in the gateway files. To be more precise in gateways/quickpay/init.php and should be fixed in the 3.1.27.P release (scheduled this week?)
In the meantime have a look here – I copied the modified code (thanks to Sidney) from my working version of init.php. I hope this can help you out!


Franz Skaaning

September 11, 2012 at 1:57 pm

That did the trick. Thank you very much 🙂

The support post ‘empty ESPRESSO_PAYMENTS / Thanks page’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Franz Skaaning 7 years, 7 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!