Support

Emails

Posted: June 25, 2012 at 9:13 pm


rhughes

June 25, 2012 at 9:13 pm

I’m receiving an email with p tags, break tags, etc in the registration confirmations. I have not modified any of the email templates. This is the emails under the general tab. Please let me know if there is a setting, and thank you in advance.


Josh

  • Support Staff

June 26, 2012 at 7:36 am

Hi there,

Which version of WordPress and Event Espresso do you have installed? More recent versions of Event Espresso use the new editor API that was added to WordPress 3.3. So if you have an older version of Event Espresso, or an older version of WP, that could cause an issue with the emails.

It may be a plugin or the theme adding on its own functions to the editor as well.

I would suggest switching to html mode in the email, then make sure that any unnecessary markup gets removed, then save. If it’s an issue with a plugin, you might go with an alternative. I’ve tested the Tiny MCE Advanced plugin a bit and it doesn’t seem to create issues, keep in mind that any new plugin added into the mix should be fully tested. You can also rule out whether a theme conflict by switching the twentyeleven theme for the admin by using the theme test drive plugin.


rhughes

June 26, 2012 at 8:35 am

I’m using WP 3.3 and WP Event Registration 3.1.22.2.P. How do I switch to HTML mode? I was under the impression I was in HTML mode already. I’m receiving an email that looks like this….

Dear Ruth,
Good day to you and thank you for your registration. Details for your training class follow: Training Class: Â Barcoding Basics
Dates: Â July 9, 2012 -Â [last_date] Training Facility: Â CDG
Address: Â


rhughes

June 26, 2012 at 8:36 am

Well, the formatting issue is not showing what I received in the email. Is there somewhere I can send this email for review?


Josh

  • Support Staff

June 26, 2012 at 9:10 am

There should be tabs that let you switch between Visual and HTML mode in the email editor as illustrated below:

If these tabs are not appearing, it’s very likely there is a code being executed on the Event Espresso manage event emails screen from another plugin or the theme. Try deactivating other plugins and switching to another theme to see if this issue persists.

If you wrap the email content in code tags, it should display as received:
<code>email content</code>


rhughes

June 26, 2012 at 11:38 am

Okay, I have the two tabs and it’s set to HTML. When I save the emails, it automatically adds all of the HTML formatting (p tags, etc). I tried adding the tags but it ends up adding the HTML formatting outside of the tags. I've tried disabling all of the plugins as well. I can provide the website address if you need to test it. Nothing seems to help. Please keep in mind this is happening in the general settings, not email manager.


Josh

  • Support Staff

June 26, 2012 at 1:49 pm

Have you tried switching to a different theme? That would be the first thing I would check at this point.


rhughes

July 1, 2012 at 9:17 am

I tried switching to the twentyeleven theme and deactivating plugins. Is there a way to force the emails as plain-text? Any option I choose seems to add the body and html codes even if I disable wpautop. Please let me know, and thank you in advance.


rhughes

July 1, 2012 at 9:50 am

Figured it out. It appears that if I start by Pasting as Text within the email editor, I don’t have any issues. Thanks!

The support post ‘Emails’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  rhughes 7 years, 5 months ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!