Home Forums Event Espresso Premium email not sending

email not sending

Posted: June 26, 2018 at 11:04 am


June 26, 2018 at 11:04 am
sent email in the list on green, but nog receiving,
test email works

What could this be?


  • Support Staff

June 26, 2018 at 12:22 pm

The first thing to check is the spam folder.

You can install this plugin to verify whether the mail actually gets sent or not:

It’s important to discern whether the emails are actually not getting sent, or if they’re actually getting sent, but not received. If you find that they’re getting sent, can you check to see whether the emails are getting trapped in the spam folder?

In most cases, setting up a third party service to deliver email will resolve email delivery issues. The built-in mail servers (especially those that are used for shared hosting accounts) can be unreliable. We recommend using a service like Mandrill, Postmark, or any of the other services listed in our documentation for sending transactional email. More info here:

Alternatively, you could also use a gmail account and configure a plugin like the WP Mail SMTP plugin to send the emails.


June 28, 2018 at 9:17 am

Hi josh,
i installed wp mail logging

in the message table, a tool icon showed up
where the record says no recipient etc

so seems to work but not automatically

So when clicking the icon the record changed to;
“name recipient” “etc”

Then i clicked the double arrow aan the mail was send.
– the mail showed up in the log
– the mail also has been received


  • Support Staff

June 28, 2018 at 12:02 pm

Usually you’ll need to wait at least 5 minutes for the message to generate. However, if your site has wp_cron disabled then the email will not be sent. In which case, you go to Event Espresso > Messages > Message Settings and set the the option for emails to be sent on the same request, the Save.


June 28, 2018 at 4:02 pm

i’ve done that.
seems to work,
but on one event the “reservation approved” mail
is only send to the mail address positioned in the “to” section
– rest of event are doing fine
– can’t find any difference in settings though,
– “from” section has: [CO_EMAIL]


  • Support Staff

June 28, 2018 at 4:10 pm

I’m sorry, I don’t follow your question. Are you expecting the email to be sent to another email address in addition to what’s set in the To: field?


June 29, 2018 at 12:17 am

To *:
From *: [CO_EMAIL]
Subject *: Inschrijving bevestiging Kingsmen

above are the settings used like this in all “reservation approved” mails
– but in one of the there is no mail sent to the registrant, only to “”


  • Support Staff

June 29, 2018 at 2:17 am

That’s expected because you have told EE to send the email to a static email address, in this case, “”.

Are you editing the ‘Registrant’ context? (See HERE)

If so change the ‘To’ field to use [RECIPIENT_EMAIL]

Why have you set that static email address in the settings? If you want a copy of the registrant’s email to go to that email address, add it to the CC field.


July 11, 2018 at 12:37 am

thanks, it works,
is there somewhere within the documentation an explanation
for different of [RECIPIENT_EMAIL] and the other types?


  • Support Staff

July 11, 2018 at 3:35 am

is there somewhere within the documentation an explanation
for different of [RECIPIENT_EMAIL] and the other types?

In the message editor, click the help tab on the top right –

Inside that help section, there are various sections and one of those displays all shortcodes with a description of what they are for.

Is that what you are looking for?

The support post ‘email not sending’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 8 months, 2 weeks ago ago

Topic Tags


This topic is: not resolved
Do NOT follow this link or you will be banned from the site!