Support

Home Forums Event Espresso Premium EE4 registration form question settings not updated

EE4 registration form question settings not updated

Posted: November 17, 2017 at 11:39 am


soudeliit

November 17, 2017 at 11:39 am

Hello

Having problems to update the data of registration form question settings. Whenever I change the dropdown option or text field value of default fields, it will change back after saving. Success message is displayed. Added custom fields and values update well. Not able to track back when the issue started.

Tried default themes (2015, 2016) with all other plugins disabled. Deleted and re-installed the EE4 plugin without deleting all data. Changed the site language back to English US. It was in Estonian when installed. The EE4 core version was upgraded from EE4 decaf. Re-installed directly the core version.

EE 4.9.51.p
WordPress 4.8.3
PHP 7.1.11
MySQL 5.5.5 (MariaDB 10.1.28)
charset utf8mb4

Thanks


Josh

  • Support Staff

November 17, 2017 at 12:23 pm

Hi there,

This is actually expected if there’s an answer to that question saved in the database. If those were allowed to be changed it would break the answer data. If you need to update an existing question and change it to a different question type, then the way forward will be to make a new question, then remove the original question from the question group and replace it with the new question.


soudeliit

November 17, 2017 at 4:20 pm

Thanks for the tip, it’s good to keep in mind. However, the registration is not tested yet, so there should not be answers in database, I guess. Also, I made a test with completely new question and had the same problem to update the value immediately after first save, without closing. The values I had problems to update were Question Label (admin only), Maximum Allowed Response Size, Required Question, Required Text. Didn’t test others.

In some point I had the front-end registration form opened simultaneously in another window and I reloaded the page after making changes in back-end. Then, it’s possible I didn’t cancel the process from link, but just navigated to another page. Maybe it still saved something in database.

Not sure, but I may try to Reset Event Espresso Data and repeat the whole setup process. If you think the clean install may solve the problem, I will first Permanently Delete ALL Event Espresso Data. In other hand, if the issue appears again, we will need to find the cause and quick solution.


Tony

  • Support Staff

November 17, 2017 at 4:35 pm

So to confirm, if you go to Event Espresso -> Registration Forms -> Questions -> Add new question.

Then create a new question and provide custom values for each field, like so – http://take.ms/9iuS8

Then click save, it will revert back to default?


soudeliit

November 17, 2017 at 5:37 pm

The fresh new values are saved, but when to modify them at next step, they will revert to those saved in first step.


Tony

  • Support Staff

November 17, 2017 at 5:47 pm

That’s without any registrations being made on that question? Meaning the example I gave you above, you just saved the settings, then updated them again and saved once again but it shows the original?

So once created it shows – http://take.ms/qUbSD

Changing the values to just use the number 2 – http://take.ms/qUbSD

When you save it goes back to 1?


soudeliit

November 17, 2017 at 6:49 pm

Yes, that”s correct. No registration made. I just have only the very first try to create the question. 2 reverts to 1, not to the plugin default. If the default value were saved, it will revert to default value on next try.


soudeliit

November 19, 2017 at 5:01 pm

Just for your information, I made a screen recording video of the issue. Please find it from the main menu on the site the plugin is registered to.


soudeliit

November 20, 2017 at 11:45 am

By additional tests I performed the conclusion is that the EE4 version 4.9.51 has this issue with our configuration, which is sort of common configuration. I had the versions 4.9.47.decaf and 4.9.50.decaf from past tests and they work. Updating to 4.9.51 will start the nightmare again. I tested several different configurations before by downgrading the WordPress and PHP versions, changing the database collation, but no success.

I don’t know how to solve the situation generally, because we have pretty complex registration forms to be built and there is no much time available. Does it work with your configuration?


Josh

  • Support Staff

November 20, 2017 at 1:25 pm

What’s interesting about your video is actually shows a different issue: The Question Text and Required settings do not update, but the Answer options do update. This will be fixed in the next update of Event Espresso 4.


soudeliit

November 20, 2017 at 1:57 pm

Thanks. Probably I wasn’t able to describe the issue clearly enough as English isn’t my home language. Still in the first message I tried my best: “Whenever I change the dropdown option or text field value of default fields, it will change back after saving. Success message is displayed. Added custom fields and values update well.”

Can you provide us the version 4.9.50 of EE4 core (in case it works) to let me to work with our project? In case you can provide the fixed update in 12 hours, it would help too.


Josh

  • Support Staff

November 20, 2017 at 2:03 pm

You can download prior releases from Github:

https://github.com/eventespresso/event-espresso-core/releases


soudeliit

November 20, 2017 at 3:39 pm

Thanks, seems be working for now.

I have a business related question. Can we talk privately? No rush with that right now, as my local time is +9 hours comparing to yours and you may have other things to do. But later on it would be good to know when and how to contact you.


Josh

  • Support Staff

November 20, 2017 at 5:08 pm

You can contact the sales team and they’ll can answer any business-related questions. They have a secure contact form here and they’ll follow up with you via email.


Josh

  • Support Staff

November 21, 2017 at 9:19 am

Update: Event Espresso 4.9.51.p is released and includes a fix for the issue described earlier in this topic.


soudeliit

December 5, 2017 at 2:06 pm

Thanks for the infos. We have been very busy. I’ll update the plugin after the registrations to important event are finished. It’s just to avoid any possible risks.

Also, I haven’t had proper chance to contact your sales team, but I’ll do it soon. For now the topic is solved by downgrading the plugin, but I believe the new version solves it too. The case itself is unsolved yet, but as mentioned I’ll contact the sales team.

The support post ‘EE4 registration form question settings not updated’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  soudeliit 1 year, 11 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!