Support

Home Forums Event Espresso Premium EE4 Mobile Scanner App error message about permissions

EE4 Mobile Scanner App error message about permissions

Posted: March 10, 2017 at 1:41 am


Andreas

March 10, 2017 at 1:41 am

Hi,

Downloaded the Mobile Scanner App “Event Espresso 4”.
Can login with my WordPress administrator account but immediately after login I get error message stating the following:

ERROR
Sorry, you are not allowed to list events. Missing permissions:
ee_read_events,ee_read_others_events,ee_read_private_events

I have purchased a Support Ticket to get this fixed.

Kind regards,
Andreas


Tony

  • Support Staff

March 10, 2017 at 5:09 am

Hi Andreas,

We’ll need access to the server to troubleshoot this, your previous submission did not include FTP details.

Can you please re-submit the same form providing all of the requested details.


Andreas

March 10, 2017 at 7:40 am

Hi Tony!

I have now re-submitted the form with all details.
Hope you’ll be able to help me out!

~Andreas


Josh

  • Support Staff

March 10, 2017 at 10:04 am

Hi Andreas,

We are able to fix your site. The problem was the server wasn’t allowing the Authorization header to pass with the request. There’s an .htaccess file in the root level directory of your server that had this line of code:

RewriteRule ^index\.php$ - [L]

we changed that line of code to this:

RewriteRule ^index\.php$ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

and the app will log in correctly now.


Andreas

March 11, 2017 at 11:56 pm

Thank you very much Josh!

Today, Sunday the 12th of March, for some strange reason it started to appear another error message when trying to login using the Mobile Scanner App. It all worked fine when testing it on Friday.

No changes or installations were made, except I removed two TAX records under the Pricing menu.

The error message I now recieve is:

Error Occurred

The server was acting as a gateway or proxy and received an invalid response from the upstream server.

Found some other posts about this, but I did not want to follow the instrucitons as it has worked and suddenly did not.

Kind regards,
Andreas


Josh

  • Support Staff

March 13, 2017 at 11:19 am

Hi Andreas,

You should probably check the root level .htaccess file and make sure it has the changes outlined in the documentation:

https://eventespresso.com/wiki/ee4-event-apps/#troubleshooting


Andreas

March 13, 2017 at 11:46 am

You were right Josh!
I think (still needs further investigation on my behalf) it is a WordsPress plugin that rewrites my .htaccess file, thus making it not work after a while.

Thanks for great support Josh!

Kind regards,
Andreas

The support post ‘EE4 Mobile Scanner App error message about permissions’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Andreas 2 years, 7 months ago ago

Topic Tags

Tagged: , , ,

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!