Support

Home Forums Event Espresso Premium EE4: Changing answers to questions on 2nd registrant

EE4: Changing answers to questions on 2nd registrant

Posted: March 19, 2014 at 11:57 am


RJG

March 19, 2014 at 11:57 am

Hello,

I would like to know how to edit or update the answers provided.

I have a guest who bought two tickets and provided answers for the 2nd guest.

Then, messaged us and asked us to change the 2nd guest’ information to a new person’s infomration, so I changed the name and email.

However, it’s not even showing the other questions I created for this event and therefore I cannot edit them. however, when I click on the person who bought the two tickets, I can see all of their information and answers to the form.

I double checked the email and can see that the original attendee’s name shows all of their answers, but I cannot see them or edit them.

Any ideas on how I can do that please?

thanks.


Tony

  • Support Staff

March 19, 2014 at 1:42 pm

Hi Riffard,

This depends on how you have the events questions setup.

Did you require Personal Information/Addition Questions for additional attendees within the event?

Within the Event Editor look in the sidebar on the right. In this example, Primary attendees must enter Personal Information, additional attendees must enter Personal & Address Information. http://take.ms/owwSV


RJG

March 19, 2014 at 1:48 pm

Hello Tony,

I require them to answer these questions. The additional attendees answered the question. All i was trying to do was edit the name, email and the answer to one of the questions, so when I clicked on the former attendee’s name and changed it to the new one, updated the email, scrolled down, there were no questions at all.

So I checked the confirmation email that is sent to me automatically with their info and I can see the answers provided by the original attendee.


Tony

  • Support Staff

March 19, 2014 at 1:59 pm

Testing this locally works fine. I placed some registrations, opened up one of the additional attendees (within the Registration list), clicked ‘Edit this Registrant’, edited the Name and email and then updated.

Then Re-open the registration under the new name and can edit the questions.

Are those the steps you took?

Can you tell me which version of EE4 are you currently running please?

You can find this under Dashboard -> Plugins. Under Event Espresso you’ll find a version number.


RJG

March 19, 2014 at 2:03 pm

yes, those are the steps I took.

I am using version 4.1.9.1


Tony

  • Support Staff

March 20, 2014 at 4:34 am

Would it be possible for me to take a look?

If so could you send temporary log in details and some details of which registration using this form please:

https://eventespresso.com/send-login-details/


RJG

March 20, 2014 at 7:42 am

Hello Tony,

I sent you the info.

The attendee is Victoria.


Tony

  • Support Staff

March 21, 2014 at 5:15 am

Hi Riffard,

Thank you for sending me the log-in details.

I have taken a look at the registration for Victoria and can confirm what you are seeing on your site, however this is not due changing the registrant details.

If you view one of your other Multi Attendee Registrations you’ll find the custom questions are also not saving for those. Unfortunately I can not reproduce this locally but suspect this is either a plugin or theme conflict.

One thing I did notice is the site is running a caching plugin (W3 Total Cache) and is caching Event Espresso pages. This may be causing issues so I would first recommend adding all Event Espresso pages to be excluded from caching. With W3 Total Cache you do this by going to ‘Performance -> Page Cache’ within there you will find ‘Never cache the following pages:’ within that field add:

/events/
/registration-checkout/
/registration-cancelled/
/thank-you/
/transactions/

Those are the default pages for Event Espresso 4. If you have modified these you will need to put the relevant modified page also (it would appear you have not)

Then save the settings and purge (delete) the cache.

Then run through a test registration with multiple attendees. Do the additional attendee question now save?


RJG

March 21, 2014 at 11:40 am

Hello Tony,

thank you for taking a look at it.

I can’t see the page which would allow me to exclude these things. I went to the plugin, this isn’t an option. Do you mind doing it you think that will ehlp?

Second thing is, is there anyway to add this info for existing guests where it wasn’t saved? Why wasn’t it saved? Since the email captured it. Is this lost forever? This would seem useful to be able to add these things.


Dean

March 24, 2014 at 2:41 am

Hi,

The plugin will provide a main menu called Performance. Then click the submenu called Page cache – screenshot http://take.ms/NTooG

Then scroll down until you find a section called Never cache the following pages. Here you can add in the pages not to cache – http://take.ms/OAt5L

If the data didn’t save then it is probable that it is lost and will need to be added in manually. You can do this by editing each attendee in the Registrations page.

Why isn’t it saving? That is unclear. Once the cache issue is resolved (and the cache has been cleared), you can test to see if the issue persists. If it does we can look into it further.


RJG

March 24, 2014 at 5:11 am

Hello Dean& Tony,

the option to purge the cache is grayed out. I don’t have that option or i can’t select it. Does that mean that the plugin is enabled but it is not caching (sp?)? More importantly does it mean that this isn’t the issue.

I also don’t have the option of editing registration details even under registration.

sidenote: I couldn’t see the page cache because I have the Ozh’s admin drop down menu


Tony

  • Support Staff

March 24, 2014 at 6:53 am

the option to purge the cache is grayed out. I donโ€™t have that option or i canโ€™t select it. Does that mean that the plugin is enabled but it is not caching (sp?)? More importantly does it mean that this isnโ€™t the issue.

This means it is not actively caching currently, but caching can cause unexpected results so we can not rule it out 100%.

It appears the only caching you have active is Browser Caching. You could try disabling that. (Performance -> General Settings. Find Browser Caching and un-tick the checkbox, then save)

Also I would recommend disabling the Custom Template Add-on as it is not compatible with Event Espresso 4.

Personally I would recommend using a plugin such as ‘Duplicator‘ to clone the site locally, then run some registrations locally to see if you get the same results. If so then try a full troubleshoot by disabling all Non-EE plugins and re-run a registration to see if the details are saved (again locally), if so re-activate the plugins one by one to see which one causes the conflict.

Something that comes to mind is that recently we have been noticing WordPress SEO has had quite a few conflicts with other plugins since there last major update, we have not notice this particular issue before, but maybe try temporarily disabling that plugin and run a registration.

As we can’t reproduce this locally we’ll need your help in narrowing this down as much as we can ๐Ÿ™‚


RJG

March 24, 2014 at 9:01 pm

I had disabled all of my plugins and people have registered and nothing is being saved.

Could you login and again and take a look again please?

Also, should I have the ability to add info if someone had not responded to my questions? It’s one thing that the info isn’t be added but I cannot even add it afterward…


Tony

  • Support Staff

March 25, 2014 at 1:00 pm

Hi Riffard,

We did a little digging into this and found a bug within EE4 when using the same questions in 2 questions groups (in both Primary and Additional attendees), which will need to be addressed and we now have a ticket for a future version.

The fix for yourself in the meantime is to simply change your Additional Attendee Questions from this: http://take.ms/3WLY0

To this: http://take.ms/Filtq

As you have the questions within each Group this should not make any difference other than showing the Name and description of the question group.

Once that has been set, update the event and view one of the previous registrations, you should see that attendee’s answers and be able to edit them.


RJG

March 25, 2014 at 1:41 pm

Hello Tony,

thank you for troubleshooting it and offering a solution. You guys are really excellent with your support. I am very impressed and pleased with this plugin and the overall support.

I am trying to do it right now and it’s saying that you have the event locked. Are you still working on it or may I take over?


Tony

  • Support Staff

March 25, 2014 at 2:45 pm

I do apologize, I had logged in to take the snapshots above.

I’m assuming you have already done so, but I’m not working on the event and you can take it over by all means.

Thank you for the feedback, I’m glad your happy with both Event Espresso and our support ๐Ÿ™‚


RJG

March 25, 2014 at 3:37 pm

No worries. Thanks again for your help. I’ll go ahead and delete the attendees and user account created. Thanks for creating a ticket.

The support post ‘EE4: Changing answers to questions on 2nd registrant’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  RJG 5 years, 8 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!