Support

Home Forums Event Espresso Premium EE4 and Authorize.net Not Connecting

EE4 and Authorize.net Not Connecting

Posted: August 4, 2014 at 6:48 pm


Karen Richardson

August 4, 2014 at 6:48 pm

Wordpress version: WordPress 3.9.1 running Iced Mocha theme.
EE version: 4.2.5.p
New installation
http://events.vstereg.org

I am simply unable to get EE to connect with Authorize.net. I have generated API Login IDs and transaction keys, deactivated and reactived the AIM payment module and tried connecting to the developer server. Nothing seems to work. My payments are declined by EE because they aren’t even getting to authorize.net. There are no suspicious transactions or unsettled transactions in authorize. I have successfully used authorize.net SIM to run a shopping cart for years and also to connect through my website. Any ideas? I’ve trolled the forums but don’t seem to find my particular problem. It seems pretty simple so I’m clearly missing something.


Karen Richardson

August 4, 2014 at 7:04 pm

A quick follow up: it is really frustrating that none of the links on this page seem to work at all: http://eventespresso.com/wiki/payment-settings/


Karen Richardson

August 4, 2014 at 8:04 pm

Update: we were able to get the sandbox server working. But payment is still declined when we use our real login and transaction key and do a test payment.


Lorenzo Orlando Caum

  • Support Staff

August 4, 2014 at 10:51 pm

Hi, is this a new Authorizenet account?

If so, there may be some fields that are set to required that Event Espresso does not use — for example company name.

Please also double-check that there is no extra white space before and after your credentials in the payment methods page.


Lorenzo


Karen Richardson

August 5, 2014 at 8:39 am

Thanks for the quick reply. This is an existing account but there may be some field that are required. We’ve only ever connected directly to Authorize.net rather than doing this kind of onsite form so it wouldn’t be an issue so I’ll check on the required fields. I did turn on the CCV filter that we had not been using before since that’s required on the Event Espresso form.

I have checked the white spaces each time I put in the numbers.

I’m going to start from scratch today with a new login and transaction key. There was a forum post with this similar problem but for the life of me I can’t find it now. I don’t think it was ever resolved from May of this year.


Karen Richardson

August 5, 2014 at 8:59 am

THANK YOU! The stars aligned and it works! At your suggestion, I turned off company and made sure the CCV filter was on and required. At my webmaster’s suggestion, I made sure test mode was turned on correctly in authorize.net. And, my test transaction to the live server worked.

The support post ‘EE4 and Authorize.net Not Connecting’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Karen Richardson 5 years, 3 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.