Support

Home Forums Event Espresso Premium EE3 Payment Gateway not working with Authorize.net

EE3 Payment Gateway not working with Authorize.net

Posted: July 17, 2014 at 4:59 pm


Lisa

July 17, 2014 at 4:59 pm

Hello,
Please help. I have been trying to figure this issue out through forums but can’t find anything.
We have a golf tournament where we need to register individuals and 4somes $90-$10 discount, register sponsored players $90, and register hole sponsorship at $400, $300 and $200.
My issue is that when go through the payment processing, the money is not correct when it gets to Authorize.net. They say that the issue is with Event Espresso and not them. We had a tournament last year and didn’t have any problems with it, now nothing seems to work. We are a non-profit organization helping injured veterans and can’t really afford to hire someone to look at it, so any help will be greatly appreciated.

The page for checkout is:
http://www.patriotshonor.org/2gt/

Thanks,
Lisa


Lorenzo Orlando Caum

  • Support Staff

July 17, 2014 at 8:01 pm

Hi Lisa,

Could you provide additional information:

First, are any payments being processed and being received to your Authorizenet merchant account?

If they are but the amounts are incorrect, then please share a link to an event and also provide a specific example:

For example, the cost is $50 but we are receiving $45.

Thanks.


Lorenzo


Lisa

July 17, 2014 at 9:28 pm

Hello Orlando,
Below is the link to the event:
http://www.patriotshonor.org/2gt/

For the registration of the players, it cost $90 but there is a current discount of $10, which works fine. But when I submit to pay, authorize.net shows $90 instead of $80

For the hole sponsorship, there are 3 different prices, $400, $300, and $200. When an amount is changed from $400 to $200 and submit to pay, the amount stays on $400 in authorize.net

Very frustrating.


Dean

July 18, 2014 at 3:09 am

Hi Lisa,

I ran a couple of tests on your site, and everything in the code looked ok (as in it was passing the $80 amount and $200 of the events I tested). However I could not access Authorize.net due to an error.

Have you removed or changed the settings in the gateway?


Lisa

July 18, 2014 at 12:55 pm

Yes, when it started not working I got a new key from Authorize.net because I was getting an error:

The following errors have occurred.
(14) The referrer, relay response or receipt link URL is invalid.

but I set it in the payment gateway and it still does it. Nothing else has changed and Authorize.net says it an issue with event espresso.

Yikes


Josh

  • Support Staff

July 18, 2014 at 1:15 pm

Hi Lisa,

It would be so helpful if they knew more to say it’s an issue with Event Espresso wouldn’t it?

Can you log into your Authorize.net account and make sure that the following URL’s are listed as relay response URL’s:

http://www.patriotshonor.org/?page_id=1259
http://www.patriotshonor.org/thank-you/


Lisa

July 19, 2014 at 11:57 am

Yes Josh, those are my links. Authorize.net is no help at all. 🙁


Lorenzo Orlando Caum

  • Support Staff

July 19, 2014 at 4:31 pm

Hi Lisa,

I tried to take a look at the pricing issue but it looks like there are some issues with the account settings.

Could you please double-check your account credentials once more?

http://eventespresso.com/wiki/payment-settings/#SIM

Authorizenet SIM needs an API Login ID and Transaction Key. The API login ID is different than your merchant login.

Please also regenerate a new transaction key and update that in the Authorizenet SIM settings page for Event Espresso.

Also, be careful of extra spacing when copying and pasting your Authorizenet information.

Let us know if anything changes after checking the credentials. Thanks.


Lorenzo


Lisa

July 20, 2014 at 3:44 pm

Hello Lorenzo, I have done what you asked and reviewed the info. I created a new key and entered it all in. Now I get a new error:

The following errors have occurred.
(13) The merchant login ID or password is invalid or the account is inactive.

Once again, Authorize.net says everything is fine on their end.
So frustrated! But I appreciate all the help.


Tony

  • Support Staff

July 21, 2014 at 7:51 am

Hi Lisa,

It appears there is some whitespace at the end of your login ID.

Could you please re-check all the fields within the AIM settings an ensure there is no whitespace (spaces) at the beginning or end of each field?


Lorenzo Orlando Caum

  • Support Staff

July 21, 2014 at 7:56 am

Hi Lisa,

Authorizenet should be able to see the failed attempts on the API login ID.

Are you currently in live mode or in test mode on this account?


Lorenzo


Lisa

July 21, 2014 at 3:50 pm

I’ve check the fields for any white spaces. I also spoke with authorize.net again this morning and they had me take out the response url altogether and it worked. BUT I’ve tried to re-enter the response url from EE and it still doesn’t work. Only works without a url. Is that ok to keep it empty?


Lorenzo Orlando Caum

  • Support Staff

July 21, 2014 at 6:18 pm

When the field is left blank, is the attendee record updated so that its marked as complete (green)?


Lorenzo


Lisa

July 21, 2014 at 6:56 pm

yes Lorenzo?


Lisa

July 21, 2014 at 6:58 pm

I turned on the test mode for authorize.net so you can see the follow thru.


Josh

  • Support Staff

July 22, 2014 at 2:46 pm

Hi Lisa,

In test mode it should work okay if there isn’t a relay response configured. I think what Lorenzo was asking about was whether the Payment status was updating when you return to the Thank You page after payment, or is the Payment status showing an incomplete payment?


Lisa

July 22, 2014 at 4:44 pm

Hello Guys,
It is working now but I have to get a relay response configured. You are right, the payment status is not updating. I found the issue, I think.

My thank you page’s short link is:
http://www.patriotshonor.org/?p=1259

BUT in my payment gateway it says:
http://www.patriotshonor.org/?page_id=1259

The payment gateway does not let me correct it. Do I need to go into the editor to change it? If so where?
It is like the ee payment gateway is not talking to the ee thank you page.
Does this make sense?
Thanks,
Lisa


Josh

  • Support Staff

July 23, 2014 at 1:48 pm

Hi Lisa,

Are you referring to the Event Espresso Payment gateway settings when you asked:

The payment gateway does not let me correct it. Do I need to go into the editor to change it? If so where?

If so, the answer is no. The Thank You page is set via the Event Espresso > General Settings under Page settings. In Event Espresso 3 the Auto Return URL (Thank You and Return Payment page) needs to have the [ESPRESSO_PAYMENTS] shortcode on it. It looks like this is set up correctly on your website.

In addition to that, in your Authorize.net account a relay response URL needs to be set in order to everything to work properly. You can add both of these URLs to the relay response URL settings:

http://www.patriotshonor.org/thank-you/

and

http://www.patriotshonor.org/?page_id=1259

You can even add the shortlink ( http://www.patriotshonor.org/?p=1259 ) there if you’d like, but you’ll notice that the shortlink gets redirected to /thank-you/.

Do you see how both of the links you posted both redirect to the thank you page? I mentioned this before, the Authorize.net relay response URL needs to be set to the page that matches the Thank You page on your site.

I’d suggest adding both of theses

http://www.patriotshonor.org/thank-you/


Lisa

July 24, 2014 at 12:50 pm

Okay, I’ve added the urls to authorize.net but I still get an error that says:

The following errors have occurred.
(14) The referrer, relay response or receipt link URL is invalid.

The Thank You page has the correct verbiage. Do I need to change it in the code?
Thanks guys for helping me out. I guess I might have to take payment another way?


Lisa

July 24, 2014 at 12:53 pm

This is what my authorize.net url has:
/Users/lisaharris/Desktop/Screen Shot 2014-07-24 at 11.51.34 AM.png

And what EE payment says:
/Users/lisaharris/Desktop/Screen Shot 2014-07-24 at 11.53.59 AM.png


Lorenzo Orlando Caum

  • Support Staff

July 24, 2014 at 1:22 pm

Hi, could you upload those images to your WordPress Media area and then link to them here?

Alternatively, please email those images to the address below:

support [at] eventespresso.com

Be sure to include a link to this support post in the email.


Lorenzo


Lisa

July 24, 2014 at 2:18 pm

http://www.patriotshonor.org/?p=2081
http://www.patriotshonor.org/?p=2082

Did I do this right?


Lorenzo Orlando Caum

  • Support Staff

July 24, 2014 at 3:20 pm

Hi Lisa,

We were able to view the images, thank you. You can go ahead and delete them from WP Media.

There is no default set for the relay option. Could you remove the thank you page (last URL) and edit the default option and add the thank you URL to that option?


Lorenzo


Lisa

July 24, 2014 at 4:05 pm

HI Lorenzo, did as you said and still had the same error 14. Is there something else I can send you to see if my settings are ok?
When I don’t have any url entered it works fine but authorize.net says its EE.
🙁


Lorenzo Orlando Caum

  • Support Staff

July 24, 2014 at 8:20 pm

Hi there,

Could you please create a temporary WordPress admin login so we can take a closer look at this issue?

Please share that temporary login through the secure link below:

https://eventespresso.com/send-login-details/

To prevent delays in troubleshooting, be sure to double check your information on the form before submitting.

The submit button for the form appears after you have answered “Yes” to the last question.

Thank you.


Lorenzo


Josh

  • Support Staff

July 25, 2014 at 7:38 am

Hi Lisa,

I found the cause of the breakage. In the EE Authnet payment settings, the Force HTTPS on Return URL checkbox was checked. What this does when checked is make the return/thank you page redirect to:

https://www.patriotshonor.org/?page_id=1259

instead of

http://www.patriotshonor.org/?page_id=1259

The s after http is a very important distinction. It’s important because:

1) You don’t have an SSL certificate installed for your domain, so https will not work.

2) Even if you did have an SSL certificate, and you might choose to add one, once the Force SSL box is checked, your relay response URL redirects to https. Authnet would then require you to update the Relay response url and add the s after http. When they check for the relay response URL, it’s an exact comparison.

So when https: is sent with the payment fields, and there isn’t a url that matches https in the relay response settings, Authnet throws the “(14) The referrer, relay response or receipt link URL is invalid.”


Lisa

July 25, 2014 at 12:49 pm

WOW! It works! I can’t believe it was something so simple. I’ve learned my lesson.
A big THANK YOU to all you guys for helping me out and being patient with this beginner. Lorenzo and Josh you guys rule!!!

Thanks again,
Lisa

The support post ‘EE3 Payment Gateway not working with Authorize.net’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Lisa 5 years, 3 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.