Support

Home Forums Event Espresso Premium EE 3.1.25 Auto-update did not decrement WP plugin update number

EE 3.1.25 Auto-update did not decrement WP plugin update number

Posted: July 21, 2012 at 4:30 pm


Roger

July 21, 2012 at 4:30 pm

I just used the EE auto-update to update from 3.1.24.P to 3.1.25.P. When I did so, the WordPress admin display for number of plugins available to be updated did not decrement by 1. It remained at the same value it was before the EE update.

I tried logging out of the WP admin and logging back in, thinking it might refresh the count, but that does not fix the issue. I have counted (twice) the number of plugins for which auto-updates are available, and it differs from the displayed number by exactly 1. Prior to the EE update, the displayed number was correct; now, it is too high by 1.


Chris Reynolds

  • Support Staff

July 21, 2012 at 4:33 pm

This has been reported by someone else as well. I’m not sure what’s up with that as I’m not seeing it on my install but I will have our developer who is working on the update engine take a look.


Darren Ethier

August 3, 2012 at 8:18 am

Roger do you still see this happening?


Roger

August 3, 2012 at 8:32 am

Darren,
Yes, it’s still happening. I have performed several updates to other plugins since reporting this, but the displayed number of available updates always exceeds the true number by one.
For example, right now, I have only one plugin that needs updating (not EE), but the WP Dashboard top bar and Updates menu option both show “2” available updates.
Roger


Darren Ethier

August 3, 2012 at 8:44 am

Roger. Can you try re-saving your EE general options page (leave everything the same) and see if the number shows the right count?


Roger

August 3, 2012 at 8:53 am

Josh,
I just tried the re-saving operation. Clicked every “Save Options” button on the General Settings page and waited for confirmation in each case that the save operation had succeeded.
No change. Updates value is still too high by 1.
Roger


Roger

August 3, 2012 at 8:54 am

Also, after performing the operation, I logged out of WP and logged back in, thinking that might reset something… No luck. Still too high by 1.


Darren Ethier

August 3, 2012 at 11:55 am

Thanks for troubleshooting Roger. Just a few things to verify:

  1. Do you have any old versions of Event Espresso (or any addons) still installed but not activated?
  2. Do you have any plugins installed that are for Event Espresso but not released by us?
  3. Do you have any inactive addons for Event Espresso installed?


Roger

August 3, 2012 at 12:51 pm

Darren,
1. No… no old versions. I deleted all of them.
2. No… no plugins installed for EE that are not released by EE
3. Yes… I have five total EE plugins installed: EE 3.1.25.P, Calendar v2.0.3, Members Addon v1.9.4, Social Media v.1.1.3, and SSL/HTTPS v.1.0. The last two — Social Media and SSL/HTTPS — are INACTIVE… because I don’t use them.
Roger


Josh

  • Support Staff

August 3, 2012 at 12:52 pm

Can you try deleting the inactive add-ons?


Darren Ethier

August 3, 2012 at 12:54 pm

The social media addon has a new version (v.1.1.4) and it is possible that WordPress is picking up that it is a new version but the update script we use to hook in isn’t displaying the normal update strip there. If you delete the social media addon (since you’re not using it) does the number disappear? (you may need to save your EE general options page – the page with your site-license key on it – after as well)


Roger

August 3, 2012 at 12:57 pm

I’ll try that and let you know.


Roger

August 3, 2012 at 1:05 pm

  1. I deleted both add-ons, no change.
  2. Deleted my site license key and clicked “Save Options.” Then copied my license key back in and clicked “Save Options” again. Now, the update increment is STILL off by 1 (no change), but I’m also getting now (which I wasn’t getting before, a message at the top of the “General Settings” page that reads:
    “You have the correct Site License Key for Espresso Calendar but your current membership access only allows for automatic upgrades on one domain. Please log into your account to manage your Site License Keys or purchase a support license now.”

Yoiks. How can I get rid of the new message?


Darren Ethier

August 3, 2012 at 1:18 pm

Roger I’ve reset your license key. If you resave the options page it’ll reset on your end.


Roger

August 3, 2012 at 1:23 pm

That worked, thanks.
Still have the update increment problem, though. Sounds like it must be a puzzler on your end.


Darren Ethier

August 3, 2012 at 1:36 pm

yup it’s a puzzler. more because we can’t replicate.

One more thing to try and then I’ll have to revisit next week with you.

Try installing the social media addon (the old version) and then activate it, does it show 2 instead of 1? If it only shows one, then try updating and then you can deactivate and delete. If it shows 2 then at least I know that it’s not that plugin.

If that fixes it then I’ll know what happened. If it doesn’t then I’ve eliminated all the options we can check without me seeing what’s in your database (and we’ll revisit next week).


Roger

August 3, 2012 at 2:05 pm

Darren,
I could not reinstall Social Media v1.1.3, because I had deleted it per your earlier note and neglected to save a copy.
1. I tried installing and activating SM v1.1.4, but that did not solve the issue.
2. I deleted SM v1.1.4 then installed and activated v1.1.1 (which I happened to keep from my first EE install, I think). Still had the issue, and for some reason v1.1.1 did not indicate that it needed updating. So I deactivated and deleted it.
So as of now, I do not have any version of SM installed.
If you want me to try again with v1.1.3, please point me to a copy that I can install.
Thanks.


Chris Reynolds

  • Support Staff

August 3, 2012 at 3:19 pm

Roger —
Here’s a copy of espresso-social 1.1.3
http://new-ee-updates.s3.amazonaws.com/espresso-social-1.1.3.zip


Roger

August 3, 2012 at 3:32 pm

Chris,
That link doesn’t work for me. Here’s what I get:

<Code>AccessDenied</Code>
Access Denied
C992EC5902A17E35KrN9IZl01Z2peG5I5C8Qn6UD67M5Gchm4RRsNIc6MBOZQ87yZc6+gcTGjGNw87Xr


Chris Reynolds

  • Support Staff

August 3, 2012 at 6:30 pm

Hmm…okay try this one:
http://ee-updates.s3.amazonaws.com/espresso-social.1.1.3.zip


Roger

August 3, 2012 at 7:13 pm

Chris,
Thanks. That link worked.
However…
I installed and activated SM v1.1.3. Update list still off by one.
Updated SM v1.1.3 to v1.1.4. No change… list still off by one.
So it doesn’t seem to be that add-on.
I left SM v1.1.4 installed but deactivated it.
Roger

The support post ‘EE 3.1.25 Auto-update did not decrement WP plugin update number’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Roger 7 years ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!