Support

Home Forums Event Espresso Premium E-xact gateway "Return to your site" URL

E-xact gateway "Return to your site" URL

Posted: June 26, 2012 at 2:13 pm


sheathe

June 26, 2012 at 2:13 pm

Hi,
I’m running into an issue when in Debug mode for the E-xact payment gateway and I’m not sure if it is because of an incorrect setting.

In my E-xact developer account, there is an option as mentioned above called: “Return to your site” URL.

I have the value set to:

In the Event Espresso payment settings for E-xact, the relay response url shows as:

However, if I click on the little Help icon beside that field, it shows the following:
Relay Response URL:

When I do a test transaction, the E-xact dev account shows that it was a successful transaction, however, when I am returned to the Thank You page, all I see is:

Thank You!
Cheaters never win!

Any ideas what the problem could be?
Thanks,
Scott


sheathe

June 26, 2012 at 2:18 pm

Hi,
I just tested setting “Return to your site” URL to and I am still seeing:
—-
Thank You!
Cheaters never win!
—-

Is it possible this the expected behavior for debug mode?
Scott


Josh

  • Support Staff

June 26, 2012 at 2:27 pm

The first thing to check would be for any older gateway files in /wp-content/uploads/espresso/gateway files.

From there, check your permalink settings to be sure that that this isn’t getting redirected wrong.

The response/receipt URL should be the same as the Thank you page. So if the page that is set as the return/thank you page has an ID of 5, it should be:

http://www.example.com/wp/?page_id=5

Also verify that this page has the [ESPRESS0_PAYMENTS] shortcode on it.

  • This reply was modified 8 years, 5 months ago by  Josh. Reason: edited for clarity


sheathe

June 26, 2012 at 2:40 pm

Thank you Josh,
I’ve confirmed that the thank you page is page_id=5 and that it has the [ESPRESSO_PAYMENTS] shortcode on it.

I also removed all the custom template files from /wp-content/uploads/espresso/gateway, de-activated and re-activated the gateway, re-registered for an event, and still had the same result.

I’m wondering if it may be related to the configuration options in the E-xact admin area. Here is how I currently have the payment page set up from within E-xact:


Receipt Page Settings
Return Link Method (for receipt page)

[x] Automatic linking to the receipt page including result parameters using HTTP POST method (AUTO-POST)
[ ] Link to the receipt page including result parameters using HTTP POST method (POST)
[ ] Automatic linking to the receipt page including result parameters using HTTP GET method (AUTO-GET)
[ ] Link to the receipt page including result parameters using HTTP GET method (GET)
[ ] Link to the receipt page (LINK)
[ ] An HTTP Redirection to the receipt page (REDI)
~The type of link made back to merchant’s website

Receipt Link Text: [blank]
Receipt Link URL: [blank]
Reference Number Title (x_invoice_num): [blank]
~Leave blank if you don’t want x_invoice_num to display on the payment page.
Customer Reference Title (x_po_num): [blank]
~Leave blank if you don’t want x_po_num to display on the payment page.

Authorize.Net Protocol – Relay Response Settings
[X] Allow Relay Response
Relay Response URL: [http://www.mysite.com/wp/?type=exact&page_id=5]
Note: This value is required, if Relay Response is allowed.
[X] Allow HTTP Redirect to Merchant Website
When Relay Response is made, any redirect requests will send customer to merchant site
[ ] Validate Relay Response HTML
~Note: Tick this if you want to validate the HTML of the relay response

Authorize.Net Protocol – Silent Post Settings
Silent Post URL: [blank]
Note: Leave empty if silent response post is not desired.


Can you see anything in these settings that I should change?
Scott


sheathe

June 26, 2012 at 2:59 pm

Hi Josh,
Forgot to check the Permalinks. Here’s how it’s currently configured:

/%category%/%postname%/

Should it be something else?
Scott


Josh

  • Support Staff

June 26, 2012 at 3:13 pm

The permalinks look good, but the relay response URL should be:

http://www.example.com/wp/?page_id=5

It shouldn’t have the ‘type=exact’ in the URL


sheathe

June 26, 2012 at 3:31 pm

Okay, I’ve confirmed that the relay response URL does NOT have ‘type=exact’ in the URL and it is still behaving the same way.

Regarding the other options, I tried disabling the section called “Authorize.Net Protocol – Relay Response Settings” and the E-xact payment page stopped working entirely.

Do you have any other ideas?


Josh

  • Support Staff

June 26, 2012 at 4:11 pm

Do you have any customized payment page templates? Try loading up the stock payment page templates.

Also, try switching it to the page ID of 7.


Josh

  • Support Staff

June 26, 2012 at 4:49 pm

I dug up some more info on this: Use the home page for the Return to your site URL.


Josh

  • Support Staff

June 26, 2012 at 4:49 pm

I dug up some more info on this: Use the home page for the Return to your site URL.


sheathe

June 26, 2012 at 4:59 pm

Thanks Josh,
I’ve changed the “Return to your site URL” to the home page.

I changed the receipt url to page ID 7 and am still receiving the “Cheaters never win!” message.

I have tried both with my customized template pages installed, and also with my template pages totally removed and I have de-activated/re-activated the payment gateways any time I’ve removed/re-uploaded my custom gateway template pages.

I found references to “Cheaters never win!” in two places:
/gateways/process_payments.php file
and
/process-registration/payment_page.php

As a test, I customized the message in the process_payments.php file by adding random text on to the end of it. I ran another test transaction and my random text did not show up. So I’m thinking the message must be coming from the /process-registration/payment_page.php file.

Is it it possible that E-xact isn’t passing something back to the receipt page? Could it have to do with the Return Link Method in the E-xact options?


Josh

  • Support Staff

June 26, 2012 at 6:57 pm

It could be. I’ve opened up a ticket for one of the developers to look into this. The ‘cheaters never win’ message is from a security measure that we added a few versions ago. The e-xact gateway was tested as working when we added it in. Something else on our end, or the gateway API may have changed recently.


Josh

  • Support Staff

June 26, 2012 at 8:56 pm

Sidney committed this change to /gateways/exact/init.php:

line 11:
$_GET['registration_id'] = $temp_array[0];
change to:
$_REQUEST['registration_id'] = $temp_array[0];

This fix will be included with Event Espresso 3.1.25.P


sheathe

June 27, 2012 at 9:01 am

Thank you, that resolved the issue. This ticket can be closed now.

* For anyone else making changes to gateway template files, always remember to de-activate and re-activate the gateway from the payment settings page or the changes may not take effect.

The support post ‘E-xact gateway "Return to your site" URL’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  sheathe 8 years, 5 months ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!