Support

Home Forums Event Espresso Premium Divi Builder not working

Divi Builder not working

Posted: February 23, 2019 at 7:01 pm


ITMA Houston

February 23, 2019 at 7:01 pm

Hi there,

I’m using the Divi theme, which has a page builder that is capable to work with other plugins and CPTs. Unfortunately, it doesn’t work with Event Espresso. I searched your Forum and found this post: https://eventespresso.com/topic/divi-builder/. I followed the suggestion in here and increased the memory of my page to the recommended 256M, without any changes. My host is Siteground who allows me up to 768M, so that is also not the issue. How can I resolve this to use the Divi builder?

Thank you!


Tony

  • Support Staff

February 24, 2019 at 3:08 pm

Hi there,

When you say it doesn’t work, what is happening on the site?

Increasing the memory limit would help if your getting errors regarding the server’s memory being exhausted or white screens, but if you’re getting another error you’ll likely need a different fix.


ITMA Houston

February 25, 2019 at 12:13 pm

Hi Tony,

There is no indication that the memory is too low on my site. The link I posted also didn’t indicate that and that was the solution being presented. That’s the only reason why I tried it before contacting you.

According to your colleague answering that previous post, the Divi builder should be working with EE. What else could be the issue?

Thank you.


Josh

  • Support Staff

February 25, 2019 at 12:40 pm

Hi,

Can you please define what you mean by “not working”?


ITMA Houston

February 25, 2019 at 12:56 pm

I don’t have the option to activate the builder on the event pages.


Josh

  • Support Staff

February 25, 2019 at 1:19 pm

OK, thank you for clarifying. In Divi version 3.10, they added a system for enabling the Divi Builder on custom post types. This feature does not work as expected. What you can do instead is use this plugin to extend the Divi Page builder to Event Espresso post types.

If you have any other issues with using Divi or the Divi Builder on your site, please contact Elegant themes for support.


ITMA Houston

February 27, 2019 at 1:26 pm

Josh,

Divi support found some EE error messages (may or may not be related). Do you know what this is about?
[IMG]http://i67.tinypic.com/er0s43.png[/IMG]
(is this link working?)

Divi support is also wondering if EE is adding a CPT and what post do you provide? Did you (EE) have the chance to test the latest Divi and WordPress versions with EE4?

When you look at that error message – what makes me wonder is why the link says ‘event-espresso-decaf’ although I’m using the full version. I downloaded the core-reg plugin and tried to install it, but got an error message saying that the destination folder already exists, so the plugin installation failed. Don’t even know if it has anything to do with it? My plugin overview doesn’t indicate that I only have the decaf version running and my license key is active.

Pleased to hear.

The plugin you suggested was not updated in a year and isn’t tested with Gutenberg so I won’t install it.

Thanks for your assistance.


ITMA Houston

February 27, 2019 at 1:49 pm

Looks like the link isn’t working. Let me try another version:

http://i67.tinypic.com/er0s43.png


Josh

  • Support Staff

February 27, 2019 at 1:52 pm

Did you (EE) have the chance to test the latest Divi and WordPress versions with EE4?

No. I reached out to Elegant Themes and asked them for access to their private repository so I could test the current version of Divi. Someone replied back and asked for my Github account name. That was the last I heard from them. So no, I haven’t tested the latest version of Divi with Event Espresso. The reason I haven’t tested is because I don’t have access.

With regards to the error from the screenshot, those would not be related to the issue you’ve reported here.

Divi support is also wondering if EE is adding a CPT and what post do you provide?

Event Espresso adds the espresso_events post type (for events) and the espresso_venue post type (for venues).

When you look at that error message – what makes me wonder is why the link says ‘event-espresso-decaf’

The error message includes a file path of event-espresso-decaf because that site is using the decaf version that’s available to download from wordpress.org. The decaf version does not have all the features as the version you download from your account page on this website.


ITMA Houston

February 27, 2019 at 2:21 pm

Thanks, Josh. I’ll check with the Divi support on your first two points.

The decaf version does not have all the features as the version you download from your account page on this website.

Should I delete my EE plugin and install it new from your website download?


Josh

  • Support Staff

February 27, 2019 at 6:56 pm

No reason to, you don’t have the decaf version on your site. To be extra sure though, what’s the version number of Event Espresso that appears at the bottom of your site’s WP admin page?


ITMA Houston

February 27, 2019 at 6:59 pm

I’m on Version 4.9.78.p.


Josh

  • Support Staff

February 27, 2019 at 7:10 pm

The p at the end means it’s the version from eventespresso.com. The decaf version number ends with decaf instead of a p. So no need to reinstall Event Espresso.


ITMA Houston

February 27, 2019 at 7:10 pm

Great, thanks.


ITMA Houston

March 4, 2019 at 7:23 am

This reply has been marked as private.


Josh

  • Support Staff

March 4, 2019 at 7:32 am

Hi,

The folks at Elegant themes are welcome to download the latest version of EE4 from GitHub:

https://github.com/eventespresso/event-espresso-core

EE4 does use the register_post_type() function to register its post types.


ITMA Houston

March 4, 2019 at 7:37 am

Thanks, Josh. I passed it on.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  ITMA Houston 2 weeks, 1 day ago ago

Topic Tags

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!