Support

Home Forums Event Espresso Premium Database Error

Database Error

Posted: May 16, 2016 at 6:25 pm


Sean Firth

May 16, 2016 at 6:25 pm

This is teh error I am getting: “There were errors creating the Event Espresso database table and Event Espresso has been deactivated…..” the plugin was not actually deactivated so after setting WP_Debug to true (It said to do so in error) and it did nothing I deactivated EE and tried to reactivate it and now it looks really broken.

Here’s teh first from a whole page of errors “WordPress database error: [Unknown storage engine ‘InnoDB’]
SELECT COUNT(‘STA_ID’) FROM wp_esp_state”


Sean Firth

May 16, 2016 at 9:06 pm

Fatal error: Uncaught exception ‘EE_Error’ with message ‘WPDB Error: “Unknown storage engine ‘InnoDB'”‘ in /wp-content/plugins/event-espresso-core-reg/core/db_models/EEM_Base.model.php:1849 Stack trace: #0 /wp-content/plugins/event-espresso-core-reg/core/db_models/EEM_Base.model.php(850): EEM_Base->_do_wpdb_query(‘get_results’, Array) #1 /wp-content/plugins/event-espresso-core-reg/core/db_models/EEM_Base.model.php(748): EEM_Base->_get_all_wpdb_results(Array, ‘ARRAY_A’, NULL) #2 /wp-content/plugins/event-espresso-core-reg/core/db_models/EEM_Base.model.php(984): EEM_Base->get_all(Array) #3 /wp-content/plugins/event-espresso-core-reg/core/db_models/EEM_Payment_Method.model.php(196): EEM_Base->get_one(Array) #4 /wp-content/plugins/eea-stripe-gateway/EE_Stripe_Gateway.class.php(67): EEM_Payment_Method->get_one_of_type(‘Stripe_Onsite’) #5 /home/seanfi in /wp-content/plugins/event-espresso-core-reg/core/db_models/EEM_Base.model.php on line 1849


Tony

  • Support Staff

May 17, 2016 at 1:00 am

Hi Sean,

Is this a new install?

Unknown storage engine ‘InnoDB’ points to an issue with the server rather than EE, EE is attempting to read/write (in your errors it is reading) to tables within the database and the MySQL server is failing.

I recommend contacting your hosting provider and providing them with the above error.


Sean Firth

May 17, 2016 at 1:07 am

No, its an old istall thats been working fine. Looks like a corruption in my database so I have contacted my provider to hopefully fix it.

Thanks


Tony

  • Support Staff

May 17, 2016 at 2:09 am

You’re most welcome.

Please do let us know how you get on with this.

The support post ‘Database Error’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 3 years, 4 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!