Support

Home Forums Event Espresso Premium CyberSource Gateway Error Missing Fields

CyberSource Gateway Error Missing Fields

Posted: January 18, 2023 at 11:35 am


sobeit71

January 18, 2023 at 11:35 am

Hello, we switched to using the CyberSource payment gateway add-on and are getting declined payments for missing fields:

The request data did not pass the required fields check for this application: [bill_address1, bill_city, bill_country, customer_email, customer_lastname]

We created a $0.01 test event: https://georgeranchgolfacademy.com/camps/test/

The registration form includes all of the address fields to collect the missing information but it looks like the CyberSource gateway is not receiving them? We were using the Authorize.NET gateway before switching and there were no issues.

Note we are using the live production CyberSource keys and are awaiting for the bank to issue us a test account.

If possible we’d like to get this resolved by Friday Jan. 20th so we can start taking registrations for our upcoming events.

Thanks for your help.


Tony

  • Support Staff

January 18, 2023 at 5:20 pm

Hi there,

The CyberSource integration is an offsite integration which means we setup up the payment request to send the user to CyberSource for them to pay. We do not pass over the billing information with that payment method so you will need to include those within your Checkout form.

If you log into CyberSource and in the left navigation panel, choose Payment Configuration > Secure AcceptanceSettings.

Chose a profile and the General Setting pare appears.

Click Payment Form.

There you should be able to configure the form fields shown.


sobeit71

January 20, 2023 at 7:44 am

Thanks for letting us know. We’ll look into the CyberSource payment form settings.

Thanks for your help.

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso