Support

Home Forums Event Espresso Premium Custom Registration Approved Messages not being queued or sending

Custom Registration Approved Messages not being queued or sending

Posted: June 7, 2019 at 9:09 am


lisa burgess

June 7, 2019 at 9:09 am

Hi,

I have custom messages for my events for payment rec’d, payment declined, and registration approved. I set them inside of each event and all of them are working – except for the registration approved.

The send to email address is [RECIPIENT_EMAIL]

I’m not sure what’s going wrong – it looks as if they don’t even exist. There is no error since its not event attempting to send them.

Please help!

Lisa


Tony

  • Support Staff

June 7, 2019 at 9:17 am

Hi Lisa,

Can you add a screenshot of your custom Registration Message Approved template here so I can take a look?

https://eventespresso.com/wiki/troubleshooting-checklist/#screenshots


lisa burgess

June 7, 2019 at 9:48 am

This reply has been marked as private.


Josh

  • Support Staff

June 7, 2019 at 12:37 pm

Hi,

It looks like your screenshot requires permission to view. Can you change that to allow support staff to view it?


lisa burgess

June 7, 2019 at 1:09 pm

hi josh,
how about this?
https://cl.ly/dd2bd86bef4d

lisa


lisa burgess

June 7, 2019 at 1:12 pm

[update] I had someone who purchased 9 event registrations earlier in the day. the payment received message was sent but not the registration success. so I went into registrations and clicked “resend registration details” and then all 9 registration emails were sent. I can now see that in the message activity tab.

why do you think these were not automatically triggered?

Lisa


Josh

  • Support Staff

June 7, 2019 at 1:16 pm

It could be the reg. status isn’t set to approved at the moment when the messages are triggered. May I ask which payment method is in use?

Also, on the Event Espresso > Messages > Settings page there’s a setting for when to send messages, may I ask which one of the two options (send now or send later) is set there?


lisa burgess

June 7, 2019 at 1:21 pm

Hi Josh,
I don’t see the setting you are referring to. See screenshot. https://cl.ly/24019c8fd841

I am using Stripe.


Josh

  • Support Staff

June 7, 2019 at 1:36 pm

Right now “Generate and send all messages” is set to “On a separate request”. I can advise to change that to “On the same request”. If there are any issues with wp-cron on that site, changing that setting will help. You can also go to the Tools > Site Health page of your site to check if there’s an issue with wp-cron (or scheduled tasks).


lisa burgess

June 7, 2019 at 1:42 pm

ok thank you. i changed the setting to “on the same request”.

Was I missing something? in your previous reply you asked about two options: send now or send later? I don’t see either of those options.

-Lisa


Josh

  • Support Staff

June 7, 2019 at 1:46 pm

“Send on the same request” means the same thing as “send now”.


lisa burgess

June 7, 2019 at 1:47 pm

Ok thank you. I’ll monitor this to see if the registration confirmations auto-send on our next sale of registration tickets.

The support post ‘Custom Registration Approved Messages not being queued or sending’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  lisa burgess 10 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!