Support

Home Forums Event Espresso Premium Custom Message Template Recipients

Custom Message Template Recipients

Posted: September 3, 2014 at 12:37 am


Shari

September 3, 2014 at 12:37 am

I have been trying to create a custom message template for two particular events. I started by editing from the Edit Event page. Then I discovered they had been listed in the Messages Overview page (but it seemed a separate entry had been created each and everytime I saved from the Edit Event page). SO I figured that the reason my changes weren’t being emailed in my tests were because EE did not know which one to send! I’ve deleted all the duplicates, but it seems the problem may lie in which recipients are selected.

In this case, it lists “Recipients: Event Admin | Primary Registrant | Registrant”

But Primary Registrant is greyed out. Does this mean it is not selected for that template? How do I select it for that template?


Tony

  • Support Staff

September 3, 2014 at 5:20 am

Hi,

A single message type can have different content based on the context in which that message is used. For example the ‘Approved Registration’ message sent to the Event Admin, will likely contain different information than the ‘Approved Registration’ message sent to the Registrant.

When you edit a message from the event editor by default you will be editing the Event Admin context. So at that point you are editing the message that the Event Admin is sent. You can switch contexts using the dropdown to select another context and the ‘Switch Recipient’ button at the top of the editor, for more information have a look here:

http://eventespresso.com/wiki/ee4-message-contexts/

But Primary Registrant is greyed out. Does this mean it is not selected for that template? How do I select it for that template?

Depending on what you would like to achieve you may not need the Primary Recipient context active.

The ‘Primary Registrant’ is details of the first attendee that is entered, they are considered the Primary Attendee and is most likely the user that will be handling the payment (currently for the full transaction)

I’m assuming the message type you are editing has ‘Recipient’ active (not greyed out)? If so the Recipient message will be sent to all the attendees within that registration, if you want the Primary Attendee to receive a different message from all of the others (maybe containing some extra information) you can activate it by assigning a value to the ‘To’ field for that context.

So go to Event Espresso -> Messages. Find the message you wish to edit and click on the greyed out ‘Primary Recipient’ link. Here is an example – http://take.ms/YqT7T

You will now be within the editor for Message type you selected, within the ‘Primary Registrant’ context – http://take.ms/FDxRX

Notice you can see the current message & context at the top of the page. The ‘To’ field is currently empty (which de-activates that message context)

Within that field use the [PRIMARY_REGISTRANT_EMAIL] shortcode to send that message to only the Primary Registrant. Like so – http://take.ms/meHyq

Remember to save the message once you have finished editing.


Shari

September 3, 2014 at 5:58 pm

Thankyou. I was aware of the need to ensure I was editing the relevant recipient (although I was not clear about that in my post). It was setting the To: field that had escaped me. Also, there were multiple copies of the custom template being produced I think from editing it from the Edit Event page. But by deleting the duplicates, and setting the To: field, the custom messages are now sending out as required.

The support post ‘Custom Message Template Recipients’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Shari 5 years, 2 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.