Support

Home Forums Event Espresso Premium Custom Fields is different in WP 5

Custom Fields is different in WP 5

Posted: January 6, 2021 at 11:28 am


skillstat

January 6, 2021 at 11:28 am

We have been using WP Custom Fields in the Event Espresso events to add custom Infusionsoft/Keap IDs (please see screenshot https://www.dropbox.com/s/y4c32sfplihmpem/Screen%20Shot%202021-01-06%20at%2010.21.06%20AM.png?dl=0). However, on WP 5 we are no longer able to create and save these custom fields all at once. Each custom field has to be saved (by clicking “update” for the Event Espresso post) individually, which adds a lot of time. Is there any work around for this?


Tony

  • Support Staff

January 7, 2021 at 4:02 am

Hi there,

That doesn’t sound right, a quick test of this on one of my test sites.

Starting with no custom fields:
https://monosnap.com/file/OX6YCEaXYALlFr9aHfYZNJNVqgfGNq

Add 3 custom fields:
https://monosnap.com/file/2swCrGpvho3y2j1n7OGZLZYDDUQLf9

Add values:
https://monosnap.com/file/GaamlHC4AyVf9fBAuix8tyjeD9YO6O

Save the event (the values all save).

Update all custom field values:
https://monosnap.com/file/hi5ocU8FXx2sHSjj99Z4kBbBCcdO8h

Save (again they all save).

Looking at the screenshot you added, there is no update button on each individual custom field and the formatting is off.

If you open up Chrome Dev Tools (or similar) and look in the ‘console’ section of that when on the event editor, does it show any errors?


skillstat

January 7, 2021 at 11:35 pm

Here is what I see when I open Chrome Dev Tools and look in the console: https://www.dropbox.com/s/37prpxi1xo7fyl3/Screen%20Shot%202021-01-07%20at%206.58.48%20PM.png?dl=0


Tony

  • Support Staff

January 8, 2021 at 7:22 am

They don’t look related to this.

So the reason you’re having to update them individually is the ‘Add Custom Field’ field button isn’t showing, which you would normally click to add the field without updating the post. You would then see a ‘Delete’ and ‘Update’ button on each individual field that can be used without updating the post if needed.

Is the above screenshot from your live site or a development copy?

The site linked to your license has WP5.5.3 installed and is using EE 4.9.81, which was released May 28th 2019. So the first step I would recommend is updating Event Espresso to the latest version (which is currently 4.10.10) and check if you run into the same issue then.

The support post ‘Custom Fields is different in WP 5’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Tony 2 weeks, 3 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!