Support

Home Forums Event Espresso Premium CSV Download doesn't work on Chrome

CSV Download doesn't work on Chrome

Posted: February 15, 2017 at 4:14 am


2silda

February 15, 2017 at 4:14 am

I have strange error with latest update from EE4. If I try to download CSV report from registrations it successfully writes that file generated, but it doesn’t start to download it. It refreshes page and that’s it.

However everything is working with Safari on my Mac. Tried Chrome on Mac and Windows but it doesn’t work.

Is there something you can do?


Lorenzo Orlando Caum

  • Support Staff

February 15, 2017 at 5:18 am

Hello,

I had a look at the registrations csv report in Chrome (https://cl.ly/2q0I0F323F1m) on two sites this morning and I was able to get the report generated.

Are you using any add-ons or extensions in Google Chrome?

What happens if you temporarily deactivate other plugins on your site and try to get the registration csv report?


Lorenzo


2silda

February 17, 2017 at 12:57 am

Hi,
I don’t have any add-ons and extensions on my Chrome browser and so don’t another computer also. I tried to temporarily de-activate all plugins expect Event Espresso ones and still it didn’t work.


Josh

  • Support Staff

February 17, 2017 at 10:49 am

Hi there,

You can try the steps outlined here:

http://www.presentermedia.com/blog/2013/10/my-file-automatically-opens-instead-of-saving-with-chrome/


Giant Dwarf

February 17, 2017 at 9:13 pm

Thought I’d pass on that this exact same issue has started happening this week with our organisation, reports won’t download in Chrome, but will in Safari. We haven’t updated anything on our site, so I’m left wondering whether it might be linked to a Chrome auto-update?

The only solution I’ve been able to come up with is to create a completely seperate plugin that exports reports using the legacy CSV generator code.


Giant Dwarf

February 17, 2017 at 10:20 pm

Also, looks like this person might be having the same issue too.

https://eventespresso.com/topic/event-registration-csv-report-not-downloading/


Giant Dwarf

February 18, 2017 at 10:12 pm

After many, many hours of pouring over EE’s code I’ve resolved the issue we’ve been having with reports not downloading. It seems the callback which redirects to the registrations page after the report is generated fires instantly after the download redirect is called, cancelling the download in Chrome before it has a chance to even request the file, because obviously you can’t redirect a window to two url’s at once.

I managed to resolve this (at least until the next update) by modifying batch_file_runner_init.js so that the timeout of 2 seconds occurs inside the callback, rather than inside the ee_support_download_file function, which means the 2 second delay is actually honoured rather than being skipped. I haven’t got the patience to do any more digging into why exactly the callback is firing outside of the call in the download function, but you guys should probably look into that.


Giant Dwarf

February 18, 2017 at 10:30 pm

Bother, spoke too soon. While undoing some other changes I had made to narrow down the problem, I’ve noticed reports won’t download if I remove the 1 second sleep I’d added into the function batch_cleanup in EED_Batch.module.php so the issue may actually just be that the file gets deleted before Chrome begins the download. However just adding in the delay alone didn’t seem to fix the issue initially so I’m at a loss here.

Feel free to delete the previous comment. I’ll stop spamming this thread now and leave this to the experts!


2silda

February 20, 2017 at 6:44 am

Yes, as you can see the problem is more spreaded than only my site. EE developers, could you please fix this issue, it’s pretty hard to handle registrations that way.


Josh

  • Support Staff

February 20, 2017 at 10:45 am

@Giant Dwarf,

If you make the change logged here:

https://github.com/eventespresso/event-espresso-core/commit/9d4cf54600a25a46cec47a4d56b476de2297e7d6

Does it fix the issue you are having?


2silda

March 1, 2017 at 1:42 am

For me it already didn’t have extra “/” there.

Is there anything else we could try, because we really need data to be exported on different computers via CSV.


Josh

  • Support Staff

March 1, 2017 at 9:47 am

May I ask which version of Event Espresso 4 do you have installed right now?


2silda

March 1, 2017 at 10:20 am

I was on 4.9.30 and it didn’t work, then updated to 4.9.31 and still no luck. It definitely worked in beginning of January this year.


Josh

  • Support Staff

March 1, 2017 at 10:23 am

May I ask what other things have changed on your website since the beginning of January this year? New plugins, changes to the server, etc?


2silda

March 7, 2017 at 2:30 am

Hi, sorry for late answer, we are busy with events. Changes have not been made to the server, everything is same as it was before. Some plugins got updates, but there are only 2-3 of them and they definitely can’t affect the issue.

And I don’t believe there are issues by server, because everything works on Mac’s Safari, but won’t work on Chrome. There is something wrong in the code.


Josh

  • Support Staff

March 7, 2017 at 11:11 am

IF there is something wrong in the code, the CSV Download wouldn’t work in Chrome on any server, would it? We’re aware of a few sites that are having some trouble with downloading CSVs with Chrome, but the majority of sites running EE4 (including all of our testing sites) function correctly with Chrome.

So while I get that you don’t believe it’s an issue caused by another plugin or a server, that’s where we’re looking to investigate the cause of the issue.

The support post ‘CSV Download doesn't work on Chrome’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 2 years, 2 months ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!